summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2015-02-12 05:34:22 +0000
committerBrian Dolbec <dolsen@gentoo.org>2015-02-12 05:34:22 +0000
commit72942941090c6704a67cad618abc7b2ee83bd371 (patch)
tree73ed8e7fadc114bf6d4a8cb73f762681117792c7 /sys-apps
parentWhitespace (diff)
downloadgentoo-2-72942941090c6704a67cad618abc7b2ee83bd371.tar.gz
gentoo-2-72942941090c6704a67cad618abc7b2ee83bd371.tar.bz2
gentoo-2-72942941090c6704a67cad618abc7b2ee83bd371.zip
Version bump, remove masked version, /add cvs, git, subversion USE flags
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xD80F5F1E1245142E)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog12
-rw-r--r--sys-apps/portage/portage-2.2.17.ebuild (renamed from sys-apps/portage/portage-2.2.16.ebuild)13
-rw-r--r--sys-apps/portage/portage-9999.ebuild10
3 files changed, 28 insertions, 7 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index bd3a4b1eb07a..a316a4d889c4 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,12 +1,20 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1428 2015/02/08 18:06:12 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.1429 2015/02/12 05:34:22 dolsen Exp $
+
+*portage-2.2.17 (12 Feb 2015)
+
+ 12 Feb 2015; Brian Dolbec <dolsen@gentoo.org> -portage-2.2.16.ebuild,
+ +portage-2.2.17.ebuild, portage-9999.ebuild:
+ Regression fix bump. Remove buggy version. Add git, cvs, subversion USE flags
+ to toggle installation and RDEPENDS of those sync modules.
+ Fixes bug 539746, 539478, 539402.
*portage-2.2.16 (08 Feb 2015)
08 Feb 2015; Brian Dolbec <dolsen@gentoo.org> +portage-2.2.16.ebuild:
Version bump. First release with the new plug-in sync system. Fixes bugs
- 583512, 538314, 537298, 534722, 536926, 536392, 492932, 142579, 282927,
+ 583512, 538314, 537298, 534722, 536926, 536392, 492932, 142579, 282927,
535850, 533036, 463266, 533884, 531656, 531724, 534070, 532670, 532784,
532594, 525718, 532224, 504116, 412471, 531690, 531854, 522032.
diff --git a/sys-apps/portage/portage-2.2.16.ebuild b/sys-apps/portage/portage-2.2.17.ebuild
index 3063197f29a0..edd6b2322240 100644
--- a/sys-apps/portage/portage-2.2.16.ebuild
+++ b/sys-apps/portage/portage-2.2.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.16.ebuild,v 1.1 2015/02/08 18:06:12 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.17.ebuild,v 1.1 2015/02/12 05:34:22 dolsen Exp $
EAPI=5
@@ -20,7 +20,7 @@ HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
SLOT="0"
-IUSE="build doc epydoc +ipc linguas_ru selinux xattr"
+IUSE="build cvs doc epydoc git +ipc linguas_ru selinux subversion xattr"
DEPEND="!build? ( ${PYTHON_DEPS//bzip2(+)/ssl(+),bzip2(+)} )
dev-lang/python-exec:2
@@ -41,11 +41,14 @@ RDEPEND="
app-shells/bash:0[readline]
>=app-admin/eselect-1.2
)
+ cvs? ( dev-vcs/cvs )
elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
+ git? ( dev-vcs/git )
>=app-misc/pax-utils-0.1.17
selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+ subversion? ( dev-vcs/subversion )
xattr? ( kernel_linux? (
>=sys-apps/install-xattr-0.3
$(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \
@@ -78,6 +81,7 @@ SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
$(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)"
python_prepare_all() {
+ esetup.py select_plugins
distutils-r1_python_prepare_all
if ! use ipc ; then
@@ -349,4 +353,9 @@ pkg_postinst() {
-exec chown -R portage:portage {} +
fi
fi
+
+ einfo "The portage build now has USE flag enabled sync modules."
+ einfo "The rsync and webrsync modules are installed by default."
+ einfo "Enable the cvs, git and subversion USE flags to install "
+ einfo "those sync modules as needed."
}
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index 70a9e0a1daf7..7e122adfb3b5 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.108 2014/12/22 11:14:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.109 2015/02/12 05:34:22 dolsen Exp $
EAPI=5
@@ -20,7 +20,7 @@ HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="build doc epydoc +ipc linguas_ru selinux xattr"
+IUSE="build cvs doc epydoc git +ipc linguas_ru selinux subversion xattr"
DEPEND="!build? ( ${PYTHON_DEPS//bzip2(+)/ssl(+),bzip2(+)} )
dev-lang/python-exec:2
@@ -41,11 +41,14 @@ RDEPEND="
app-shells/bash:0[readline]
>=app-admin/eselect-1.2
)
+ cvs? ( dev-vcs/cvs )
elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
+ git? ( dev-vcs/git )
>=app-misc/pax-utils-0.1.17
selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+ subversion? ( dev-vcs/subversion )
xattr? ( kernel_linux? (
>=sys-apps/install-xattr-0.3
$(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \
@@ -77,6 +80,7 @@ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/portage.git
https://github.com/gentoo/portage.git"
python_prepare_all() {
+ esetup.py select_plugins
distutils-r1_python_prepare_all
if ! use ipc ; then