summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-04 08:14:58 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-04 08:14:58 +0000
commit9471174f05ae554b1201058c9969c93bbe5a19bd (patch)
treeae95ee6b5d863e21a43732a6b2c3460d0a457385 /sys-apps
parentChange licence to public-domain, bug #445872 (diff)
downloadgentoo-2-9471174f05ae554b1201058c9969c93bbe5a19bd.tar.gz
gentoo-2-9471174f05ae554b1201058c9969c93bbe5a19bd.tar.bz2
gentoo-2-9471174f05ae554b1201058c9969c93bbe5a19bd.zip
Fix crash on 32-bit systems (bug #445894, thanks to Denny Reeh).
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/accountsservice/ChangeLog9
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild (renamed from sys-apps/accountsservice/accountsservice-0.6.29.ebuild)3
-rw-r--r--sys-apps/accountsservice/files/accountsservice-0.6.29-32bit-crash.patch30
3 files changed, 40 insertions, 2 deletions
diff --git a/sys-apps/accountsservice/ChangeLog b/sys-apps/accountsservice/ChangeLog
index 583a250e4b4b..fe193e405780 100644
--- a/sys-apps/accountsservice/ChangeLog
+++ b/sys-apps/accountsservice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/accountsservice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/ChangeLog,v 1.21 2012/11/30 22:38:12 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/ChangeLog,v 1.22 2012/12/04 08:14:58 tetromino Exp $
+
+*accountsservice-0.6.29-r1 (04 Dec 2012)
+
+ 04 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -accountsservice-0.6.29.ebuild, +accountsservice-0.6.29-r1.ebuild,
+ +files/accountsservice-0.6.29-32bit-crash.patch:
+ Fix crash on 32-bit systems (bug #445894, thanks to Denny Reeh).
*accountsservice-0.6.29 (30 Nov 2012)
diff --git a/sys-apps/accountsservice/accountsservice-0.6.29.ebuild b/sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild
index efb84d76e160..7c3d067993d5 100644
--- a/sys-apps/accountsservice/accountsservice-0.6.29.ebuild
+++ b/sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/accountsservice-0.6.29.ebuild,v 1.1 2012/11/30 22:38:12 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/accountsservice/accountsservice-0.6.29-r1.ebuild,v 1.1 2012/12/04 08:14:58 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -42,6 +42,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}/${PN}-0.6.21-gentoo-system-users.patch"
+ epatch "${FILESDIR}/${P}-32bit-crash.patch" # bug #445894, fixed in 0.6.30
use vala && vala_src_prepare
gnome2_src_prepare
}
diff --git a/sys-apps/accountsservice/files/accountsservice-0.6.29-32bit-crash.patch b/sys-apps/accountsservice/files/accountsservice-0.6.29-32bit-crash.patch
new file mode 100644
index 000000000000..1015072ef709
--- /dev/null
+++ b/sys-apps/accountsservice/files/accountsservice-0.6.29-32bit-crash.patch
@@ -0,0 +1,30 @@
+From 4d5166d1833e42d81b854374aa6e73f83a67a70e Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Tue, 27 Nov 2012 18:30:45 -0500
+Subject: [PATCH] Fix a crash on 32bit systems
+
+The login-frequency property of the User interface is defined
+as uint64 type. Therefore, when setting it with g_object_set,
+a 64bit value is collected, and passing an int might lead to
+bad things.
+https://bugs.freedesktop.org/show_bug.cgi?id=57343
+---
+ src/daemon.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/daemon.c b/src/daemon.c
+index ed3a114..4d6f3ab 100644
+--- a/src/daemon.c
++++ b/src/daemon.c
+@@ -207,7 +207,7 @@ daemon_local_user_is_excluded (Daemon *daemon, const gchar *username, const gcha
+ #ifdef HAVE_UTMPX_H
+
+ typedef struct {
+- int frequency;
++ guint64 frequency;
+ gint64 time;
+ GList *previous_logins;
+ } UserAccounting;
+--
+1.8.0
+