summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-01 08:08:58 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-01 08:08:58 +0000
commit95a5974e980ae32bbe9f10122afbebced2b753f8 (patch)
treeca3e9477baaab99c7f8ecf0fd931931755b49a4b /sys-apps
parentAdd back amd64-fbsd keyword that got dropped by accident. (diff)
downloadgentoo-2-95a5974e980ae32bbe9f10122afbebced2b753f8.tar.gz
gentoo-2-95a5974e980ae32bbe9f10122afbebced2b753f8.tar.bz2
gentoo-2-95a5974e980ae32bbe9f10122afbebced2b753f8.zip
Version bump (bug #499588) and add myself as a maintainer.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/the_silver_searcher/ChangeLog9
-rw-r--r--sys-apps/the_silver_searcher/files/the_silver_searcher-0.19.2-automagic-lzma.patch24
-rw-r--r--sys-apps/the_silver_searcher/metadata.xml4
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.19.2.ebuild39
4 files changed, 75 insertions, 1 deletions
diff --git a/sys-apps/the_silver_searcher/ChangeLog b/sys-apps/the_silver_searcher/ChangeLog
index e813031a9748..2fb346524e30 100644
--- a/sys-apps/the_silver_searcher/ChangeLog
+++ b/sys-apps/the_silver_searcher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/the_silver_searcher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.32 2014/02/24 01:47:28 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.33 2014/03/01 08:08:58 radhermit Exp $
+
+*the_silver_searcher-0.19.2 (01 Mar 2014)
+
+ 01 Mar 2014; Tim Harder <radhermit@gentoo.org>
+ +the_silver_searcher-0.19.2.ebuild,
+ +files/the_silver_searcher-0.19.2-automagic-lzma.patch, metadata.xml:
+ Version bump (bug #499588) and add myself as a maintainer.
24 Feb 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org>
the_silver_searcher-0.18.ebuild:
diff --git a/sys-apps/the_silver_searcher/files/the_silver_searcher-0.19.2-automagic-lzma.patch b/sys-apps/the_silver_searcher/files/the_silver_searcher-0.19.2-automagic-lzma.patch
new file mode 100644
index 000000000000..7d1e23927a74
--- /dev/null
+++ b/sys-apps/the_silver_searcher/files/the_silver_searcher-0.19.2-automagic-lzma.patch
@@ -0,0 +1,24 @@
+--- the_silver_searcher-0.19.2/configure.ac
++++ the_silver_searcher-0.19.2/configure.ac
+@@ -21,14 +21,15 @@
+ CFLAGS="$CFLAGS $PCRE_CFLAGS -Wall -Wextra -std=gnu89 -D_GNU_SOURCE"
+ LDFLAGS="$LDFLAGS"
+
+-AC_CHECK_HEADERS([pthread.h zlib.h lzma.h])
++AC_CHECK_HEADERS([pthread.h zlib.h])
+
+-if test "$ac_cv_header_lzma_h" == yes
+-then
++AC_ARG_ENABLE([lzma],
++ AS_HELP_STRING([--disable-lzma], [Disable compressed search support]))
++
++AS_IF([test "x$enable_lzma" != "xno"], [
++ AC_CHECK_HEADERS([lzma.h])
+ PKG_CHECK_MODULES([LZMA], [liblzma])
+-else
+- AC_MSG_WARN([LZMA lib not found. Compiling without compressed search support.])
+-fi
++])
+
+ AC_CHECK_DECL([PCRE_CONFIG_JIT], [AC_DEFINE([USE_PCRE_JIT], [], [Use PCRE JIT])], [], [#include <pcre.h>])
+
diff --git a/sys-apps/the_silver_searcher/metadata.xml b/sys-apps/the_silver_searcher/metadata.xml
index a03b29ef8760..6dd76bd51a55 100644
--- a/sys-apps/the_silver_searcher/metadata.xml
+++ b/sys-apps/the_silver_searcher/metadata.xml
@@ -5,4 +5,8 @@
<email>jdhore@gentoo.org</email>
<name>Jeff Horelick</name>
</maintainer>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.19.2.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.19.2.ebuild
new file mode 100644
index 000000000000..78c20bd00211
--- /dev/null
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.19.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.19.2.ebuild,v 1.1 2014/03/01 08:08:58 radhermit Exp $
+
+EAPI=5
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="A code-searching tool similar to ack, but faster"
+HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="lzma"
+
+RDEPEND="dev-libs/libpcre
+ sys-libs/zlib
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README.md"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-automagic-lzma.patch
+ sed -i '/^dist_bashcomp/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable lzma)
+}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}