summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-11-20 06:20:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-11-20 06:20:23 +0000
commitc438ecbb830dcc662aed0c7fa22929dffc7107cb (patch)
treec5dd263b5de3fc34befd99398645f26d9f98072f /sys-apps
parentclean old impls, add pypy3, update deps accordingly (diff)
downloadgentoo-2-c438ecbb830dcc662aed0c7fa22929dffc7107cb.tar.gz
gentoo-2-c438ecbb830dcc662aed0c7fa22929dffc7107cb.tar.bz2
gentoo-2-c438ecbb830dcc662aed0c7fa22929dffc7107cb.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/toybox/ChangeLog7
-rw-r--r--sys-apps/toybox/toybox-0.5.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/toybox/ChangeLog b/sys-apps/toybox/ChangeLog
index 9e2ec6d0ffad..52dec8e44eab 100644
--- a/sys-apps/toybox/ChangeLog
+++ b/sys-apps/toybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/toybox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/ChangeLog,v 1.6 2014/10/19 03:25:11 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/ChangeLog,v 1.7 2014/11/20 06:20:23 patrick Exp $
+
+*toybox-0.5.1 (20 Nov 2014)
+
+ 20 Nov 2014; Patrick Lauer <patrick@gentoo.org> +toybox-0.5.1.ebuild:
+ Bump
19 Oct 2014; Mike Gilbert <floppym@gentoo.org> toybox-0.5.0.ebuild,
toybox-9999.ebuild:
diff --git a/sys-apps/toybox/toybox-0.5.1.ebuild b/sys-apps/toybox/toybox-0.5.1.ebuild
new file mode 100644
index 000000000000..a4bded5f555a
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/toybox-0.5.1.ebuild,v 1.1 2014/11/20 06:20:23 patrick Exp $
+
+EAPI=5
+
+inherit eutils multiprocessing savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gfto/toybox.git"
+else
+ SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="http://landley.net/code/toybox/"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch_user
+ restore_config .config
+}
+
+src_configure() {
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, so we will save a default one"
+ emake defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ tc-export CC STRIP
+ export HOSTCC=$(tc-getBUILD_CC)
+ unset CROSS_COMPILE
+ export CPUS=$(makeopts_jobs)
+ emake V=1
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ save_config .config
+ newbin toybox_unstripped toybox
+}