summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-05-09 19:11:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-05-09 19:11:10 +0000
commitcd30a6e8a660a4f7b79b1ca30b4bb260edeb55b6 (patch)
tree8d46c7924ccd5261d5632a1f94f67683e39143d3 /sys-apps
parentRemove old versions. (diff)
downloadgentoo-2-cd30a6e8a660a4f7b79b1ca30b4bb260edeb55b6.tar.gz
gentoo-2-cd30a6e8a660a4f7b79b1ca30b4bb260edeb55b6.tar.bz2
gentoo-2-cd30a6e8a660a4f7b79b1ca30b4bb260edeb55b6.zip
Version bump.
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/attr/ChangeLog7
-rw-r--r--sys-apps/attr/attr-2.4.46.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index 0ac20b69c251..acbdf6d82c19 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/attr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.125 2011/04/15 17:17:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.126 2011/05/09 19:11:10 vapier Exp $
+
+*attr-2.4.46 (09 May 2011)
+
+ 09 May 2011; Mike Frysinger <vapier@gentoo.org> +attr-2.4.46.ebuild:
+ Version bump.
*attr-2.4.44-r1 (15 Apr 2011)
diff --git a/sys-apps/attr/attr-2.4.46.ebuild b/sys-apps/attr/attr-2.4.46.ebuild
new file mode 100644
index 000000000000..350f9b5d3105
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.46.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.46.ebuild,v 1.1 2011/05/09 19:11:10 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://savannah.nongnu.org/projects/attr"
+SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.44-gettext.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ strip-linguas po
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --enable-shared $(use_enable static-libs static) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-lib install-dev || die
+ use static-libs || find "${D}" -name '*.la' -delete
+ # the man-pages packages provides the man2 files
+ rm -r "${D}"/usr/share/man/man2
+
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+}