summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-09-15 18:08:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-09-15 18:08:30 +0000
commitd4f45da720902b079bff7204713b23498971de6b (patch)
tree22d8b7d64279e805334bf797ae89d92ece049ec0 /sys-apps
parentConvert to distutils-r1. Enable doctests. (diff)
downloadgentoo-2-d4f45da720902b079bff7204713b23498971de6b.tar.gz
gentoo-2-d4f45da720902b079bff7204713b23498971de6b.tar.bz2
gentoo-2-d4f45da720902b079bff7204713b23498971de6b.zip
Cleanup the stupid -r1/patching/non-default ebuilds.
(Portage version: 2.2.0_alpha189/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog9
-rw-r--r--sys-apps/hwids/hwids-20130717-r1.ebuild54
-rw-r--r--sys-apps/hwids/hwids-20130717.ebuild44
-rw-r--r--sys-apps/hwids/hwids-20130915.1.ebuild (renamed from sys-apps/hwids/hwids-20130707.ebuild)2
-rw-r--r--sys-apps/hwids/hwids-20130915.ebuild53
5 files changed, 9 insertions, 153 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index ed4c48a42632..181cc7e823dd 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.116 2013/09/15 17:12:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.117 2013/09/15 18:08:30 flameeyes Exp $
+
+*hwids-20130915.1 (15 Sep 2013)
+
+ 15 Sep 2013; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20130915.1.ebuild,
+ -hwids-20130707.ebuild, -hwids-20130717-r1.ebuild, -hwids-20130717.ebuild,
+ -hwids-20130915.ebuild:
+ Cleanup the stupid -r1/patching/non-default ebuilds.
*hwids-20130915 (15 Sep 2013)
diff --git a/sys-apps/hwids/hwids-20130717-r1.ebuild b/sys-apps/hwids/hwids-20130717-r1.ebuild
deleted file mode 100644
index a2f95b337b7a..000000000000
--- a/sys-apps/hwids/hwids-20130717-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130717-r1.ebuild,v 1.3 2013/08/11 18:59:22 ssuominen Exp $
-
-EAPI=5
-inherit udev eutils
-
-DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
-HOMEPAGE="https://github.com/gentoo/hwids"
-SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz
- http://dev.gentoo.org/~ssuominen/${P}-keyboard.patch.xz"
-
-LICENSE="|| ( GPL-2 BSD ) public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="+udev"
-
-DEPEND="udev? (
- dev-lang/perl
- >=virtual/udev-206
-)"
-RDEPEND="!<sys-apps/pciutils-3.1.9-r2
- !<sys-apps/usbutils-005-r1"
-
-S=${WORKDIR}/hwids-${P}
-
-src_prepare() {
- sed -i -e '/udevadm hwdb/d' Makefile || die
- # Import required 60-keyboard.hwdb for sys-fs/udev >= 206
- epatch "${WORKDIR}"/${P}-keyboard.patch
-}
-
-src_compile() {
- emake UDEV=$(usex udev)
-}
-
-src_install() {
- emake UDEV=$(usex udev) install \
- DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
- MISCDIR="${EPREFIX}/usr/share/misc" \
- HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
- DESTDIR="${D}"
-}
-
-pkg_postinst() {
- if use udev; then
- udevadm hwdb --update --root="${ROOT%/}"
- # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
- fi
- udevadm control --reload
- fi
-}
diff --git a/sys-apps/hwids/hwids-20130717.ebuild b/sys-apps/hwids/hwids-20130717.ebuild
deleted file mode 100644
index 0b55e2284c33..000000000000
--- a/sys-apps/hwids/hwids-20130717.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130717.ebuild,v 1.1 2013/07/17 20:21:16 flameeyes Exp $
-
-EAPI=5
-inherit udev eutils
-
-DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
-HOMEPAGE="https://github.com/gentoo/hwids"
-SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 BSD ) public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="+udev"
-
-DEPEND="udev? (
- dev-lang/perl
- >=virtual/udev-197-r1
-)"
-RDEPEND="!<sys-apps/pciutils-3.1.9-r2
- !<sys-apps/usbutils-005-r1"
-
-S=${WORKDIR}/hwids-${P}
-
-src_prepare() {
- sed -i -e '/udevadm hwdb/d' Makefile || die
-}
-
-src_compile() {
- emake UDEV=$(usex udev)
-}
-
-src_install() {
- emake UDEV=$(usex udev) install \
- DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
- MISCDIR="${EPREFIX}/usr/share/misc" \
- HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
- DESTDIR="${D}"
-}
-
-pkg_postinst() {
- use udev && udevadm hwdb --update --root="${ROOT%/}"
-}
diff --git a/sys-apps/hwids/hwids-20130707.ebuild b/sys-apps/hwids/hwids-20130915.1.ebuild
index dbf4176f0a22..94e5516cd551 100644
--- a/sys-apps/hwids/hwids-20130707.ebuild
+++ b/sys-apps/hwids/hwids-20130915.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130707.ebuild,v 1.1 2013/07/08 08:44:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130915.1.ebuild,v 1.1 2013/09/15 18:08:30 flameeyes Exp $
EAPI=5
inherit udev eutils
diff --git a/sys-apps/hwids/hwids-20130915.ebuild b/sys-apps/hwids/hwids-20130915.ebuild
deleted file mode 100644
index c148319f0dc5..000000000000
--- a/sys-apps/hwids/hwids-20130915.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130915.ebuild,v 1.1 2013/09/15 17:12:59 ssuominen Exp $
-
-EAPI=5
-inherit udev eutils
-
-DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
-HOMEPAGE="https://github.com/gentoo/hwids"
-# https://github.com/gentoo/hwids/pull/4 + make fetch =
-SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.gz"
-#SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 BSD ) public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="+udev"
-
-DEPEND="udev? (
- dev-lang/perl
- >=virtual/udev-206
-)"
-RDEPEND="!<sys-apps/pciutils-3.1.9-r2
- !<sys-apps/usbutils-005-r1"
-
-S=${WORKDIR}/hwids-${P}
-
-src_prepare() {
- sed -i -e '/udevadm hwdb/d' Makefile || die
-}
-
-src_compile() {
- emake UDEV=$(usex udev)
-}
-
-src_install() {
- emake UDEV=$(usex udev) install \
- DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
- MISCDIR="${EPREFIX}/usr/share/misc" \
- HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
- DESTDIR="${D}"
-}
-
-pkg_postinst() {
- if use udev; then
- udevadm hwdb --update --root="${ROOT%/}"
- # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
- fi
- udevadm control --reload
- fi
-}