summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-18 01:27:02 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-18 01:27:02 +0000
commite72063fc9bf14b4fd8b282b5cd83fd0df5109e7d (patch)
tree507c36ef32a7788dcbe36ca6ab2a5c2a59a28b71 /sys-apps
parent*portage-2.2.0_alpha16 (18 Jan 2011) (diff)
downloadgentoo-2-e72063fc9bf14b4fd8b282b5cd83fd0df5109e7d.tar.gz
gentoo-2-e72063fc9bf14b4fd8b282b5cd83fd0df5109e7d.tar.bz2
gentoo-2-e72063fc9bf14b4fd8b282b5cd83fd0df5109e7d.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-5.03.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/sys-apps/file/file-5.03.ebuild b/sys-apps/file/file-5.03.ebuild
deleted file mode 100644
index a1a4ca13aee9..000000000000
--- a/sys-apps/file/file-5.03.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.03.ebuild,v 1.10 2010/02/04 18:25:47 arfrever Exp $
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils distutils libtool flag-o-matic
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
- ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="python"
-
-DEPEND=""
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
-
- elibtoolize
- epunt_cxx
-
- # make sure python links against the current libmagic #54401
- sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
- # dont let python README kill main README #60043
- mv python/README{,.python}
-
- # only one data file, so put it into /usr/share/misc/
-# sed -i '/^pkgdatadir/s:/@PACKAGE@::' $(find -name Makefile.in)
-}
-
-src_compile() {
- # file uses things like strndup() and wcwidth()
- append-flags -D_GNU_SOURCE
-
- econf || die
- emake || die
-
- use python && cd python && distutils_src_compile
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog MAINT README
-
- use python && cd python && distutils_src_install
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}