summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-03 15:09:55 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-03 15:09:55 +0000
commitf15b1b85e210bbd1a13ab6cefee8e6ab735c0784 (patch)
treecb7c0d40b091fa55ba4f7ce7c442096ea0e1f50e /sys-apps
parentstable on alpha (diff)
downloadgentoo-2-f15b1b85e210bbd1a13ab6cefee8e6ab735c0784.tar.gz
gentoo-2-f15b1b85e210bbd1a13ab6cefee8e6ab735c0784.tar.bz2
gentoo-2-f15b1b85e210bbd1a13ab6cefee8e6ab735c0784.zip
touchups
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/i2c/i2c-2.6.5-r1.ebuild32
-rw-r--r--sys-apps/i2c/i2c-2.7.0.ebuild28
-rw-r--r--sys-apps/i2c/i2c-2.8.0.ebuild47
3 files changed, 57 insertions, 50 deletions
diff --git a/sys-apps/i2c/i2c-2.6.5-r1.ebuild b/sys-apps/i2c/i2c-2.6.5-r1.ebuild
index c86ebbd7a4e7..7904ef2b821f 100644
--- a/sys-apps/i2c/i2c-2.6.5-r1.ebuild
+++ b/sys-apps/i2c/i2c-2.6.5-r1.ebuild
@@ -1,39 +1,43 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.6.5-r1.ebuild,v 1.4 2003/09/08 08:02:45 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.6.5-r1.ebuild,v 1.5 2003/10/03 15:09:55 vapier Exp $
-S="${WORKDIR}/${P}"
DESCRIPTION="I2C Bus support"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
-HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
-KEYWORDS="x86 amd64 ppc"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 amd64 ppc"
DEPEND="virtual/linux-sources"
-src_compile () {
- emake LINUX_INCLUDE_DIR=/usr/include/linux clean all || \
- die "i2c requires the source of a compatible kernel\nversion installed in /usr/src/linux\nand kernel i2c *disabled* or *enabled as a module*"
+src_compile() {
+ if [ ! `emake LINUX_INCLUDE_DIR=/usr/include/linux clean all` ] ; then
+ eerror "i2c requires the source of a compatible kernel"
+ eerror "version installed in /usr/src/linux"
+ eerror "and kernel i2c *disabled* or *enabled as a module*"
+ die "make failed"
+ fi
}
-src_install () {
- emake LINUX_INCLUDE_DIR=/usr/include/linux DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+src_install() {
+ emake \
+ LINUX_INCLUDE_DIR=/usr/include/linux \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ install || die
dodoc CHANGES INSTALL README
}
pkg_postinst() {
[ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- einfo "*****************************************************************"
einfo
einfo "i2c package installed ..."
einfo
einfo "IMPORTANT ... if you are installing this package you need to either"
einfo "IMPORTANT ... *disable* kernel i2c support or *enable it as a module*"
einfo
- einfo "*****************************************************************"
}
-
-
diff --git a/sys-apps/i2c/i2c-2.7.0.ebuild b/sys-apps/i2c/i2c-2.7.0.ebuild
index 8f4aea5f1dc0..65c90857870e 100644
--- a/sys-apps/i2c/i2c-2.7.0.ebuild
+++ b/sys-apps/i2c/i2c-2.7.0.ebuild
@@ -1,39 +1,45 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.6 2003/09/08 08:02:45 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.7 2003/10/03 15:09:55 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="I2C Bus support"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
-HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ~ppc"
-LICENSE="GPL-2"
DEPEND="virtual/linux-sources"
-src_compile () {
- emake LINUX_INCLUDE_DIR=/usr/include/linux clean all || \
- die "i2c requires the source of a compatible kernel\nversion installed in /usr/src/linux\nand kernel i2c *disabled* or *enabled as a module*"
+src_compile() {
+ if [ ! `emake LINUX_INCLUDE_DIR=/usr/include/linux clean all` ] ; then
+ eerror "i2c requires the source of a compatible kernel"
+ eerror "version installed in /usr/src/linux"
+ eerror "and kernel i2c *disabled* or *enabled as a module*"
+ die "make failed"
+ fi
}
-src_install () {
- emake LINUX_INCLUDE_DIR=/usr/include/linux DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+src_install() {
+ emake \
+ LINUX_INCLUDE_DIR=/usr/include/linux \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ install || die
dodoc CHANGES INSTALL README
}
pkg_postinst() {
[ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- einfo "*****************************************************************"
einfo
einfo "i2c package installed ..."
einfo
einfo "IMPORTANT ... if you are installing this package you need to either"
einfo "IMPORTANT ... *disable* kernel i2c support or *enable it as a module*"
einfo
- einfo "*****************************************************************"
}
diff --git a/sys-apps/i2c/i2c-2.8.0.ebuild b/sys-apps/i2c/i2c-2.8.0.ebuild
index 51a3b46f6aa9..b21cf1218389 100644
--- a/sys-apps/i2c/i2c-2.8.0.ebuild
+++ b/sys-apps/i2c/i2c-2.8.0.ebuild
@@ -1,21 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.0.ebuild,v 1.5 2003/09/08 11:32:47 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.0.ebuild,v 1.6 2003/10/03 15:09:55 vapier Exp $
-# plasmaroo@plasmaroo.squirrelserver.co.uk, datestamp Tue Aug 12, 11:11 PM
-
-S=${WORKDIR}/${P}
DESCRIPTION="I2C Bus support for 2.4.x kernels"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
-HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
-LICENSE="GPL-2"
-DEPEND=""
-src_compile () {
+DEPEND=""
+pkg_setup() {
echo
einfo "*****************************************************************"
einfo
@@ -52,8 +49,9 @@ src_compile () {
eerror
eerror "*****************************************************************"
echo
- sleep 10
+}
+src_compile () {
if [ "$LINUX" != "" ]; then
einfo "Cross-compiling using:- $LINUX"
einfo "Using headers from:- `echo $LINUX/include/linux | sed 's/\/\//\//'`"
@@ -77,25 +75,29 @@ src_compile () {
fi
fi
- echo
- sleep 2
-
- emake LINUX=$LINUX clean all || \
- die "i2c requires the source of a compatible kernel version installed in /usr/src/linux or the environmental variable \$LINUX and kernel i2c *disabled* or *enabled as a module*"
+ if [ ! `emake LINUX=$LINUX clean all` ] ; then
+ eerror "i2c requires the source of a compatible kernel"
+ eerror "version installed in /usr/src/linux"
+ eerror "(or the environmental variable \$LINUX)"
+ eerror "and kernel i2c *disabled* or *enabled as a module*"
+ die "make failed"
+ fi
}
-src_install () {
-
- emake LINUX=$LINUX LINUX_INCLUDE_DIR=/usr/include/linux DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+src_install() {
+ emake \
+ LINUX=$LINUX \
+ LINUX_INCLUDE_DIR=/usr/include/linux \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ install || die
dodoc CHANGES INSTALL README
-
}
pkg_postinst() {
[ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- echo
- einfo "*****************************************************************"
einfo
einfo "I2C modules installed ..."
einfo
@@ -103,9 +105,4 @@ pkg_postinst() {
einfo "IMPORTANT ... *disable* kernel I2C support OR *modularize it*"
einfo "IMPORTANT ... if your 2.4.x kernel is patched with such support"
einfo
- einfo "*****************************************************************"
- echo
-
}
-
-