summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-03 19:09:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-03 19:09:46 +0000
commit6c117b6168d82b332777eb2291f30ae7fa4ef892 (patch)
treeaf18f7a90ca8aadee291f554465f479bcc387500 /sys-auth/pam_ldap/pam_ldap-178-r1.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-6c117b6168d82b332777eb2291f30ae7fa4ef892.tar.gz
gentoo-2-6c117b6168d82b332777eb2291f30ae7fa4ef892.tar.bz2
gentoo-2-6c117b6168d82b332777eb2291f30ae7fa4ef892.zip
Security Bug #96767, ssl not being used always. Note that both 176-r1 and 178-r1 have the patch.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-auth/pam_ldap/pam_ldap-178-r1.ebuild')
-rw-r--r--sys-auth/pam_ldap/pam_ldap-178-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-auth/pam_ldap/pam_ldap-178-r1.ebuild b/sys-auth/pam_ldap/pam_ldap-178-r1.ebuild
new file mode 100644
index 000000000000..8bd0af81bde9
--- /dev/null
+++ b/sys-auth/pam_ldap/pam_ldap-178-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/pam_ldap-178-r1.ebuild,v 1.1 2005/07/03 19:09:46 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha"
+IUSE="ssl"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-1.2.11"
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-176-fix-referral-tls.patch
+
+ cd ${S}
+ export WANT_AUTOCONF=2.5
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ automake --add-missing || die "automake failed"
+}
+
+src_compile() {
+ econf --with-ldap-lib=openldap `use_enable ssl` || die
+ emake || die
+}
+
+src_install() {
+ exeinto /lib/security
+ doexe pam_ldap.so
+
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog COPYING.* CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ docinto pam.d
+ dodoc pam.d/*
+}