summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-24 20:15:49 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-24 20:15:49 +0000
commit16ba5cb799044ec9fa1f5845f485c77fcb814aff (patch)
tree6a6ee30a64a38875caa03312f6543dc9493bb7a2 /sys-auth
parentmask net-firewall/fireflier (diff)
downloadgentoo-2-16ba5cb799044ec9fa1f5845f485c77fcb814aff.tar.gz
gentoo-2-16ba5cb799044ec9fa1f5845f485c77fcb814aff.tar.bz2
gentoo-2-16ba5cb799044ec9fa1f5845f485c77fcb814aff.zip
added patch to fix gcc-4.2 warnings
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_chroot/ChangeLog6
-rw-r--r--sys-auth/pam_chroot/files/pam_chroot-0.9.1-gcc42.patch11
-rw-r--r--sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/sys-auth/pam_chroot/ChangeLog b/sys-auth/pam_chroot/ChangeLog
index 385aa9d8e7e7..b316ff8f1039 100644
--- a/sys-auth/pam_chroot/ChangeLog
+++ b/sys-auth/pam_chroot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/pam_chroot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/ChangeLog,v 1.6 2007/07/18 05:35:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/ChangeLog,v 1.7 2007/07/24 20:15:49 hawking Exp $
+
+ 24 Jul 2007; Ali Polatel <hawking@gentoo.org>
+ +files/pam_chroot-0.9.1-gcc42.patch, pam_chroot-0.9.1.ebuild:
+ added patch to fix gcc-4.2 warnings
18 Jul 2007; Jeroen Roovers <jer@gentoo.org> pam_chroot-0.9.1.ebuild:
Marked ~hppa (bug #185205).
diff --git a/sys-auth/pam_chroot/files/pam_chroot-0.9.1-gcc42.patch b/sys-auth/pam_chroot/files/pam_chroot-0.9.1-gcc42.patch
new file mode 100644
index 000000000000..f8bf6f39f3a1
--- /dev/null
+++ b/sys-auth/pam_chroot/files/pam_chroot-0.9.1-gcc42.patch
@@ -0,0 +1,11 @@
+--- pam_chroot-0.9.1/pam_chroot.c.orig 2007-07-24 23:04:09.000000000 +0300
++++ pam_chroot-0.9.1/pam_chroot.c 2007-07-24 23:00:52.000000000 +0300
+@@ -291,7 +291,7 @@
+ if(NULL == grp) {
+ _pam_log(LOG_DEBUG, "%s: no grnam for gid %d", opts->module, gids[i]);
+ snprintf(scratch, SCRATCH, "%d", gids[i]);
+- groups[i] = x_strdup(scratch);
++ groups[i] = (scratch[0]) ? strdup(scratch):NULL;
+ } else {
+ groups[i] = x_strdup(grp->gr_name);
+ }
diff --git a/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild b/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
index acfb0894326a..1e515ed8ad6d 100644
--- a/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
+++ b/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild,v 1.6 2007/07/18 05:35:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild,v 1.7 2007/07/24 20:15:49 hawking Exp $
inherit toolchain-funcs pam flag-o-matic eutils
@@ -22,6 +22,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-makefile.patch"
+ epatch "${FILESDIR}/${P}-gcc42.patch"
}
src_compile() {