summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2011-10-20 19:14:47 +0000
committerIan Stakenvicius <axs@gentoo.org>2011-10-20 19:14:47 +0000
commita1a2f1ae24dd1c03190e832abb2ffdc2f6f686ab (patch)
treedcd1605d917c5451f79435521c8be30422df2fa0 /sys-auth
parentMake it build against newer poppler, bug 356027. (diff)
downloadgentoo-2-a1a2f1ae24dd1c03190e832abb2ffdc2f6f686ab.tar.gz
gentoo-2-a1a2f1ae24dd1c03190e832abb2ffdc2f6f686ab.tar.bz2
gentoo-2-a1a2f1ae24dd1c03190e832abb2ffdc2f6f686ab.zip
Removed keepdir on /var/run/ConsoleKit as per bug 387901
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/ChangeLog8
-rw-r--r--sys-auth/consolekit/consolekit-0.4.5-r2.ebuild94
-rw-r--r--sys-auth/consolekit/files/consolekit-0.2.rc26
3 files changed, 127 insertions, 1 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index 31f20f451bcb..368b3ec4dc58 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.113 2011/10/14 18:38:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.114 2011/10/20 19:14:47 axs Exp $
+
+*consolekit-0.4.5-r2 (20 Oct 2011)
+
+ 20 Oct 2011; Ian Stakenvicius <axs@gentoo.org> +files/consolekit-0.2.rc,
+ +consolekit-0.4.5-r2.ebuild:
+ Removed keepdir on /var/run/ConsoleKit as per bug 387901
14 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> -consolekit-0.4.4.ebuild,
-consolekit-0.4.5.ebuild:
diff --git a/sys-auth/consolekit/consolekit-0.4.5-r2.ebuild b/sys-auth/consolekit/consolekit-0.4.5-r2.ebuild
new file mode 100644
index 000000000000..e5babf82bc8b
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-0.4.5-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.5-r2.ebuild,v 1.1 2011/10/20 19:14:47 axs Exp $
+
+EAPI=4
+inherit autotools eutils linux-info multilib pam systemd
+
+MY_PN=ConsoleKit
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="http://www.freedesktop.org/software/${MY_PN}/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug doc kernel_linux pam policykit test"
+
+RDEPEND=">=dev-libs/dbus-glib-0.88
+ >=dev-libs/glib-2.20:2
+ sys-libs/zlib
+ x11-libs/libX11
+ pam? ( virtual/pam )
+ policykit? ( >=sys-auth/polkit-0.101-r1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ doc? ( app-text/xmlto )
+ test? ( app-text/docbook-xml-dtd:4.1.2 )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # This is required to get login-session-id string with pam_ck_connector.so
+ if use pam && use kernel_linux; then
+ CONFIG_CHECK="~AUDITSYSCALL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.2.10-cleanup_console_tags.patch \
+ "${FILESDIR}"/${PN}-0.4.0-polkit-automagic.patch \
+ "${FILESDIR}"/${PN}-0.4.0-multilib.patch \
+ "${FILESDIR}"/${PN}-0.4.1-shutdown-reboot-without-policies.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ XMLTO_FLAGS="--skip-validation" \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable pam pam-module) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ --with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
+ --with-pam-module-dir=$(getpam_mod_dir) \
+ "$(systemd_with_unitdir)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README TODO
+
+ newinitd "${FILESDIR}"/${PN}-0.2.rc consolekit
+
+ keepdir /usr/$(get_libdir)/ConsoleKit/run-seat.d
+ keepdir /usr/$(get_libdir)/ConsoleKit/run-session.d
+ keepdir /etc/ConsoleKit/run-session.d
+ keepdir /var/log/ConsoleKit
+
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/90-consolekit-3 90-consolekit
+
+ exeinto /usr/$(get_libdir)/ConsoleKit/run-session.d
+ doexe "${FILESDIR}"/pam-foreground-compat.ck
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ ewarn "You need to restart ConsoleKit to get the new features."
+ ewarn "This can be done with /etc/init.d/consolekit restart"
+ ewarn "but make sure you do this and then restart your session"
+ ewarn "otherwise you will get access denied for certain actions"
+}
diff --git a/sys-auth/consolekit/files/consolekit-0.2.rc b/sys-auth/consolekit/files/consolekit-0.2.rc
new file mode 100644
index 000000000000..b20226767525
--- /dev/null
+++ b/sys-auth/consolekit/files/consolekit-0.2.rc
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/files/consolekit-0.2.rc,v 1.1 2011/10/20 19:14:47 axs Exp $
+
+depend() {
+ need dbus
+ use logger
+}
+
+start() {
+ ebegin "Starting ConsoleKit daemon"
+
+ checkpath -q -d -m 0755 /var/run/ConsoleKit
+
+ start-stop-daemon --start -q \
+ --pidfile /var/run/ConsoleKit/pid \
+ --exec /usr/sbin/console-kit-daemon --
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ConsoleKit daemon"
+ start-stop-daemon --stop -q --pidfile /var/run/ConsoleKit/pid
+ eend $?
+}