summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-04-11 15:33:02 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-04-11 15:33:02 +0000
commitdf099de19785e4d2fa76169d985ec5a8909c1771 (patch)
tree3ff5799a6ad024d46080fa41651a4eedf2f83634 /sys-auth
parentApply arch detection logic from bug #296917 by ferret (diff)
downloadgentoo-2-df099de19785e4d2fa76169d985ec5a8909c1771.tar.gz
gentoo-2-df099de19785e4d2fa76169d985ec5a8909c1771.tar.bz2
gentoo-2-df099de19785e4d2fa76169d985ec5a8909c1771.zip
Revision bump by Víctor Enríquez Miguel. Patches from mephinet & Michael Weber close bug #298459. Patch from Michael Weber closes bug #309751.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/thinkfinger/ChangeLog13
-rw-r--r--sys-auth/thinkfinger/files/0.3-send-sync-event.patch50
-rw-r--r--sys-auth/thinkfinger/files/60-thinkfinger.rules14
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.2.2-r1.ebuild51
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.3-r2.ebuild (renamed from sys-auth/thinkfinger/thinkfinger-0.3-r1.ebuild)5
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.3.ebuild60
6 files changed, 65 insertions, 128 deletions
diff --git a/sys-auth/thinkfinger/ChangeLog b/sys-auth/thinkfinger/ChangeLog
index 818198ca8c8e..643b7dc2825d 100644
--- a/sys-auth/thinkfinger/ChangeLog
+++ b/sys-auth/thinkfinger/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-auth/thinkfinger
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/ChangeLog,v 1.7 2009/02/18 15:37:38 chainsaw Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/ChangeLog,v 1.8 2010/04/11 15:33:02 chainsaw Exp $
+
+*thinkfinger-0.3-r2 (11 Apr 2010)
+
+ 11 Apr 2010; <chainsaw@gentoo.org> +files/0.3-send-sync-event.patch,
+ -thinkfinger-0.2.2-r1.ebuild, -thinkfinger-0.3.ebuild,
+ files/60-thinkfinger.rules, -thinkfinger-0.3-r1.ebuild,
+ +thinkfinger-0.3-r2.ebuild:
+ Revision bump by Víctor Enríquez Miguel. Patches from mephinet & Michael
+ Weber close bug #298459. Patch from Michael Weber closes bug #309751.
*thinkfinger-0.3-r1 (18 Feb 2009)
diff --git a/sys-auth/thinkfinger/files/0.3-send-sync-event.patch b/sys-auth/thinkfinger/files/0.3-send-sync-event.patch
new file mode 100644
index 000000000000..39e0edb27ba1
--- /dev/null
+++ b/sys-auth/thinkfinger/files/0.3-send-sync-event.patch
@@ -0,0 +1,50 @@
+--- pam/pam_thinkfinger-uinput.c 2009-12-27 18:42:26.000000000 +0100
++++ pam/pam_thinkfinger-uinput.c 2009-12-27 18:41:55.000000000 +0100
+@@ -34,27 +34,40 @@
+ int uinput_cr (int *fd)
+ {
+ int retval = 0, ev_size = 0;
+- struct input_event ev = {
++ struct input_event key_ev = {
+ .type = EV_KEY,
+ .code = KEY_ENTER,
+ .time = {0, }
+ };
+
+- ev_size = sizeof (ev);
++ ev_size = sizeof (key_ev);
+
+ /* key press */
+- ev.value = 1;
+- if (write (*fd, &ev, ev_size) != ev_size) {
++ key_ev.value = 1;
++ if (write (*fd, &key_ev, ev_size) != ev_size) {
+ retval = errno;
+ goto out;
+ }
+ /* key release */
+- ev.value = 0;
+- if (write (*fd, &ev, ev_size) != ev_size) {
++ key_ev.value = 0;
++ if (write (*fd, &key_ev, ev_size) != ev_size) {
+ retval = errno;
+ goto out;
+ }
+-
++
++ /* syn event */
++ struct input_event syn_ev = {
++ .time = {0, },
++ .type = EV_SYN,
++ .code = SYN_REPORT,
++ .value = 0
++ };
++
++ if (write (*fd, &syn_ev, ev_size) != ev_size) {
++ retval = errno;
++ goto out;
++ }
++
+ out:
+ return retval;
+ }
diff --git a/sys-auth/thinkfinger/files/60-thinkfinger.rules b/sys-auth/thinkfinger/files/60-thinkfinger.rules
index 21e1ac9461e3..1ccc394d49ff 100644
--- a/sys-auth/thinkfinger/files/60-thinkfinger.rules
+++ b/sys-auth/thinkfinger/files/60-thinkfinger.rules
@@ -1,17 +1,5 @@
-#
-# udev rules file for the thinkfinger fingerprint scanner
-#
-# gives access to the fingerprint reader to those in the "fingerprint" group
-#
-# Taken from:
-# http://www.thinkwiki.org/wiki/How_to_enable_the_fingerprint_reader_with_ThinkFinger
-# which was taken and modified from:
-# http://article.gmane.org/gmane.linux.drivers.thinkfinger/329
-#
-
# SGS Thomson Microelectronics Fingerprint Reader
-SYSFS{idVendor}=="0483", SYSFS{idProduct}=="2016", SYMLINK+="input/thinkfinger-%k", MODE="0660", GROUP="fingerprint"
+ATTRS{idVendor}=="0483", ATTRS{idProduct}=="2016", SYMLINK+="input/thinkfinger-%k", MODE="0660", GROUP="fingerprint"
# the also-needed uinput device
KERNEL=="uinput", MODE="0660", GROUP="fingerprint"
-
diff --git a/sys-auth/thinkfinger/thinkfinger-0.2.2-r1.ebuild b/sys-auth/thinkfinger/thinkfinger-0.2.2-r1.ebuild
deleted file mode 100644
index 8fb81356eda4..000000000000
--- a/sys-auth/thinkfinger/thinkfinger-0.2.2-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/thinkfinger-0.2.2-r1.ebuild,v 1.3 2007/02/27 14:58:09 peper Exp $
-
-inherit pam
-
-DESCRIPTION="Support for the UPEK/SGS Thomson Microelectronics fingerprint reader, often seen in Thinkpads"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://thinkfinger.sourceforge.net/"
-
-RDEPEND=">=dev-libs/libusb-0.1.12
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- >=dev-util/pkgconfig-0.9.0"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pam"
-
-src_compile() {
- econf \
- $(use_enable pam) \
- "--with-securedir=$(getpam_mod_dir)" \
- || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- keepdir /etc/pam_thinkfinger
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- elog "Use tf-tool --acquire to take a finger print"
- elog "tf-tool will write the finger print file to /tmp/test.bir"
- elog ""
- if useq pam ; then
- elog "To add a fingerprint to PAM, use tf-tool --add-user USERNAME"
- elog ""
- elog "Add the following to /etc/pam.d/system-auth after pam_env.so"
- elog "auth sufficient pam_thinkfinger.so"
- elog ""
- elog "Your system-auth should look similar to:"
- elog "auth required pam_env.so"
- elog "auth sufficient pam_thinkfinger.so"
- elog "auth sufficient pam_unix.so try_first_pass likeauth nullok"
- fi
-}
diff --git a/sys-auth/thinkfinger/thinkfinger-0.3-r1.ebuild b/sys-auth/thinkfinger/thinkfinger-0.3-r2.ebuild
index 80b5d14066d3..bf4e30e66186 100644
--- a/sys-auth/thinkfinger/thinkfinger-0.3-r1.ebuild
+++ b/sys-auth/thinkfinger/thinkfinger-0.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/thinkfinger-0.3-r1.ebuild,v 1.1 2009/02/18 15:37:38 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/thinkfinger-0.3-r2.ebuild,v 1.1 2010/04/11 15:33:02 chainsaw Exp $
inherit pam linux-info eutils
@@ -24,6 +24,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PV}-direct_set_config_usb_hello.patch" || die
epatch "${FILESDIR}/${PV}-carriagereturn.patch" || die
+ epatch "${FILESDIR}/${PV}-send-sync-event.patch" || die
epatch "${FILESDIR}/${PV}-tftoolgroup.patch" || die
}
diff --git a/sys-auth/thinkfinger/thinkfinger-0.3.ebuild b/sys-auth/thinkfinger/thinkfinger-0.3.ebuild
deleted file mode 100644
index bcb7ccc42a53..000000000000
--- a/sys-auth/thinkfinger/thinkfinger-0.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/thinkfinger-0.3.ebuild,v 1.2 2007/09/08 18:21:42 vapier Exp $
-
-inherit pam linux-info
-
-DESCRIPTION="Support for the UPEK/SGS Thomson Microelectronics fingerprint reader, often seen in Thinkpads"
-HOMEPAGE="http://thinkfinger.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug pam"
-
-RDEPEND=">=dev-libs/libusb-0.1.12
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- sys-devel/libtool
- >=dev-util/pkgconfig-0.9.0"
-
-pkg_setup() {
- if use pam ; then
- CONFIG_CHECK="~INPUT_UINPUT"
- ERROR_CFG="Your kernel needs uinput for the pam module to work"
- check_extra_config
- fi
-}
-
-src_compile() {
- econf \
- $(use_enable pam) \
- $(use_enable debug usb-debug) \
- "--with-securedir=$(getpam_mod_dir)" \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- keepdir /etc/pam_thinkfinger
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- elog "Use tf-tool --acquire to take a finger print"
- elog "tf-tool will write the finger print file to /tmp/test.bir"
- elog ""
- if use pam ; then
- elog "To add a fingerprint to PAM, use tf-tool --add-user USERNAME"
- elog ""
- elog "Add the following to /etc/pam.d/system-auth after pam_env.so"
- elog "auth sufficient pam_thinkfinger.so"
- elog ""
- elog "Your system-auth should look similar to:"
- elog "auth required pam_env.so"
- elog "auth sufficient pam_thinkfinger.so"
- elog "auth sufficient pam_unix.so try_first_pass likeauth nullok"
- fi
-}