summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-02-16 22:16:28 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-02-16 22:16:28 +0000
commit4159bf6ead24e32a07abd56acba239b23e7510ab (patch)
tree97517a7a03c993493a4ba667929782d5f4498dcf /sys-block/iscsitarget
parentVersion bump. Dropped m68k bug 324097. Dropped s390 and sh bug 355253. (diff)
downloadgentoo-2-4159bf6ead24e32a07abd56acba239b23e7510ab.tar.gz
gentoo-2-4159bf6ead24e32a07abd56acba239b23e7510ab.tar.bz2
gentoo-2-4159bf6ead24e32a07abd56acba239b23e7510ab.zip
Respect LDFLAGS. Thanks to Stefan Behte and Kacper Kowalik for the patch. Bug #350742. Stable on amd64 wrt bug #349436
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/iscsitarget')
-rw-r--r--sys-block/iscsitarget/ChangeLog9
-rw-r--r--sys-block/iscsitarget/files/iscsitarget-1.4.20.2-respect-flags.patch32
-rw-r--r--sys-block/iscsitarget/iscsitarget-1.4.20.2.ebuild8
3 files changed, 44 insertions, 5 deletions
diff --git a/sys-block/iscsitarget/ChangeLog b/sys-block/iscsitarget/ChangeLog
index d08284c43e38..e84791341390 100644
--- a/sys-block/iscsitarget/ChangeLog
+++ b/sys-block/iscsitarget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/iscsitarget
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/ChangeLog,v 1.39 2010/12/25 19:42:25 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/ChangeLog,v 1.40 2011/02/16 22:16:27 hwoarang Exp $
+
+ 16 Feb 2011; Markos Chandras <hwoarang@gentoo.org>
+ iscsitarget-1.4.20.2.ebuild, +files/iscsitarget-1.4.20.2-respect-flags.patch:
+ Respect LDFLAGS. Thanks to Stefan Behte and Kacper Kowalik for the patch. Bug
+ #350742. Stable on amd64 wrt bug #349436
25 Dec 2010; Christian Faulhammer <fauli@gentoo.org>
iscsitarget-1.4.20.2.ebuild:
diff --git a/sys-block/iscsitarget/files/iscsitarget-1.4.20.2-respect-flags.patch b/sys-block/iscsitarget/files/iscsitarget-1.4.20.2-respect-flags.patch
new file mode 100644
index 000000000000..347650ab9407
--- /dev/null
+++ b/sys-block/iscsitarget/files/iscsitarget-1.4.20.2-respect-flags.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -26,7 +26,7 @@
+ endif
+ endif
+
+-KVER := $(shell $(CC) $(CFLAGS) -E -dM $(VERSION_FILE) | \
++KVER := $(shell $(CC) $(CFLAGS) $(LDFLAGS) -E -dM $(VERSION_FILE) | \
+ grep UTS_RELEASE | awk '{ print $$3 }' | sed 's/\"//g')
+
+ KMOD := /lib/modules/$(KVER)/extra
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS += -O2 -fno-inline -Wall -Wstrict-prototypes -g -I../include
++CFLAGS += -fno-inline -Wall -Wstrict-prototypes -I../include
+ CFLAGS += -D_GNU_SOURCE # required for glibc >= 2.8
+ PROGRAMS = ietd ietadm
+ LIBS =
+@@ -7,10 +7,10 @@
+
+ ietd: ietd.o iscsid.o conn.o session.o target.o message.o ctldev.o log.o chap.o event.o param.o plain.o isns.o md5.o sha1.o
+
+- $(CC) $^ -o $@ $(LIBS)
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ ietadm: ietadm.o param.o
+- $(CC) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@
+
+ clean:
+ rm -f *.o $(PROGRAMS)
diff --git a/sys-block/iscsitarget/iscsitarget-1.4.20.2.ebuild b/sys-block/iscsitarget/iscsitarget-1.4.20.2.ebuild
index 750716c8f765..78b8fea75a14 100644
--- a/sys-block/iscsitarget/iscsitarget-1.4.20.2.ebuild
+++ b/sys-block/iscsitarget/iscsitarget-1.4.20.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/iscsitarget-1.4.20.2.ebuild,v 1.3 2010/12/25 19:42:25 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/iscsitarget-1.4.20.2.ebuild,v 1.4 2011/02/16 22:16:27 hwoarang Exp $
inherit linux-mod eutils flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE=""
DEPEND="dev-libs/openssl"
@@ -24,6 +24,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.4.15-isns-set-scn-flag.patch #180619
+ # Respect LDFLAGS. Bug #350742
+ epatch "${FILESDIR}"/${P}-respect-flags.patch
# NIPQUAD removed in 2.6.36, #340449
if kernel_is ge 2 6 36; then
epatch "${FILESDIR}"/iscsitarget-1.4.20.2_kernel-2.6.36.patch