summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-06 00:50:07 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-06 00:50:07 +0000
commit67740e86bb29b86332ee9e45b6c6e288959f5850 (patch)
tree48d7dc9b7f3cd5295df675a9be76948c0de6c266 /sys-block/nwutil/nwutil-1.4.ebuild
parentMarked ~ppc for bug #83706. (diff)
downloadgentoo-2-67740e86bb29b86332ee9e45b6c6e288959f5850.tar.gz
gentoo-2-67740e86bb29b86332ee9e45b6c6e288959f5850.tar.bz2
gentoo-2-67740e86bb29b86332ee9e45b6c6e288959f5850.zip
Moved from sys-apps/nwutil to sys-block/nwutil.
Diffstat (limited to 'sys-block/nwutil/nwutil-1.4.ebuild')
-rw-r--r--sys-block/nwutil/nwutil-1.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-block/nwutil/nwutil-1.4.ebuild b/sys-block/nwutil/nwutil-1.4.ebuild
new file mode 100644
index 000000000000..509320ce2e85
--- /dev/null
+++ b/sys-block/nwutil/nwutil-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/nwutil/nwutil-1.4.ebuild,v 1.1 2005/03/06 00:50:07 ciaranm Exp $
+
+inherit eutils
+
+DEB_VER=3
+DESCRIPTION="Netwinder hardware utilities"
+HOMEPAGE="http://packages.debian.org/stable/base/nwutil"
+SRC_URI="mirror://debian/pool/main/n/nwutil/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/n/nwutil/${PN}_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* arm"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${PN}_${PV}-${DEB_VER}.diff
+ epatch ${FILESDIR}/${PV}-errno.patch
+ epatch ${FILESDIR}/${PV}-rename-debug.patch
+ mv {,nw}debug.c; mv {,nw}debug.8
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake main failed"
+ cd flashlogo
+ emake || die "emake flashlogo failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install main failed"
+ cd flashlogo
+ make DESTDIR=${D} install || die "install flashlogo failed"
+}