summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-15 10:09:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-15 10:09:19 +0000
commit8b01791996a5a44deafb20aeb2af5edae901d8d6 (patch)
treee9fab9eb92ec3039ec2b7ff9f550435256dd21ae /sys-block
parentAutomatically create directory structure necessary for normal operation as su... (diff)
downloadgentoo-2-8b01791996a5a44deafb20aeb2af5edae901d8d6.tar.gz
gentoo-2-8b01791996a5a44deafb20aeb2af5edae901d8d6.tar.bz2
gentoo-2-8b01791996a5a44deafb20aeb2af5edae901d8d6.zip
Add new revision with pmount useflag to work better when coupled with pmount wrappers.
(Portage version: 2.1)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/unieject/ChangeLog9
-rw-r--r--sys-block/unieject/files/digest-unieject-5.2-r13
-rw-r--r--sys-block/unieject/unieject-5.2-r1.ebuild80
3 files changed, 91 insertions, 1 deletions
diff --git a/sys-block/unieject/ChangeLog b/sys-block/unieject/ChangeLog
index 11afcb343720..5d5c64158d3e 100644
--- a/sys-block/unieject/ChangeLog
+++ b/sys-block/unieject/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/unieject
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.23 2006/06/05 05:50:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.24 2006/06/15 10:09:19 flameeyes Exp $
+
+*unieject-5.2-r1 (15 Jun 2006)
+
+ 15 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +unieject-5.2-r1.ebuild:
+ Add new revision with pmount useflag to work better when coupled with pmount
+ wrappers.
*unieject-5.2 (05 Jun 2006)
diff --git a/sys-block/unieject/files/digest-unieject-5.2-r1 b/sys-block/unieject/files/digest-unieject-5.2-r1
new file mode 100644
index 000000000000..9319bdf13bf7
--- /dev/null
+++ b/sys-block/unieject/files/digest-unieject-5.2-r1
@@ -0,0 +1,3 @@
+MD5 3028c259b1f600900cccac2f89f3ed21 unieject-5.2.tar.bz2 301463
+RMD160 61edef4319c2accef9693fdf1143cabd3a2e109a unieject-5.2.tar.bz2 301463
+SHA256 866e72717a162d59e09bcc9d998e5e0347eb22874481e9dcb7af04c9e0dc8bfd unieject-5.2.tar.bz2 301463
diff --git a/sys-block/unieject/unieject-5.2-r1.ebuild b/sys-block/unieject/unieject-5.2-r1.ebuild
new file mode 100644
index 000000000000..7b16e44a5a57
--- /dev/null
+++ b/sys-block/unieject/unieject-5.2-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/unieject-5.2-r1.ebuild,v 1.1 2006/06/15 10:09:19 flameeyes Exp $
+
+inherit libtool
+
+DESCRIPTION="Multiplatform command to eject and load CD-Rom drives"
+HOMEPAGE="http://dev.gentoo.org/~flameeyes/projects"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86-fbsd"
+IUSE="nls pmount"
+
+RDEPEND=">=dev-libs/libcdio-0.75-r1
+ dev-libs/popt
+ >=dev-libs/confuse-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/sed"
+RDEPEND="${RDEPEND}
+ pmount? ( sys-apps/pmount )
+ !sys-apps/eject
+ !sys-block/eject-bsd"
+
+PROVIDE="virtual/eject"
+
+pkg_setup() {
+ use pmount && enewgroup plugdev
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # libcdio-0.75-r1 in Gentoo is fixed, so no need to ask 0.76 either on
+ # FreeBSD.
+ sed -i -e '/freebsd/s:libcdiomin="0\.76":libcdiomin="0.75":' \
+ ${S}/configure
+
+ elibtoolize
+}
+
+src_compile() {
+ use pmount && append-ldflags "-Wl,-z,now"
+
+ econf \
+ $(use_enable nls) \
+ --enable-lock-workaround \
+ --disable-dependency-tracking \
+ --disable-doc \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README ChangeLog NEWS AUTHORS unieject.conf.sample
+
+ # Symlink to eject to provide a good virtual/eject
+ dosym unieject.1.gz /usr/share/man/man1/eject.1.gz
+ dosym unieject /usr/bin/eject
+
+ # If we enable support for pmount, we need to change the installed
+ # configuration file to enable the unmount wrapper, and we also set the
+ # command setuid root but in group plugdev, so that it's inlined with pmount
+ # itself.
+ if use pmount; then
+ fowners root:plugdev /usr/bin/unieject
+ fperms 1710 /usr/bin/unieject
+ chmod +s "${D}/usr/bin/unieject"
+
+ dodir /etc
+ sed -e 's:^# \(unmount-wrapper = \):\1:' \
+ "${S}/unieject.conf.sample" \
+ > "${D}/etc/unieject.conf"
+ fi
+}