summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-06-17 07:21:51 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-06-17 07:21:51 +0000
commit91fcb3ce8a4f4af84510dbb854f024f4db2fb3fc (patch)
treed91a8791fe34e05408d6ff2a67254c2d61f47eef /sys-block
parentRevision bump: EAPI 5, epatch_user, fix building with new ffmpeg/libav, wrt b... (diff)
downloadgentoo-2-91fcb3ce8a4f4af84510dbb854f024f4db2fb3fc.tar.gz
gentoo-2-91fcb3ce8a4f4af84510dbb854f024f4db2fb3fc.tar.bz2
gentoo-2-91fcb3ce8a4f4af84510dbb854f024f4db2fb3fc.zip
Version bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/megacli/ChangeLog7
-rw-r--r--sys-block/megacli/megacli-8.07.07.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/sys-block/megacli/ChangeLog b/sys-block/megacli/ChangeLog
index 342f9c88621c..37f0fe0241ca 100644
--- a/sys-block/megacli/ChangeLog
+++ b/sys-block/megacli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/megacli
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/ChangeLog,v 1.17 2013/06/17 06:55:33 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/ChangeLog,v 1.18 2013/06/17 07:21:51 xarthisius Exp $
+
+*megacli-8.07.07 (17 Jun 2013)
+
+ 17 Jun 2013; Kacper Kowalik <xarthisius@gentoo.org> +megacli-8.07.07.ebuild:
+ Version bump
17 Jun 2013; Kacper Kowalik <xarthisius@gentoo.org> metadata.xml:
Take over the maintainership
diff --git a/sys-block/megacli/megacli-8.07.07.ebuild b/sys-block/megacli/megacli-8.07.07.ebuild
new file mode 100644
index 000000000000..c6be559bc785
--- /dev/null
+++ b/sys-block/megacli/megacli-8.07.07.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/megacli-8.07.07.ebuild,v 1.1 2013/06/17 07:21:51 xarthisius Exp $
+
+EAPI=5
+
+inherit rpm
+
+DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
+HOMEPAGE="http://www.lsi.com/"
+SRC_URI="http://www.lsi.com/downloads/Public/MegaRAID%20Common%20Files/${PV}_MegaCLI.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ app-admin/chrpath"
+RDEPEND=""
+
+S=${WORKDIR}
+
+RESTRICT="mirror fetch"
+QA_PREBUILT="/opt/${PN}/${PN}
+ /opt/${PN}/lib/*"
+
+pkg_nofetch() {
+ einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
+ einfo "Please visit $SRC_URI"
+ einfo "And place $A in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rpm_unpack ./linux/MegaCli-${PV}-1.noarch.rpm
+}
+
+src_install() {
+ exeinto /opt/megacli
+ libsysfs=libstorelibir-2.so.13.05-0
+ case ${ARCH} in
+ amd64) MegaCli=MegaCli64;;
+ x86) MegaCli=MegaCli;;
+ *) die "invalid ARCH";;
+ esac
+ newexe opt/MegaRAID/MegaCli/${MegaCli} ${PN}
+
+ exeinto /opt/${PN}/lib
+ doexe opt/MegaRAID/MegaCli/${libsysfs}
+
+ into /opt
+ newbin "${FILESDIR}"/${PN}-wrapper ${PN}
+ dosym ${PN} /opt/bin/MegaCli
+
+ dodoc ${PV}_MegaCLI.txt
+
+ # Remove DT_RPATH
+ chrpath -d "${D}"/opt/${PN}/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See /usr/share/doc/${PF}/${PV}_MegaCli.txt for a list of supported controllers"
+ einfo "(contains LSI model names only, not those sold by 3rd parties"
+ einfo "under custom names like Dell PERC etc)."
+ einfo
+ einfo "As there's no dedicated manual, you might want to have"
+ einfo "a look at the following cheat sheet (originally written"
+ einfo "for Dell PowerEdge Expandable RAID Controllers):"
+ einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
+ einfo
+ einfo "For more information about working with Dell PERCs see:"
+ einfo "http://tools.rapidsoft.de/perc/"
+ einfo
+}