summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-25 08:40:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-25 08:40:43 +0000
commitc746d3e79addae4651a38077110e08c783860408 (patch)
tree23a1606dec895e7a35cbf744654cf89a969efd5a /sys-boot/mbr-gpt
parentNew version of the Gentoo grub patchset. Provides support for 256-byte ext3 i... (diff)
downloadgentoo-2-c746d3e79addae4651a38077110e08c783860408.tar.gz
gentoo-2-c746d3e79addae4651a38077110e08c783860408.tar.bz2
gentoo-2-c746d3e79addae4651a38077110e08c783860408.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>. This is useful for testing crazy GPT setups.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot/mbr-gpt')
-rw-r--r--sys-boot/mbr-gpt/ChangeLog11
-rw-r--r--sys-boot/mbr-gpt/Manifest4
-rw-r--r--sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild52
-rw-r--r--sys-boot/mbr-gpt/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/sys-boot/mbr-gpt/ChangeLog b/sys-boot/mbr-gpt/ChangeLog
new file mode 100644
index 000000000000..a8aa1d5fbed0
--- /dev/null
+++ b/sys-boot/mbr-gpt/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-boot/mbr-gpt
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/mbr-gpt/ChangeLog,v 1.1 2008/03/25 08:40:43 robbat2 Exp $
+
+*mbr-gpt-0.0.1 (25 Mar 2008)
+
+ 25 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +mbr-gpt-0.0.1.ebuild:
+ Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>. This is
+ useful for testing crazy GPT setups.
+
diff --git a/sys-boot/mbr-gpt/Manifest b/sys-boot/mbr-gpt/Manifest
new file mode 100644
index 000000000000..fa12adaf4581
--- /dev/null
+++ b/sys-boot/mbr-gpt/Manifest
@@ -0,0 +1,4 @@
+DIST mbr-gpt_0.0.1.tar.gz 15861 RMD160 1d61afc95e558951709b604e6695a0cfbbf9d5f7 SHA1 e9cd243b8f139169edaf18ea5562a198270a7746 SHA256 c66cc48c6034f1db72ddba187a52f590001a946f87478171b3d362b601b26bc2
+EBUILD mbr-gpt-0.0.1.ebuild 1404 RMD160 e8b1186634990b139b1b0483c9802ca1bfc1e987 SHA1 40f24b4fc00849bad3a7ce6a54876c31937b04d1 SHA256 81be773fb0f060c0c52b13e567b53f690996a158fd5d9da9d343c50a875cd490
+MISC ChangeLog 355 RMD160 fb20be9e2d97d9008e8d3292cc249bc3664463c3 SHA1 a6647f723af382a3baf647bea12d972a1ab568ab SHA256 9d5b99e7a7fb89eee4dafbab5219dc3884e75bc9d4b3c90699c0f967b7e2723e
+MISC metadata.xml 227 RMD160 e54f63c709ba122fa8d5931652deb3821a967981 SHA1 84c05df3fda91de26beaaf15ffdbf4ea15b3784b SHA256 eb6179099f91f31168c95bd4a018a01f37aa1eb8d9ba8d3ed039056bac71bcf8
diff --git a/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild b/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
new file mode 100644
index 000000000000..4f82a8beb6dd
--- /dev/null
+++ b/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild,v 1.1 2008/03/25 08:40:43 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="An MBR that can handle BIOS-based boot on GPT."
+MY_P="${PN}_${PV}"
+HOMEPAGE="http://aybabtu.com/mbr-gpt/"
+SRC_URI="http://aybabtu.com/mbr-gpt/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+# This should probably NEVER go to stable. It's crazy advanced dangerous magic.
+# It's also pure ASM, so not suitable for elsewhere anyway.
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+# It only depends on binutils/gcc/make, and doesn't link against libc even.
+DEPEND=""
+RDEPEND=""
+
+# It's a mostly an MBR block and it does use the executable stack.
+QA_WX_LOAD="usr/sbin/boot.elf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ emake clean
+
+ # Need to build it 32-bit for the MBR
+ # Btw, no CFLAGS are respected, it's ASM!
+ use amd64 && sed -i -e 's/-Wall/-Wall -m32/g' "${S}"/Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ # get_libdir is not correct here. We want this to go into a 32-bit library
+ # location.
+ insinto /usr/lib/mbr-gpt/
+ doins mbr
+ dosbin boot.elf
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ einfo "See the instructions on the homepage, and make sure you know what"
+ einfo "you are doing before touching this. The mbr file does into your"
+ einfo "MBR, or alternatively you can do a creative reboot utilizing the"
+ einfo "boot.elf binary."
+}
diff --git a/sys-boot/mbr-gpt/metadata.xml b/sys-boot/mbr-gpt/metadata.xml
new file mode 100644
index 000000000000..035bc6b0e2cd
--- /dev/null
+++ b/sys-boot/mbr-gpt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>