summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-17 19:10:26 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-17 19:10:26 +0000
commitd40b3950dcc2be59b4286eaffd86b97b3e773c9b (patch)
tree74a949895ca8e0076d5e535e75083e0f0e0757ef /sys-boot/raspberrypi-firmware
parentMask Raspberry Pi upstream next versions. (diff)
downloadgentoo-2-d40b3950dcc2be59b4286eaffd86b97b3e773c9b.tar.gz
gentoo-2-d40b3950dcc2be59b4286eaffd86b97b3e773c9b.tar.bz2
gentoo-2-d40b3950dcc2be59b4286eaffd86b97b3e773c9b.zip
Version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-boot/raspberrypi-firmware')
-rw-r--r--sys-boot/raspberrypi-firmware/ChangeLog12
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130715.ebuild51
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.6.ebuild42
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.9.ebuild (renamed from sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild)5
4 files changed, 107 insertions, 3 deletions
diff --git a/sys-boot/raspberrypi-firmware/ChangeLog b/sys-boot/raspberrypi-firmware/ChangeLog
index c95b85431ae3..cd40ee5e5a3c 100644
--- a/sys-boot/raspberrypi-firmware/ChangeLog
+++ b/sys-boot/raspberrypi-firmware/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-boot/raspberrypi-firmware
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.2 2013/07/15 11:34:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.3 2013/07/17 19:10:26 xmw Exp $
+
+*raspberrypi-firmware-9999.3.9 (17 Jul 2013)
+*raspberrypi-firmware-1_pre20130715 (17 Jul 2013)
+*raspberrypi-firmware-9999.3.6 (17 Jul 2013)
+
+ 17 Jul 2013; Michael Weber <xmw@gentoo.org>
+ +raspberrypi-firmware-1_pre20130715.ebuild,
+ +raspberrypi-firmware-9999.3.6.ebuild, +raspberrypi-firmware-9999.3.9.ebuild,
+ -raspberrypi-firmware-9999.ebuild:
+ Version bump
15 Jul 2013; Michael Weber <xmw@gentoo.org>
+files/raspberrypi-firmware-0_p20130711-cmdline.txt,
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130715.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130715.ebuild
new file mode 100644
index 000000000000..a7f62c0811b0
--- /dev/null
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130715.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130715.ebuild,v 1.1 2013/07/17 19:10:26 xmw Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="Raspberry PI boot loader and firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_COMMIT="9e9acf8978"
+SRC_URI=""
+for my_src_uri in bootcode.bin fixup{,_cd,_x}.dat start{,_cd,_x}.elf ; do
+ SRC_URI="${SRC_URI} https://github.com/raspberrypi/firmware/raw/${MY_COMMIT}/boot/${my_src_uri} -> ${PN}-${MY_COMMIT}-${my_src_uri}"
+done
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!sys-boot/raspberrypi-loader"
+
+S=${WORKDIR}
+
+RESTRICT="binchecks strip"
+
+src_unpack() { :; }
+
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ if [ -e /boot/cmdline.txt -o -e /boot/config.txt ] ; then
+ die "Please backup and remove /boot/cmdline.txt and /boot/config.txt to and merge configs after installation."
+ fi
+ fi
+}
+
+src_install() {
+ insinto /boot
+ local a
+ for a in ${A} ; do
+ newins "${DISTDIR}"/${a} ${a#${PN}-${MY_COMMIT}-}
+ done
+ newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.6.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.6.ebuild
new file mode 100644
index 000000000000..945fbd902632
--- /dev/null
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.6.ebuild,v 1.1 2013/07/17 19:10:26 xmw Exp $
+
+EAPI=5
+
+inherit git-2 readme.gentoo
+
+DESCRIPTION="Raspberry PI boot loader and firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+EGIT_REPO_URI="https://github.com/raspberrypi/firmware.git"
+EGIT_PROJECT="raspberrypi-firmware.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="!sys-boot/raspberrypi-loader"
+
+RESTRICT="binchecks strip"
+
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ if [ -e /boot/cmdline.txt -o -e /boot/config.txt ] ; then
+ die "Please backup and remove /boot/cmdline.txt and /boot/config.txt to and merge configs after installation."
+ fi
+ fi
+}
+
+src_install() {
+ insinto /boot
+ doins boot/bootcode.bin boot/fixup*.dat boot/start*.elf
+ newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.9.ebuild
index 37b38beddfb7..01f7071dec1e 100644
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild,v 1.2 2013/07/15 11:34:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.3.9.ebuild,v 1.1 2013/07/17 19:10:26 xmw Exp $
EAPI=5
@@ -10,6 +10,7 @@ DESCRIPTION="Raspberry PI boot loader and firmware"
HOMEPAGE="https://github.com/raspberrypi/firmware"
EGIT_REPO_URI="https://github.com/raspberrypi/firmware.git"
EGIT_PROJECT="raspberrypi-firmware.git"
+EGIT_BRANCH="next"
LICENSE="GPL-2 raspberrypi-videocore-bin"
SLOT="0"
@@ -31,7 +32,7 @@ pkg_preinst() {
src_install() {
insinto /boot
- doins bootcode.bin boot/fixup*.dat boot/start*.elf
+ doins boot/bootcode.bin boot/fixup*.dat boot/start*.elf
newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}