summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-23 11:56:54 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-23 11:56:54 +0000
commit09011fd95f8773fa51e39f1838da956511a050b6 (patch)
treeb25390b1b07948c7459fb151e7e51fbdcb876e26 /sys-boot/syslinux
parentNew patch set. (diff)
downloadgentoo-2-09011fd95f8773fa51e39f1838da956511a050b6.tar.gz
gentoo-2-09011fd95f8773fa51e39f1838da956511a050b6.tar.bz2
gentoo-2-09011fd95f8773fa51e39f1838da956511a050b6.zip
sys-boot/syslinux: Drop QA check for CFLAGS with USE=-custom-cflags
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/syslinux-4.07.ebuild10
-rw-r--r--sys-boot/syslinux/syslinux-5.00.ebuild10
-rw-r--r--sys-boot/syslinux/syslinux-5.01.ebuild10
-rw-r--r--sys-boot/syslinux/syslinux-5.10.ebuild10
-rw-r--r--sys-boot/syslinux/syslinux-6.02_pre15.ebuild10
-rw-r--r--sys-boot/syslinux/syslinux-6.02_pre16.ebuild10
7 files changed, 60 insertions, 7 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 4c2ad6a61f30..4e13d3c97d9a 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.104 2013/09/22 06:47:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.105 2013/09/23 11:56:54 jlec Exp $
+
+ 23 Sep 2013; Justin Lecher <jlec@gentoo.org> syslinux-4.07.ebuild,
+ syslinux-5.00.ebuild, syslinux-5.01.ebuild, syslinux-5.10.ebuild,
+ syslinux-6.02_pre15.ebuild, syslinux-6.02_pre16.ebuild:
+ Drop QA check for CFLAGS with USE=-custom-cflags
22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> syslinux-4.07.ebuild:
Stable for x86, wrt bug #485048
diff --git a/sys-boot/syslinux/syslinux-4.07.ebuild b/sys-boot/syslinux/syslinux-4.07.ebuild
index 1281ff5fa32d..f5272d142276 100644
--- a/sys-boot/syslinux/syslinux-4.07.ebuild
+++ b/sys-boot/syslinux/syslinux-4.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-4.07.ebuild,v 1.3 2013/09/22 06:47:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-4.07.ebuild,v 1.4 2013/09/23 11:56:54 jlec Exp $
inherit eutils toolchain-funcs
@@ -47,6 +47,14 @@ src_unpack() {
-e 's|-Os||g' \
-e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
|| die "sed custom-cflags failed"
+ else
+ QA_FLAGS_IGNORED="
+ /sbin/extlinux
+ /usr/bin/memdiskfind
+ /usr/bin/gethostip
+ /usr/bin/isohybrid
+ /usr/bin/syslinux
+ "
fi
}
diff --git a/sys-boot/syslinux/syslinux-5.00.ebuild b/sys-boot/syslinux/syslinux-5.00.ebuild
index f2d6d196d7e4..f7ad29d423a1 100644
--- a/sys-boot/syslinux/syslinux-5.00.ebuild
+++ b/sys-boot/syslinux/syslinux-5.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-5.00.ebuild,v 1.3 2013/01/11 17:24:42 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-5.00.ebuild,v 1.4 2013/09/23 11:56:54 jlec Exp $
EAPI=4
@@ -50,6 +50,14 @@ src_prepare() {
-e 's|-Os||g' \
-e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
|| die "sed custom-cflags failed"
+ else
+ QA_FLAGS_IGNORED="
+ /sbin/extlinux
+ /usr/bin/memdiskfind
+ /usr/bin/gethostip
+ /usr/bin/isohybrid
+ /usr/bin/syslinux
+ "
fi
}
diff --git a/sys-boot/syslinux/syslinux-5.01.ebuild b/sys-boot/syslinux/syslinux-5.01.ebuild
index 4ec3ad88dbf8..c20d879e388f 100644
--- a/sys-boot/syslinux/syslinux-5.01.ebuild
+++ b/sys-boot/syslinux/syslinux-5.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-5.01.ebuild,v 1.2 2013/06/02 15:23:29 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-5.01.ebuild,v 1.3 2013/09/23 11:56:54 jlec Exp $
EAPI=4
@@ -50,6 +50,14 @@ src_prepare() {
-e 's|-Os||g' \
-e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
|| die "sed custom-cflags failed"
+ else
+ QA_FLAGS_IGNORED="
+ /sbin/extlinux
+ /usr/bin/memdiskfind
+ /usr/bin/gethostip
+ /usr/bin/isohybrid
+ /usr/bin/syslinux
+ "
fi
}
diff --git a/sys-boot/syslinux/syslinux-5.10.ebuild b/sys-boot/syslinux/syslinux-5.10.ebuild
index 49f4080fbf31..2bccbb5fc9cb 100644
--- a/sys-boot/syslinux/syslinux-5.10.ebuild
+++ b/sys-boot/syslinux/syslinux-5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-5.10.ebuild,v 1.1 2013/06/24 13:58:11 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-5.10.ebuild,v 1.2 2013/09/23 11:56:54 jlec Exp $
EAPI=4
@@ -50,6 +50,14 @@ src_prepare() {
-e 's|-Os||g' \
-e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
|| die "sed custom-cflags failed"
+ else
+ QA_FLAGS_IGNORED="
+ /sbin/extlinux
+ /usr/bin/memdiskfind
+ /usr/bin/gethostip
+ /usr/bin/isohybrid
+ /usr/bin/syslinux
+ "
fi
}
diff --git a/sys-boot/syslinux/syslinux-6.02_pre15.ebuild b/sys-boot/syslinux/syslinux-6.02_pre15.ebuild
index 5d73195c0f66..59ccac9d97b4 100644
--- a/sys-boot/syslinux/syslinux-6.02_pre15.ebuild
+++ b/sys-boot/syslinux/syslinux-6.02_pre15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-6.02_pre15.ebuild,v 1.1 2013/07/30 14:48:26 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-6.02_pre15.ebuild,v 1.2 2013/09/23 11:56:54 jlec Exp $
EAPI=4
@@ -48,6 +48,14 @@ src_prepare() {
-e 's|-Os||g' \
-e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
|| die "sed custom-cflags failed"
+ else
+ QA_FLAGS_IGNORED="
+ /sbin/extlinux
+ /usr/bin/memdiskfind
+ /usr/bin/gethostip
+ /usr/bin/isohybrid
+ /usr/bin/syslinux
+ "
fi
case ${ARCH} in
amd64) loaderarch="efi64" ;;
diff --git a/sys-boot/syslinux/syslinux-6.02_pre16.ebuild b/sys-boot/syslinux/syslinux-6.02_pre16.ebuild
index 2cc6d43fde40..35f47a257320 100644
--- a/sys-boot/syslinux/syslinux-6.02_pre16.ebuild
+++ b/sys-boot/syslinux/syslinux-6.02_pre16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-6.02_pre16.ebuild,v 1.1 2013/08/13 06:50:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-6.02_pre16.ebuild,v 1.2 2013/09/23 11:56:54 jlec Exp $
EAPI=4
@@ -48,6 +48,14 @@ src_prepare() {
-e 's|-Os||g' \
-e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
|| die "sed custom-cflags failed"
+ else
+ QA_FLAGS_IGNORED="
+ /sbin/extlinux
+ /usr/bin/memdiskfind
+ /usr/bin/gethostip
+ /usr/bin/isohybrid
+ /usr/bin/syslinux
+ "
fi
case ${ARCH} in
amd64) loaderarch="efi64" ;;