summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-12-21 20:39:28 +0000
committerNed Ludd <solar@gentoo.org>2008-12-21 20:39:28 +0000
commit0f272c37dc53310cd04ee6d8a0a8af1a91c99b4b (patch)
tree359e21e3e45f0e2865a7e4b7b1aacd4f533bb8a1 /sys-boot/syslinux
parentAdded restrict=strip for #251851; thanks to flameeyes@gentoo.org. (diff)
downloadgentoo-2-0f272c37dc53310cd04ee6d8a0a8af1a91c99b4b.tar.gz
gentoo-2-0f272c37dc53310cd04ee6d8a0a8af1a91c99b4b.tar.bz2
gentoo-2-0f272c37dc53310cd04ee6d8a0a8af1a91c99b4b.zip
- fix pie support and use local installer
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog6
-rw-r--r--sys-boot/syslinux/files/syslinux-3.72-nopie.patch2
-rw-r--r--sys-boot/syslinux/syslinux-3.72.ebuild4
3 files changed, 8 insertions, 4 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 981474822cf8..ad1e557fbee2 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.41 2008/12/21 13:48:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.42 2008/12/21 20:39:27 solar Exp $
+
+ 21 Dec 2008; <solar@gentoo.org> files/syslinux-3.72-nopie.patch,
+ syslinux-3.72.ebuild:
+ - fix pie support and use local installer
21 Dec 2008; Markus Meier <maekke@gentoo.org> syslinux-3.71.ebuild:
x86 stable, bug #251816
diff --git a/sys-boot/syslinux/files/syslinux-3.72-nopie.patch b/sys-boot/syslinux/files/syslinux-3.72-nopie.patch
index ea92b8fb5c60..2662d17b4387 100644
--- a/sys-boot/syslinux/files/syslinux-3.72-nopie.patch
+++ b/sys-boot/syslinux/files/syslinux-3.72-nopie.patch
@@ -6,7 +6,7 @@ diff -ur a/com32/MCONFIG b/com32/MCONFIG
$(call gcc_ok,-m32,) \
$(call gcc_ok,-fno-stack-protector,) \
+ $(call gcc_ok,-nopie,) \
-+ $(call gcc_ok,-fnopie,) \
++ $(call gcc_ok,-fno-pie,) \
-mregparm=3 -DREGPARM=3 -march=i386 -Os
com32 = $(topdir)/com32
diff --git a/sys-boot/syslinux/syslinux-3.72.ebuild b/sys-boot/syslinux/syslinux-3.72.ebuild
index e3eca7f285ac..8e73275807ef 100644
--- a/sys-boot/syslinux/syslinux-3.72.ebuild
+++ b/sys-boot/syslinux/syslinux-3.72.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.72.ebuild,v 1.1 2008/12/21 01:02:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.72.ebuild,v 1.2 2008/12/21 20:39:27 solar Exp $
inherit eutils
@@ -40,6 +40,6 @@ src_compile() {
}
src_install() {
- emake INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
+ emake INSTALLROOT="${D}" MANDIR=/usr/share/man local-install || die
dodoc README NEWS TODO doc/*
}