summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-03-23 16:47:47 +0000
committerJeroen Roovers <jer@gentoo.org>2011-03-23 16:47:47 +0000
commitd4737c7afb321ec0a9d93b7893fe108db5428427 (patch)
treece482410f611690b155d5162e04ec271c1cdafca /sys-boot
parentuse slot dep for gtk in old version too (diff)
downloadgentoo-2-d4737c7afb321ec0a9d93b7893fe108db5428427.tar.gz
gentoo-2-d4737c7afb321ec0a9d93b7893fe108db5428427.tar.bz2
gentoo-2-d4737c7afb321ec0a9d93b7893fe108db5428427.zip
Version bump.
(Portage version: 2.2.0_alpha28/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-506.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 15c6300c344d..823b21166066 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.54 2011/03/22 19:02:24 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.55 2011/03/23 16:47:47 jer Exp $
+
+*unetbootin-506 (23 Mar 2011)
+
+ 23 Mar 2011; Jeroen Roovers <jer@gentoo.org> +unetbootin-506.ebuild:
+ Version bump.
22 Mar 2011; Christoph Mende <angelos@gentoo.org> unetbootin-502.ebuild:
Stable on amd64 wrt bug #359869
diff --git a/sys-boot/unetbootin/unetbootin-506.ebuild b/sys-boot/unetbootin/unetbootin-506.ebuild
new file mode 100644
index 000000000000..15d5635348e0
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-506.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-506.ebuild,v 1.1 2011/03/23 16:47:47 jer Exp $
+
+EAPI="3"
+
+inherit qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_configure() {
+ lupdate unetbootin.pro || die "lupdate failed"
+ lrelease unetbootin.pro || die "lrelease failed"
+ eqmake4 unetbootin.pro || die "eqmake4 failed"
+}
+
+src_install() {
+ dobin unetbootin || die "dobin failed"
+ insinto /usr/share/applications
+ doins unetbootin.desktop || die "doins failed"
+}