summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2007-03-09 11:11:59 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2007-03-09 11:11:59 +0000
commit6e51f63ff5b3ba63f1bb35070f5c7e3abcfc4908 (patch)
tree2602840e4bfdfd42758072400a05764cd2047180 /sys-cluster/dlm/dlm-1.04.00.ebuild
parentstable x86; bug #169987 (diff)
downloadgentoo-2-6e51f63ff5b3ba63f1bb35070f5c7e3abcfc4908.tar.gz
gentoo-2-6e51f63ff5b3ba63f1bb35070f5c7e3abcfc4908.tar.bz2
gentoo-2-6e51f63ff5b3ba63f1bb35070f5c7e3abcfc4908.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-cluster/dlm/dlm-1.04.00.ebuild')
-rw-r--r--sys-cluster/dlm/dlm-1.04.00.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/dlm/dlm-1.04.00.ebuild b/sys-cluster/dlm/dlm-1.04.00.ebuild
new file mode 100644
index 000000000000..140f67660377
--- /dev/null
+++ b/sys-cluster/dlm/dlm-1.04.00.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/dlm/dlm-1.04.00.ebuild,v 1.1 2007/03/09 11:11:59 xmerlin Exp $
+
+CLUSTER_RELEASE="1.04.00"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+DESCRIPTION="General-purpose Distributed Lock Manager"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+IUSE=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+DEPEND="=sys-cluster/dlm-headers-${CLUSTER_RELEASE}*"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_compile() {
+ ./configure || die "configure problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install problem"
+ rm -f ${D}/usr/include/libdlm.h
+
+ newinitd ${FILESDIR}/${PN}.rc ${PN} || die
+ dodoc doc/*.txt
+}