summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-11-18 16:39:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-11-18 16:39:00 +0000
commit648f97d43c8319b5e24cde97f2c6bb1be72afdd6 (patch)
treead5c023600a4d15dc2276c20e78af370b7d9d3c2 /sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
parentAdding web documentation, bug #293608 (diff)
downloadgentoo-2-648f97d43c8319b5e24cde97f2c6bb1be72afdd6.tar.gz
gentoo-2-648f97d43c8319b5e24cde97f2c6bb1be72afdd6.tar.bz2
gentoo-2-648f97d43c8319b5e24cde97f2c6bb1be72afdd6.zip
Non-maintainer commit. Fix building with _FORTIFY_SOURCE=2 and recent gnutls wrt #285305. The bug has also -Wl,--as-needed patch which should be applied to Makefile.am instead of Makefile.in, so leaving it out, instead using append-ldflags $(no-as-needed) so that we have something that actually compiles.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/heartbeat/heartbeat-2.0.8.ebuild')
-rw-r--r--sys-cluster/heartbeat/heartbeat-2.0.8.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild b/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
index ad4f3acfcda6..15be1ef9a2ec 100644
--- a/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
+++ b/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild,v 1.15 2009/07/27 19:23:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild,v 1.16 2009/11/18 16:38:59 ssuominen Exp $
-inherit flag-o-matic eutils
+inherit autotools flag-o-matic eutils
DESCRIPTION="Heartbeat high availability cluster manager"
HOMEPAGE="http://www.linux-ha.org"
@@ -47,12 +47,24 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- #epatch "${FILESDIR}"/${P}-update-resources-failcount.patch || die
- epatch "${FILESDIR}"/${P}-crm-leaks.patch || die
- epatch "${FILESDIR}"/${P}-delay.patch || die
+ #epatch "${FILESDIR}"/${P}-update-resources-failcount.patch
+ epatch "${FILESDIR}"/${P}-crm-leaks.patch
+ epatch "${FILESDIR}"/${P}-delay.patch
+ epatch "${FILESDIR}"/${P}-glibc.patch
+ sed -i \
+ -e 's:libgnutls-config:pkg-config gnutls:g' \
+ lib/mgmt/Makefile.am \
+ lib/plugins/quorumd/Makefile.am \
+ lib/plugins/quorum/Makefile.am \
+ membership/quorumd/Makefile.am \
+ mgmt/client/Makefile.am \
+ mgmt/daemon/Makefile.am
+ eautoreconf
}
src_compile() {
+ # FIXME. See bug 285305.
+ append-ldflags $(no-as-needed)
./configure --prefix=/usr \
--mandir=/usr/share/man \
--sysconfdir=/etc \