summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-06-08 05:44:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-06-08 05:44:11 +0000
commit2c9561e4f96b49ec734d75603141f1ca1b306014 (patch)
tree5c8d803384086a130f4e5c6f4be5a2bbcae2a9fe /sys-cluster/keepalived
parentFix automagic dependency on libnl that is needed for working IPv6 support. (diff)
downloadgentoo-2-2c9561e4f96b49ec734d75603141f1ca1b306014.tar.gz
gentoo-2-2c9561e4f96b49ec734d75603141f1ca1b306014.tar.bz2
gentoo-2-2c9561e4f96b49ec734d75603141f1ca1b306014.zip
Add seperate variant that uses newer linux-headers instead of the bundled ip_vs.h. Tested on ipv6-ready forums.gentoo.org.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/keepalived')
-rw-r--r--sys-cluster/keepalived/ChangeLog9
-rw-r--r--sys-cluster/keepalived/keepalived-1.2.2-r1.ebuild56
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index dcf77ce33923..cb0512a72c33 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/keepalived
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.79 2011/06/08 05:38:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.80 2011/06/08 05:44:11 robbat2 Exp $
+
+*keepalived-1.2.2-r1 (08 Jun 2011)
+
+ 08 Jun 2011; Robin H. Johnson <robbat2@gentoo.org>
+ +keepalived-1.2.2-r1.ebuild:
+ Add seperate variant that uses newer linux-headers instead of the bundled
+ ip_vs.h. Tested on ipv6-ready forums.gentoo.org.
08 Jun 2011; Robin H. Johnson <robbat2@gentoo.org> keepalived-1.2.2.ebuild:
Fix automagic dependency on libnl that is needed for working IPv6 support.
diff --git a/sys-cluster/keepalived/keepalived-1.2.2-r1.ebuild b/sys-cluster/keepalived/keepalived-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..5358cb02ce81
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.2.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.2.2-r1.ebuild,v 1.1 2011/06/08 05:44:11 robbat2 Exp $
+
+EAPI=3
+
+inherit flag-o-matic autotools base
+
+DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://www.keepalived.org/"
+SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/popt
+ sys-apps/iproute2
+ dev-libs/libnl
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.30"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1.20-do-not-need-kernel-sources.patch )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ STRIP=/bin/true \
+ econf \
+ --enable-vrrp \
+ $(use_enable debug)
+}
+
+src_install() {
+ base_src_install
+
+ newinitd "${FILESDIR}"/init-keepalived keepalived || die
+
+ dodoc doc/keepalived.conf.SYNOPSIS || die
+ dodoc README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO || die
+
+ docinto genhash
+ dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION || die
+ # This was badly named by upstream, it's more HOWTO than anything else.
+ newdoc INSTALL INSTALL+HOWTO || die
+
+ # Security risk to bundle SSL certs
+ rm -f "${D}"/etc/keepalived/samples/*.pem
+ # Clean up sysvinit files
+ rm -rf "${D}"/etc/sysconfig "${D}"/etc/rc.d/
+}