summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-03-15 10:19:47 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-03-15 10:19:47 +0000
commitfcb97252e47a36cc8d2830cc40eb932d3874ad47 (patch)
treefed5ae3bf8c0e3c91a8b19ca90510d1799aeb6a8 /sys-cluster/pacemaker-gui
parentremove old (diff)
downloadgentoo-2-fcb97252e47a36cc8d2830cc40eb932d3874ad47.tar.gz
gentoo-2-fcb97252e47a36cc8d2830cc40eb932d3874ad47.tar.bz2
gentoo-2-fcb97252e47a36cc8d2830cc40eb932d3874ad47.zip
version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/pacemaker-gui')
-rw-r--r--sys-cluster/pacemaker-gui/ChangeLog10
-rw-r--r--sys-cluster/pacemaker-gui/files/pacemaker-mgmt-query-node-uuid.patch13
-rw-r--r--sys-cluster/pacemaker-gui/pacemaker-gui-2.1.2.ebuild91
3 files changed, 112 insertions, 2 deletions
diff --git a/sys-cluster/pacemaker-gui/ChangeLog b/sys-cluster/pacemaker-gui/ChangeLog
index 45c08545d238..6e1c596e850d 100644
--- a/sys-cluster/pacemaker-gui/ChangeLog
+++ b/sys-cluster/pacemaker-gui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/pacemaker-gui
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker-gui/ChangeLog,v 1.7 2012/11/23 11:05:57 ultrabug Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker-gui/ChangeLog,v 1.8 2013/03/15 10:19:47 ultrabug Exp $
+
+*pacemaker-gui-2.1.2 (15 Mar 2013)
+
+ 15 Mar 2013; Ultrabug <ultrabug@gentoo.org> +pacemaker-gui-2.1.2.ebuild,
+ +files/pacemaker-mgmt-query-node-uuid.patch:
+ Version bump supports newer pacemaker versions
23 Nov 2012; Ultrabug <ultrabug@gentoo.org> pacemaker-gui-2.1.1.ebuild:
Does not work with >=pacemaker-1.1.8
diff --git a/sys-cluster/pacemaker-gui/files/pacemaker-mgmt-query-node-uuid.patch b/sys-cluster/pacemaker-gui/files/pacemaker-mgmt-query-node-uuid.patch
new file mode 100644
index 000000000000..72d1ff5d183d
--- /dev/null
+++ b/sys-cluster/pacemaker-gui/files/pacemaker-mgmt-query-node-uuid.patch
@@ -0,0 +1,13 @@
+diff --git a/mgmt/daemon/mgmt_crm.c b/mgmt/daemon/mgmt_crm.c
+index 9e5140c..3b5ff36 100644
+--- a/mgmt/daemon/mgmt_crm.c
++++ b/mgmt/daemon/mgmt_crm.c
+@@ -1602,7 +1602,7 @@ on_cleanup_rsc(char* argv[], int argc)
+ delete_lrm_rsc(crmd_channel, argv[1], argv[2]);
+ refresh_lrm(crmd_channel, NULL);
+
+- rc = query_node_uuid(cib_conn, argv[1], &dest_node);
++ rc = query_node_uuid(cib_conn, argv[1], &dest_node, NULL);
+ if (rc != 0) {
+ mgmt_log(LOG_WARNING, "Could not map uname=%s to a UUID: %s\n",
+ argv[1], pcmk_strerror(rc));
diff --git a/sys-cluster/pacemaker-gui/pacemaker-gui-2.1.2.ebuild b/sys-cluster/pacemaker-gui/pacemaker-gui-2.1.2.ebuild
new file mode 100644
index 000000000000..9af32d363239
--- /dev/null
+++ b/sys-cluster/pacemaker-gui/pacemaker-gui-2.1.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker-gui/pacemaker-gui-2.1.2.ebuild,v 1.1 2013/03/15 10:19:47 ultrabug Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+MY_P="pacemaker-mgmt-${PV}"
+MY_TREE="3c95739"
+
+inherit python base autotools
+
+DESCRIPTION="Pacemaker python GUI and management daemon"
+HOMEPAGE="http://hg.clusterlabs.org/pacemaker/pygui/"
+SRC_URI="https://github.com/gao-yan/pacemaker-mgmt/tarball/${MY_P} -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="-gtk heartbeat nls snmp static-libs"
+
+CDEPEND="
+ app-arch/bzip2
+ dev-libs/glib:2
+ dev-libs/libxslt
+ dev-libs/openssl
+ net-libs/gnutls
+ sys-apps/util-linux
+ sys-cluster/cluster-glue
+ >=sys-cluster/pacemaker-1.1
+ heartbeat? ( sys-cluster/pacemaker[heartbeat] )
+ gtk? (
+ dev-python/pygtk
+ )
+ sys-libs/ncurses
+ sys-libs/pam
+ sys-libs/zlib"
+RDEPEND="${CDEPEND}
+ sys-devel/libtool"
+DEPEND="${CDEPEND}
+ gtk? ( dev-lang/swig )
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+S="${WORKDIR}/gao-yan-pacemaker-mgmt-${MY_TREE}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.1-doc.patch"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ base_src_prepare
+ # FIXME upstream said they will find a way to avoid this patch
+ if has_version ">sys-cluster/pacemaker-1.1.8"; then
+ epatch "${FILESDIR}"/pacemaker-mgmt-query-node-uuid.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ local myopts=""
+ use heartbeat || myopts="--with-ais-support"
+ econf $(use_with heartbeat heartbeat-support) \
+ $(use_enable snmp) \
+ $(use_enable nls) \
+ $(use_enable gtk mgmt-client) \
+ $(use_enable static-libs static) \
+ ${myopts} \
+ --disable-fatal-warnings
+}
+
+src_install() {
+ base_src_install
+ use static-libs || find "${D}"/usr/$(get_libdir)/ -name "*.la" -delete
+ dodoc README doc/AUTHORS || die
+}
+
+pkg_postinst() {
+ elog "IMPORTANT: To have the mgmtd daemon started with your cluster,"
+ elog "you must add this directive in /etc/corosync/service.d/pacemaker :"
+ elog ""
+ elog "use_mgmtd: 1"
+ elog ""
+ elog "NB: To access the GUI, your user must be part of the 'haclient' group"
+}