summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-05 20:03:08 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-05 20:03:08 +0000
commit9ea40cd45f6bb1aaa449db271e9f783b944b9c2f (patch)
tree89e6b75053f8753ea26fcc7b2626e37ed741597c /sys-cluster/torque
parentInitial commit. Shared package for openpbs/torque init scripts and stuff. (diff)
downloadgentoo-2-9ea40cd45f6bb1aaa449db271e9f783b944b9c2f.tar.gz
gentoo-2-9ea40cd45f6bb1aaa449db271e9f783b944b9c2f.tar.bz2
gentoo-2-9ea40cd45f6bb1aaa449db271e9f783b944b9c2f.zip
Revision bump for new virtual/pbs and shared init scripts. Fix libpbs location.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog8
-rw-r--r--sys-cluster/torque/Manifest4
-rw-r--r--sys-cluster/torque/files/digest-torque-1.2.0_p1-r21
-rw-r--r--sys-cluster/torque/torque-1.2.0_p1-r2.ebuild72
4 files changed, 83 insertions, 2 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index ea4ed91c4558..15af6df99eb6 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/torque
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.11 2005/07/05 01:11:23 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.12 2005/07/05 20:03:08 robbat2 Exp $
+
+*torque-1.2.0_p1-r2 (05 Jul 2005)
+
+ 05 Jul 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +torque-1.2.0_p1-r2.ebuild:
+ Revision bump for new virtual/pbs and shared init scripts. Fix libpbs location.
*torque-1.2.0_p1-r1 (05 Jul 2005)
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
index c1b5d052fec1..64b8789b46bf 100644
--- a/sys-cluster/torque/Manifest
+++ b/sys-cluster/torque/Manifest
@@ -1,6 +1,7 @@
-MD5 7dd1a27cf57520610867640d86e91ba3 torque-1.2.0_p1-r1.ebuild 1874
+MD5 84d5519eda13729bce677734bab450ee torque-1.2.0_p1-r1.ebuild 1917
MD5 c6f3121536e6adce335641c7a3c961ae torque-1.2.0_p1.ebuild 2312
MD5 38ff4b249a54a78f0a2d720fbf20b534 torque-1.0.1_p6.ebuild 1910
+MD5 30b40b56af688f5ca918620e16aef6b7 torque-1.2.0_p1-r2.ebuild 2098
MD5 68527e9f8b2b0c45d3ca6ae1508bb588 ChangeLog 2352
MD5 cde8b4e93c9339eb99fe3ad45941c99b metadata.xml 160
MD5 0358ef5f33cbdf1c0f764f1407677480 files/1.2.0_p1-respect-destdir.patch 21686
@@ -9,3 +10,4 @@ MD5 49d4d243a6dd96ba20531b240a7a32b6 files/digest-torque-1.0.1_p6 67
MD5 640bc8217559fa4bc7086a9eb9045b1e files/digest-torque-1.2.0_p1 67
MD5 e26e30bb1e82820df08330a7a9755aae files/1.2.0_p1-respect-ldflags.patch 2709
MD5 640bc8217559fa4bc7086a9eb9045b1e files/digest-torque-1.2.0_p1-r1 67
+MD5 640bc8217559fa4bc7086a9eb9045b1e files/digest-torque-1.2.0_p1-r2 67
diff --git a/sys-cluster/torque/files/digest-torque-1.2.0_p1-r2 b/sys-cluster/torque/files/digest-torque-1.2.0_p1-r2
new file mode 100644
index 000000000000..d072639ecf37
--- /dev/null
+++ b/sys-cluster/torque/files/digest-torque-1.2.0_p1-r2
@@ -0,0 +1 @@
+MD5 7555d85cf2bacda2725e04d1efcf70ff torque-1.2.0p1.tar.gz 2202860
diff --git a/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild b/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild
new file mode 100644
index 000000000000..d2f5276e4330
--- /dev/null
+++ b/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p1-r2.ebuild,v 1.1 2005/07/05 20:03:08 robbat2 Exp $
+
+inherit flag-o-matic eutils
+
+MY_P="${P/_}"
+DESCRIPTION="A freely downloadable cluster resource manager and queuing system based on OpenPBS"
+HOMEPAGE="http://www.supercluster.org/torque/"
+SRC_URI="http://supercluster.org/downloads/torque/${MY_P}.tar.gz"
+LICENSE="openpbs"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc tcltk X"
+PROVIDE="virtual/pbs"
+
+# ed is used by makedepend-sh
+DEPEND_COMMON="virtual/libc
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl )
+ !virtual/pbs"
+DEPEND="${DEPEND_COMMON}
+ sys-apps/ed"
+RDEPEND="${DEPEND_COMMON}
+ net-misc/openssh"
+PDEPEND="sys-cluster/openpbs-common"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ append-ldflags -Wl,-z,now
+
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PV}-respect-ldflags.patch || die "Failed to fix ldflags"
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PV}-respect-destdir.patch || die "Failed to fix Makefiles for DESTDIR"
+
+ # Tries to use absolute /tmp/ for tempfiles which fails miserably.
+ sed -i -e "s|/tmp/|\${TMPDIR}/|g" ${S}/buildutils/makedepend-sh || die "Failed TMPDIR change"
+}
+
+src_compile() {
+# local myconf
+# use X || myconf="--disable-gui"
+# use tcltk && myconf="${myconf} --with-tcl"
+# use doc && myconf="${myconf} --enable-docs"
+
+ ./configure \
+ $(use_enable X gui) \
+ $(use_with tcltk tcl) \
+ $(use_enable doc docs) \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --libdir="\${exec_prefix}/$(get_libdir)/torque" \
+ --enable-server \
+ --enable-mom \
+ --enable-clients \
+ --set-server-home=/usr/spool/PBS \
+ --set-environ=/etc/pbs_environment || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc INSTALL PBS_License.txt README.torque Release_Notes
+ # Init scripts come from openpbs-common
+ #newinitd ${FILESDIR}/pbs-init.d pbs
+ #newconfd ${FILESDIR}/pbs-conf.d pbs
+ dosym /usr/$(get_libdir)/torque/libpbs.a /usr/$(get_libdir)/libpbs.a
+}