summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-18 09:40:04 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-18 09:40:04 +0000
commitaa20eec56f60184a2b5c5e86126eba00aaf51bc7 (patch)
tree304c2306f99d1769b0374de213a982ab4e2b4dae /sys-cluster/vzctl
parentStable on ppc64; bug #161288 (diff)
downloadgentoo-2-aa20eec56f60184a2b5c5e86126eba00aaf51bc7.tar.gz
gentoo-2-aa20eec56f60184a2b5c5e86126eba00aaf51bc7.tar.bz2
gentoo-2-aa20eec56f60184a2b5c5e86126eba00aaf51bc7.zip
Initial ebuild for 3.0.14, including a build-time fix (thanks to Kir Kolyshkin <kir@openvz.org>).
(Portage version: 2.1.2)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog11
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.143
-rw-r--r--sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch12
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.14.ebuild61
4 files changed, 85 insertions, 2 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 50366ff86fd8..18bf532f562e 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/vzctl
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.39 2006/12/03 08:33:48 hollow Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.40 2007/01/18 09:40:03 phreak Exp $
+
+*vzctl-3.0.14 (18 Jan 2007)
+
+ 18 Jan 2007; Christian Heim <phreak@gentoo.org>
+ +files/vzctl-3.0.14-ndsend.c.patch, +vzctl-3.0.14.ebuild:
+ Initial ebuild for 3.0.14, including a build-time fix (thanks to Kir
+ Kolyshkin <kir@openvz.org>).
03 Dec 2006; Benedikt Böhm <hollow@gentoo.org> vzctl-3.0.13.ebuild:
ovz bug #254 has been solved; add ~ppc64 and ~sparc; cleanup
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.14 b/sys-cluster/vzctl/files/digest-vzctl-3.0.14
new file mode 100644
index 000000000000..07b13a27600b
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.14
@@ -0,0 +1,3 @@
+MD5 c0e3a15f711e5161b504f77b52898906 vzctl-3.0.14.tar.bz2 356300
+RMD160 529b4e3bb1fbcf673831d2891becedf6e003dcd8 vzctl-3.0.14.tar.bz2 356300
+SHA256 86be0231fd12f97e45bae8dae86fadc466e631051d4ee04569d40bb8f82d8b83 vzctl-3.0.14.tar.bz2 356300
diff --git a/sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch b/sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch
new file mode 100644
index 000000000000..f41d65bf9deb
--- /dev/null
+++ b/sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch
@@ -0,0 +1,12 @@
+Index: vzctl-3.0.14/src/ndsend.c
+===================================================================
+--- vzctl-3.0.14.orig/src/ndsend.c
++++ vzctl-3.0.14/src/ndsend.c
+@@ -17,6 +17,7 @@
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
++#include <linux/types.h>
+ #include <linux/if.h>
+ #include <netinet/icmp6.h>
+
diff --git a/sys-cluster/vzctl/vzctl-3.0.14.ebuild b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
new file mode 100644
index 000000000000..3c769d65d8df
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.14.ebuild,v 1.1 2007/01/18 09:40:03 phreak Exp $
+
+inherit bash-completion eutils flag-o-matic multilib
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="bash-completion logrotate udev"
+
+RDEPEND="logrotate? ( app-admin/logrotate )
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ udev? ( sys-fs/udev )
+ virtual/cron"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-ndsend.c.patch
+}
+
+src_compile() {
+ econf --libdir=/usr/$(get_libdir) || die "econf failed!"
+ emake CFLAGS="${CFLAGS}" || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-gentoo || die "make install failed"
+
+ # Remove udev files unless USE=udev
+ use udev || rm -rf "${D}"/etc/udev
+
+ # Remove the bash-completion and use dobashcompletion to install it in the
+ # right place!
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh.in vzctl
+
+ # Remove the logrotate entry unless USE=logrotate
+ use logrotate || rm -rf "${D}"/etc/logrotate.d
+}
+
+pkg_postinst() {
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}