summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-04-11 07:31:24 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-04-11 07:31:24 +0000
commit18fe5268b51a75942311e58687714a6275ff535b (patch)
tree9178dd58aa8cae6eb0c8c216ce6ade872e7099e2 /sys-cluster
parentinitial commit of cinder 9999 (diff)
downloadgentoo-2-18fe5268b51a75942311e58687714a6275ff535b.tar.gz
gentoo-2-18fe5268b51a75942311e58687714a6275ff535b.tar.bz2
gentoo-2-18fe5268b51a75942311e58687714a6275ff535b.zip
initial commit of quantum 9999
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/quantum/ChangeLog7
-rw-r--r--sys-cluster/quantum/quantum-9999.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sys-cluster/quantum/ChangeLog b/sys-cluster/quantum/ChangeLog
index 8fe709b8118b..d4ab110101a9 100644
--- a/sys-cluster/quantum/ChangeLog
+++ b/sys-cluster/quantum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/quantum
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/ChangeLog,v 1.6 2013/04/10 17:07:17 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/ChangeLog,v 1.7 2013/04/11 07:31:24 prometheanfire Exp $
+
+*quantum-9999 (11 Apr 2013)
+
+ 11 Apr 2013; Matthew Thode <prometheanfire@gentoo.org> +quantum-9999.ebuild:
+ initial commit of quantum 9999
*quantum-2013.1 (10 Apr 2013)
diff --git a/sys-cluster/quantum/quantum-9999.ebuild b/sys-cluster/quantum/quantum-9999.ebuild
new file mode 100644
index 000000000000..d19b5f0f835f
--- /dev/null
+++ b/sys-cluster/quantum/quantum-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/quantum/quantum-9999.ebuild,v 1.1 2013/04/11 07:31:24 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-2
+
+#restricted due to packages missing and bad depends in the test ==webob-1.0.8
+RESTRICT="test"
+DESCRIPTION="Quantum is a virtual network service for Openstack."
+HOMEPAGE="https://launchpad.net/quantum"
+EGIT_REPO_URI="https://github.com/openstack/quantum.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/cliff[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}] )
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ =dev-python/mox-0.5.3-r1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nosehtmloutput[${PYTHON_USEDEP}]
+ dev-python/nosexcover
+ dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
+ =dev-python/pep8-1.3.3
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ =dev-python/webtest-1.3.3
+ virtual/python-unittest2[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ =dev-python/amqplib-0.6.1
+ >=dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ =dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
+ dev-python/netaddr
+ >=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
+ dev-python/python-novaclient[${PYTHON_USEDEP}]
+ >=dev-python/python-quantumclient-2.2.0[${PYTHON_USEDEP}]
+ <=dev-python/python-quantumclient-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyudev
+ >dev-python/sqlalchemy-0.7.8
+ <=dev-python/sqlalchemy-0.7.99
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ keepdir /etc/quantum
+ insinto /etc/quantum
+
+ doins "etc/api-paste.ini"
+ doins "etc/dhcp_agent.ini"
+ doins "etc/l3_agent.ini"
+ doins "etc/policy.json"
+ doins "etc/quantum.conf"
+ doins "etc/rootwrap.conf"
+ insinto /etc
+ doins -r "etc/quantum/"
+
+ #remove the etc stuff from usr...
+ rm -R "${D}/usr/etc/"
+}