summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2006-01-09 04:29:22 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2006-01-09 04:29:22 +0000
commit44f141b46e23bf12d42640aa5ccc58ccf1c48146 (patch)
tree11d9d86dbfa2ea843ee4c9945a6834d53a2f9347 /sys-cluster
parentAdded ~sparc keyword wrt bug #74951. (diff)
downloadgentoo-2-44f141b46e23bf12d42640aa5ccc58ccf1c48146.tar.gz
gentoo-2-44f141b46e23bf12d42640aa5ccc58ccf1c48146.tar.bz2
gentoo-2-44f141b46e23bf12d42640aa5ccc58ccf1c48146.zip
Version bump.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/csync2/ChangeLog7
-rw-r--r--sys-cluster/csync2/Manifest12
-rw-r--r--sys-cluster/csync2/csync2-1.29.ebuild58
-rw-r--r--sys-cluster/csync2/files/digest-csync2-1.291
4 files changed, 67 insertions, 11 deletions
diff --git a/sys-cluster/csync2/ChangeLog b/sys-cluster/csync2/ChangeLog
index d27ef38b2452..c603ed046651 100644
--- a/sys-cluster/csync2/ChangeLog
+++ b/sys-cluster/csync2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/csync2
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.7 2006/01/09 03:39:35 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.8 2006/01/09 04:29:22 xmerlin Exp $
+
+*csync2-1.29 (09 Jan 2006)
+
+ 09 Jan 2006; Christian Zoffoli <xmerlin@gentoo.org> +csync2-1.29.ebuild:
+ Version bump.
09 Jan 2006; Christian Zoffoli <xmerlin@gentoo.org> csync2-1.26.ebuild:
Stable on x86.
diff --git a/sys-cluster/csync2/Manifest b/sys-cluster/csync2/Manifest
index e67e085b3014..c6e0e17915de 100644
--- a/sys-cluster/csync2/Manifest
+++ b/sys-cluster/csync2/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 9dffcb750e6e7d20097a5401b87c0d08 csync2-1.16.ebuild 1278
MD5 a64b9a1937a5cfc2fbaf373521f65d47 metadata.xml 223
MD5 fcc9e003e4824d8a46853718f8469061 ChangeLog 1115
MD5 633e05a5dc84c42923fb2f5ca9a93b10 csync2-1.22.ebuild 1277
MD5 328ebaa95fa7090e69340a4bfd3010d5 csync2-1.26.ebuild 1277
+MD5 cbcb18f74d266bccb1fa4a811fb75137 csync2-1.29.ebuild 1303
MD5 8f6c0e3b7da5a8b1a5fd7730f6ae8bdd files/csync2.xinetd 388
MD5 4f935e316a184e40ddf6dfd0f386c761 files/digest-csync2-1.16 62
MD5 204c4e198fb5a256de4f61c6069a862b files/digest-csync2-1.22 63
MD5 8fe2d3ad1d8b14adfaa878252ca38430 files/digest-csync2-1.26 63
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDwdsjgMUyd/cdjWsRAjVfAKCIAGuAb4xolfCHifLTAkP5q/nppACeLBlm
-uBcLzXC4PnjmYn607yGy/20=
-=0hry
------END PGP SIGNATURE-----
+MD5 ef30595753fb34c69ed854d074ea69d4 files/digest-csync2-1.29 63
diff --git a/sys-cluster/csync2/csync2-1.29.ebuild b/sys-cluster/csync2/csync2-1.29.ebuild
new file mode 100644
index 000000000000..593f108d11d7
--- /dev/null
+++ b/sys-cluster/csync2/csync2-1.29.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.29.ebuild,v 1.1 2006/01/09 04:29:22 xmerlin Exp $
+
+DESCRIPTION="Cluster synchronization tool."
+SRC_URI="http://oss.linbit.com/csync2/${P}.tar.gz"
+HOMEPAGE="http://oss.linbit.com/csync2/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=net-libs/librsync-0.9.5
+ =dev-db/sqlite-2.8*
+ >=net-libs/gnutls-1.0.0
+ "
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+
+src_compile() {
+ econf --localstatedir=/var || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} localstatedir=${D}/var install || die "install problem"
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/${PN}.xinetd ${PN} || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "After you setup your conf file, edit the xinetd"
+ einfo "entry in /etc/xinetd.d/${PN} to enable, then"
+ einfo "start xinetd: /etc/init.d/xinetd start"
+ echo
+ einfo "To add ${PN} to your services file just run"
+ einfo "this command after you install:"
+ echo
+ einfo "emerge --config =${PF}"
+}
+
+pkg_config() {
+ einfo "Updating /etc/services"
+ { grep -v ^${PN} /etc/services;
+ echo "csync2 30865/tcp"
+ } > /etc/services.new
+ mv -f /etc/services.new /etc/services
+
+}
diff --git a/sys-cluster/csync2/files/digest-csync2-1.29 b/sys-cluster/csync2/files/digest-csync2-1.29
new file mode 100644
index 000000000000..b0bb3c6a3d63
--- /dev/null
+++ b/sys-cluster/csync2/files/digest-csync2-1.29
@@ -0,0 +1 @@
+MD5 7520e8e3f55bd85cdf462bbb3a6d1f5f csync2-1.29.tar.gz 113511