summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 18:15:25 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-24 18:15:25 +0000
commit4d45bb836cbad96a1f725391bd247bb9ac563072 (patch)
tree1eb91cbf0a34463ac2f70613fd1fdcecac40c958 /sys-cluster
parentVersion bump, now supports symlinks for ex, view, and man pages. (diff)
downloadgentoo-2-4d45bb836cbad96a1f725391bd247bb9ac563072.tar.gz
gentoo-2-4d45bb836cbad96a1f725391bd247bb9ac563072.tar.bz2
gentoo-2-4d45bb836cbad96a1f725391bd247bb9ac563072.zip
(#148719) Use WANT_AUTOCONF instead of need-autoconf() from kde-functions.eclass.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog7
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild16
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3.ebuild14
3 files changed, 25 insertions, 12 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 0852562fab12..ff643589900e 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.12 2006/08/28 16:45:22 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.13 2006/09/24 18:15:25 dberkholz Exp $
+
+ 24 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; mpich2-1.0.3.ebuild,
+ mpich2-1.0.3-r1.ebuild:
+ (#148719) Use WANT_AUTOCONF instead of need-autoconf() from
+ kde-functions.eclass.
28 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>;
mpich2-1.0.2_p1.ebuild, mpich2-1.0.3.ebuild, mpich2-1.0.3-r1.ebuild:
diff --git a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
index 54627a86def5..6a611cedc159 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.5 2006/08/28 16:45:22 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.6 2006/09/24 18:15:25 dberkholz Exp $
-inherit fortran distutils eutils autotools kde-functions toolchain-funcs
+inherit fortran distutils eutils autotools toolchain-funcs
DESCRIPTION="MPICH2 - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
@@ -57,7 +57,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- need-autoconf 2.5
ebegin "Reconfiguring"
find . -name configure -print | xargs rm
./maint/updatefiles
@@ -103,9 +102,14 @@ src_compile() {
myconf="${myconf} --with-thread-package=none"
fi
- ./configure --prefix=/usr --exec-prefix=/usr \
- --enable-sharedlibs=gcc --enable-nmpi-as-mpi \
- --enable-error-checking=runtime --enable-timing=runtime \
+ WANT_AUTOCONF="2.5" \
+ ./configure \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --enable-sharedlibs=gcc \
+ --enable-nmpi-as-mpi \
+ --enable-error-checking=runtime \
+ --enable-timing=runtime \
${myconf} \
$(use_enable cxx) \
$(use_enable mpe) \
diff --git a/sys-cluster/mpich2/mpich2-1.0.3.ebuild b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
index 80c1faccfbfd..2897fd377e78 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.7 2006/08/28 16:45:22 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.8 2006/09/24 18:15:25 dberkholz Exp $
-inherit eutils autotools kde-functions
+inherit eutils autotools
DESCRIPTION="MPICH2 - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
@@ -35,7 +35,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- need-autoconf 2.5
ebegin "Reconfiguring"
./maint/updatefiles
eend "Reconfigure failed"
@@ -70,8 +69,13 @@ src_compile() {
myconf="${myconf} --with-thread-package=none"
fi
- ./configure --prefix=/usr --enable-sharedlibs=gcc \
- ${myconf} --enable-rlog=no --enable-slog2=no \
+ WANT_AUTOCONF="2.5" \
+ ./configure \
+ --prefix=/usr \
+ --enable-sharedlibs=gcc \
+ ${myconf} \
+ --enable-rlog=no \
+ --enable-slog2=no \
$(use_enable cxx) \
$(use_enable mpe) \
$(use_enable threads) \