summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-26 04:25:13 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-26 04:25:13 +0000
commit698f49912c6833dba8d77be50f216c56f4ac8698 (patch)
tree388185f8953eecca7cb7ecbbd40be5c02295913e /sys-cluster
parentStable x86; things always work for the Spanish inquisition (diff)
downloadgentoo-2-698f49912c6833dba8d77be50f216c56f4ac8698.tar.gz
gentoo-2-698f49912c6833dba8d77be50f216c56f4ac8698.tar.bz2
gentoo-2-698f49912c6833dba8d77be50f216c56f4ac8698.zip
Set libdir to /usr/libdir/pbs/lib for compatibility with openmpi and such. Everything should start looking there now for PBS libs. (#101326) Make xpbs work.
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openpbs/ChangeLog10
-rw-r--r--sys-cluster/openpbs/files/digest-openpbs-2.3.16-r43
-rw-r--r--sys-cluster/openpbs/openpbs-2.3.16-r4.ebuild106
3 files changed, 118 insertions, 1 deletions
diff --git a/sys-cluster/openpbs/ChangeLog b/sys-cluster/openpbs/ChangeLog
index 69b799e42897..49222ce53cf1 100644
--- a/sys-cluster/openpbs/ChangeLog
+++ b/sys-cluster/openpbs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/openpbs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/ChangeLog,v 1.28 2006/09/25 17:25:32 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/ChangeLog,v 1.29 2006/09/26 04:25:13 dberkholz Exp $
+
+*openpbs-2.3.16-r4 (26 Sep 2006)
+
+ 26 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +openpbs-2.3.16-r4.ebuild:
+ Set libdir to /usr/libdir/pbs/lib for compatibility with openmpi and such.
+ Everything should start looking there now for PBS libs. (#101326) Make xpbs
+ work.
25 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+files/2.3.16-gcc4.patch, openpbs-2.3.16-r3.ebuild:
diff --git a/sys-cluster/openpbs/files/digest-openpbs-2.3.16-r4 b/sys-cluster/openpbs/files/digest-openpbs-2.3.16-r4
new file mode 100644
index 000000000000..e0c6ef0898c3
--- /dev/null
+++ b/sys-cluster/openpbs/files/digest-openpbs-2.3.16-r4
@@ -0,0 +1,3 @@
+MD5 42be627d513839a2daf258692b0092aa OpenPBS_2_3_16.tar.gz 1307483
+RMD160 3cc617a674e206bd979508c3fa9f540e5e6a359c OpenPBS_2_3_16.tar.gz 1307483
+SHA256 b3fe6eead18aad4191d44478bc3ac40ed14c9b592dce4ed9bab88e0d3af59e68 OpenPBS_2_3_16.tar.gz 1307483
diff --git a/sys-cluster/openpbs/openpbs-2.3.16-r4.ebuild b/sys-cluster/openpbs/openpbs-2.3.16-r4.ebuild
new file mode 100644
index 000000000000..363fd4a0eaa4
--- /dev/null
+++ b/sys-cluster/openpbs/openpbs-2.3.16-r4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openpbs/openpbs-2.3.16-r4.ebuild,v 1.1 2006/09/26 04:25:13 dberkholz Exp $
+
+inherit eutils multilib
+
+NAME="${P/openpbs-/OpenPBS_}"
+NAME="${NAME//./_}"
+DESCRIPTION="The Portable Batch System (PBS) is a flexible batch queuing and workload management system"
+HOMEPAGE="http://www.openpbs.org/"
+SRC_URI="${NAME}.tar.gz"
+
+LICENSE="openpbs"
+PROVIDE="virtual/pbs"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="X tcltk crypt doc"
+RESTRICT="fetch"
+
+PROVIDE="virtual/pbs"
+DEPEND="virtual/libc
+ X? ( || ( x11-libs/libX11 virtual/x11 ) )
+ tcltk? ( dev-lang/tcl )
+ sys-apps/ed
+ !virtual/pbs"
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )"
+PDEPEND="sys-cluster/openpbs-common"
+
+S="${WORKDIR}/${NAME}"
+
+pkg_nofetch() {
+ einfo "Please visit http://www.openpbs.org/."
+ einfo "You must register to download the archive."
+ einfo "Place ${A} in ${DISTDIR}."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # apply a patch I made for gcc3.
+ # maybe this should be done with sed but I'm too lazy
+ epatch ${FILESDIR}/makedepend-sh-gcc3.patch
+ epatch ${FILESDIR}/openpbs-${PV}-errno-fixup.patch
+ epatch ${FILESDIR}/openpbs-gcc32.patch
+ # this thing doesn't use make install, but rather it's own install script
+ # fix it here so the install dirs are set to the ${D} directory
+ pushd buildutils
+ mv pbs_mkdirs.in pbs_mkdirs.in-orig
+ sed -e "s|prefix=@prefix@|prefix=\${D}@prefix@| ; \
+ s|PBS_SERVER_HOME=@PBS_SERVER_HOME@|PBS_SERVER_HOME=\${D}@PBS_SERVER_HOME@| ; \
+ s|PBS_DEFAULT_FILE=@PBS_DEFAULT_FILE@|PBS_DEFAULT_FILE=\${D}@PBS_DEFAULT_FILE@| ; \
+ s|PBS_ENVIRON=@PBS_ENVIRON@|PBS_ENVIRON=\${D}@PBS_ENVIRON@| ; \
+ s|PBS_LIB=@libdir@|PBS_LIB=\${D}@libdir@|" \
+ pbs_mkdirs.in-orig > pbs_mkdirs.in
+ popd
+
+ # Patch from SuSE srpm, found on rpmfind.net
+ epatch ${FILESDIR}/${PV}-gcc4.patch
+}
+
+src_compile() {
+ local myconf
+ use X || myconf="--disable-gui"
+ use tcltk && myconf="${myconf} --with-tcl"
+
+ use crypt && myconf="${myconf} --with-scp"
+ use doc && myconf="${myconf} --enable-docs"
+
+ ./configure ${myconf} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --libdir=/usr/$(get_libdir)/pbs/lib \
+ --enable-server \
+ --enable-clients \
+ --set-server-home=/var/spool/PBS \
+ --set-environ=/etc/pbs_environment \
+ --enable-mom || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/$(get_libdir)/pbs/lib \
+ PBS_SERVER_HOME=${D}/var/spool/PBS \
+ install || die
+
+ dosed /usr/bin/xpbs /usr/bin/xpbsmon
+
+ #
+ # if we are using tcltk, we need to fix up the tclIndex so that it will
+ # refer to the tcl library where it is installed, not where we have staged
+ # it.
+ for tcldir in xpbs xpbsmon; do
+ if [ -e ${D}/usr/$(get_libdir)/pbs/lib/${tcldir}/tclIndex ]; then
+ einfo "Patch in place the ${tcldir}/tclIndex to match our installation"
+ sed -i -e "s|\$dir .* usr $(get_libdir) pbs lib ${tcldir}|\$dir|g" ${D}/usr/$(get_libdir)/pbs/lib/${tcldir}/tclIndex
+ else
+ ewarn "We can't find ${tcldir}/tclIndex to fix!"
+ fi
+ done
+
+ dodoc INSTALL PBS_License.text Read.Me Release_Notes
+}