summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-22 22:31:39 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-22 22:31:39 +0000
commitbd70ea805d54713626b9721563e4960927e2dbd6 (patch)
treece6a4bc78b4afd47f8d53c906bfb3eb05b375b0e /sys-cluster
parentRemoval of 1.4 per bug #287615. (diff)
downloadgentoo-2-bd70ea805d54713626b9721563e4960927e2dbd6.tar.gz
gentoo-2-bd70ea805d54713626b9721563e4960927e2dbd6.tar.bz2
gentoo-2-bd70ea805d54713626b9721563e4960927e2dbd6.zip
[sys-cluster/glusterfs] Version bump per bug #304261
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/glusterfs/ChangeLog8
-rw-r--r--sys-cluster/glusterfs/glusterfs-2.0.8.ebuild102
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.0.2.ebuild (renamed from sys-cluster/glusterfs/glusterfs-3.0.0.ebuild)2
3 files changed, 8 insertions, 104 deletions
diff --git a/sys-cluster/glusterfs/ChangeLog b/sys-cluster/glusterfs/ChangeLog
index d3e22ae2d713..92975fffd855 100644
--- a/sys-cluster/glusterfs/ChangeLog
+++ b/sys-cluster/glusterfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/glusterfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/ChangeLog,v 1.8 2010/02/05 21:32:53 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/ChangeLog,v 1.9 2010/02/22 22:31:39 alexxy Exp $
+
+*glusterfs-3.0.2 (22 Feb 2010)
+
+ 22 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> -glusterfs-2.0.8.ebuild,
+ -glusterfs-3.0.0.ebuild, +glusterfs-3.0.2.ebuild:
+ Version bump per bug #304261
05 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> glusterfs-3.0.0.ebuild:
Fix bug #300122
diff --git a/sys-cluster/glusterfs/glusterfs-2.0.8.ebuild b/sys-cluster/glusterfs/glusterfs-2.0.8.ebuild
deleted file mode 100644
index 5e290719ea8d..000000000000
--- a/sys-cluster/glusterfs/glusterfs-2.0.8.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-2.0.8.ebuild,v 1.4 2009/12/14 09:42:57 alexxy Exp $
-
-EAPI="2"
-
-inherit autotools elisp-common eutils multilib versionator
-
-DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
-HOMEPAGE="http://www.gluster.org/"
-SRC_URI="http://ftp.gluster.com/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs +fuse infiniband static vim-syntax extras"
-#IUSE="emacs +fuse infiniband static vim-syntax"
-
-DEPEND="emacs? ( virtual/emacs )
- fuse? ( >=sys-fs/fuse-2.7.0 )
- infiniband? ( sys-infiniband/libibverbs )"
-RDEPEND="${DEPEND}
- !net-fs/glusterfs"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-parallel-make.patch"
- epatch "${FILESDIR}/${P}-docdir.patch"
- eautoreconf || die "eautoreconf failed"
-}
-
-src_configure() {
- econf \
- $(use_enable fuse fuse-client) \
- $(use_enable infiniband ibverbs) \
- $(use_enable static) \
- --disable-bdb \
- --docdir=/usr/share/doc/${PF} \
- --localstatedir=/var || die
-# $(use_enable berkdb bdb) \
-}
-
-src_compile() {
- emake || die "Emake failed"
- if use emacs ; then
- elisp-compile extras/glusterfs-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use emacs ; then
- elisp-install ${PN} extras/glusterfs-mode.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}/glusterfs.vim" || die
- insinto /usr/share/vim/vimfiles/syntax; doins extras/glusterfs.vim || die
- fi
-
- if use extras ; then
- newbin extras/glusterfs-volgen glusterfs-volgen || die "Failed to install bins"
- newbin extras/backend-xattr-sanitize.sh glusterfs-backend-xattr-sanitize || die "Failed to install bins"
- newbin extras/migrate-unify-to-distribute.sh glusterfs-migrate-unify-to-distribute || die "Failed to install bins"
- fi
-
- dodoc AUTHORS ChangeLog NEWS README THANKS || die "dodoc failed"
-
- newinitd "${FILESDIR}/${PN}.initd" glusterfsd || die "newinitd failed"
- newconfd "${FILESDIR}/${PN}.confd" glusterfsd || die "newconfd failed"
-
- keepdir /var/log/${PN} || die "keepdir failed"
-}
-
-pkg_postinst() {
- elog "The glusterfs startup script can be multiplexed."
- elog "The default startup script uses /etc/conf.d/glusterfs to configure the"
- elog "separate service. To create additional instances of the glusterfs service"
- elog "simply create a symlink to the glusterfs startup script."
- elog
- elog "Example:"
- elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
- elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
- elog "You can now treat glusterfsd2 like any other service"
- echo
- elog "You can mount exported GlusterFS filesystems through /etc/fstab instead of"
- elog "through a startup script instance. For more information visit:"
- elog "http://www.gluster.org/docs/index.php/Mounting_a_GlusterFS_Volume"
- echo
- ewarn "You need to use a ntp client to keep the clocks synchronized across all"
- ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
- ewarn "run GlusterFS."
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sys-cluster/glusterfs/glusterfs-3.0.0.ebuild b/sys-cluster/glusterfs/glusterfs-3.0.2.ebuild
index e5800ea9876b..04faedfcb8b3 100644
--- a/sys-cluster/glusterfs/glusterfs-3.0.0.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.0.0.ebuild,v 1.2 2010/02/05 21:32:53 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.0.2.ebuild,v 1.1 2010/02/22 22:31:39 alexxy Exp $
EAPI="2"