summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-22 04:38:40 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-22 04:38:40 +0000
commite90cacbcaf6751a9288b5802b6b79e67947f2f52 (patch)
tree9b512292bb1cc27a4cd38803fa4f4808ab683e8e /sys-cluster
parentBump (diff)
downloadgentoo-2-e90cacbcaf6751a9288b5802b6b79e67947f2f52.tar.gz
gentoo-2-e90cacbcaf6751a9288b5802b6b79e67947f2f52.tar.bz2
gentoo-2-e90cacbcaf6751a9288b5802b6b79e67947f2f52.zip
Change -> openstack herd, Edit/correct Description, update test deps, add test phase to 2013.2*, testing support from (good ol') Chicago
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/neutron/ChangeLog12
-rw-r--r--sys-cluster/neutron/files/neutron-2013.2-json-tests.patch82
-rw-r--r--sys-cluster/neutron/files/neutron-2013.2-nicira.patch164
-rw-r--r--sys-cluster/neutron/files/neutron-2013.2-sphinx_mapping.patch16
-rw-r--r--sys-cluster/neutron/metadata.xml2
-rw-r--r--sys-cluster/neutron/neutron-2013.2-r1.ebuild157
-rw-r--r--sys-cluster/neutron/neutron-2013.2.9999.ebuild27
-rw-r--r--sys-cluster/neutron/neutron-2013.2.ebuild4
-rw-r--r--sys-cluster/neutron/neutron-9999.ebuild4
9 files changed, 457 insertions, 11 deletions
diff --git a/sys-cluster/neutron/ChangeLog b/sys-cluster/neutron/ChangeLog
index c44dba470e45..65ff4ef10e75 100644
--- a/sys-cluster/neutron/ChangeLog
+++ b/sys-cluster/neutron/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-cluster/neutron
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.17 2013/11/14 04:28:47 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.18 2013/11/22 04:38:40 idella4 Exp $
+
+*neutron-2013.2-r1 (22 Nov 2013)
+
+ 22 Nov 2013; Ian Delaney <idella4@gentoo.org>
+ +files/neutron-2013.2-json-tests.patch, +files/neutron-2013.2-nicira.patch,
+ +files/neutron-2013.2-sphinx_mapping.patch, +neutron-2013.2-r1.ebuild,
+ metadata.xml, neutron-2013.2.9999.ebuild, neutron-2013.2.ebuild,
+ neutron-9999.ebuild:
+ Change -> openstack herd, Edit/correct Description, update test deps, add test
+ phase to 2013.2*, testing support from (good ol') Chicago
14 Nov 2013; Matthew Thode <prometheanfire@gentoo.org>
-neutron-2012.2.4-r7.ebuild:
diff --git a/sys-cluster/neutron/files/neutron-2013.2-json-tests.patch b/sys-cluster/neutron/files/neutron-2013.2-json-tests.patch
new file mode 100644
index 000000000000..ebf33da1d407
--- /dev/null
+++ b/sys-cluster/neutron/files/neutron-2013.2-json-tests.patch
@@ -0,0 +1,82 @@
+https://github.com/openstack/neutron/commit/d26dfed7d47926425bb55893da45f650d6549b9a
+diff --git a/neutron/tests/unit/linuxbridge/test_lb_neutron_agent.py b/neutron/tests/unit/linuxbridge/test_lb_neutron_agent.py
+index ba76786..fa2c2c0 100644
+--- a/neutron/tests/unit/linuxbridge/test_lb_neutron_agent.py
++++ b/neutron/tests/unit/linuxbridge/test_lb_neutron_agent.py
+@@ -97,11 +97,6 @@ def setUp(self):
+ super(TestLinuxBridgeAgent, self).setUp()
+ cfg.CONF.set_override('rpc_backend',
+ 'neutron.openstack.common.rpc.impl_fake')
+- self.lbmgr_patcher = mock.patch('neutron.plugins.linuxbridge.agent.'
+- 'linuxbridge_neutron_agent.'
+- 'LinuxBridgeManager')
+- self.lbmgr_mock = self.lbmgr_patcher.start()
+- self.addCleanup(self.lbmgr_patcher.stop)
+ self.execute_p = mock.patch.object(ip_lib.IPWrapper, '_execute')
+ self.execute = self.execute_p.start()
+ self.addCleanup(self.execute_p.stop)
+@@ -113,8 +108,6 @@ def setUp(self):
+ self.get_mac.return_value = '00:00:00:00:00:01'
+
+ def test_update_devices_failed(self):
+- lbmgr_instance = self.lbmgr_mock.return_value
+- lbmgr_instance.update_devices.side_effect = RuntimeError
+ agent = linuxbridge_neutron_agent.LinuxBridgeNeutronAgentRPC({},
+ 0,
+ None)
+@@ -125,17 +118,18 @@ def info_mock(msg):
+ raise_exception[0] += 1
+ else:
+ raise RuntimeError()
+-
+- with mock.patch.object(linuxbridge_neutron_agent.LOG, 'info') as log:
+- log.side_effect = info_mock
+- with testtools.ExpectedException(RuntimeError):
+- agent.daemon_loop()
+- self.assertEqual(3, log.call_count)
++ with mock.patch.object(agent.br_mgr,
++ "update_devices") as update_devices:
++ update_devices.side_effect = RuntimeError
++ with mock.patch.object(linuxbridge_neutron_agent.LOG,
++ 'info') as log:
++ log.side_effect = info_mock
++ with testtools.ExpectedException(RuntimeError):
++ agent.daemon_loop()
++ self.assertEqual(3, log.call_count)
+
+ def test_process_network_devices_failed(self):
+ device_info = {'current': [1, 2, 3]}
+- lbmgr_instance = self.lbmgr_mock.return_value
+- lbmgr_instance.update_devices.return_value = device_info
+ agent = linuxbridge_neutron_agent.LinuxBridgeNeutronAgentRPC({},
+ 0,
+ None)
+@@ -147,15 +141,18 @@ def info_mock(msg):
+ else:
+ raise RuntimeError()
+
+- with contextlib.nested(
+- mock.patch.object(linuxbridge_neutron_agent.LOG, 'info'),
+- mock.patch.object(agent, 'process_network_devices')
+- ) as (log, process_network_devices):
+- log.side_effect = info_mock
+- process_network_devices.side_effect = RuntimeError
+- with testtools.ExpectedException(RuntimeError):
+- agent.daemon_loop()
+- self.assertEqual(3, log.call_count)
++ with mock.patch.object(agent.br_mgr,
++ "update_devices") as update_devices:
++ update_devices.side_effect = device_info
++ with contextlib.nested(
++ mock.patch.object(linuxbridge_neutron_agent.LOG, 'info'),
++ mock.patch.object(agent, 'process_network_devices')
++ ) as (log, process_network_devices):
++ log.side_effect = info_mock
++ process_network_devices.side_effect = RuntimeError
++ with testtools.ExpectedException(RuntimeError):
++ agent.daemon_loop()
++ self.assertEqual(3, log.call_count)
+
+
+ class TestLinuxBridgeManager(base.BaseTestCase):
+
diff --git a/sys-cluster/neutron/files/neutron-2013.2-nicira.patch b/sys-cluster/neutron/files/neutron-2013.2-nicira.patch
new file mode 100644
index 000000000000..58461f91df87
--- /dev/null
+++ b/sys-cluster/neutron/files/neutron-2013.2-nicira.patch
@@ -0,0 +1,164 @@
+https://review.openstack.org/gitweb?p=openstack%2Fneutron.git;a=commitdiff;h=a52ef6ecf19b8b015465ddda2a3ca087f0e12122
+index 04dbfef..77f233a 100755 (executable)
+
+
+--- a/neutron/plugins/nicira/vshield/tasks/tasks.py
++++ b/neutron/plugins/nicira/vshield/tasks/tasks.py
+@@ -15,8 +15,6 @@
+ # License for the specific language governing permissions and limitations
+ # under the License.
+
+-from __future__ import print_function
+-
+ import collections
+ import uuid
+
+@@ -167,6 +165,9 @@ class TaskManager():
+ # A dict to store resource -> resource's tasks
+ self._tasks = {}
+
++ # Current task being executed in main thread
++ self._main_thread_exec_task = None
++
+ # New request event
+ self._req = event.Event()
+
+@@ -311,8 +312,10 @@ class TaskManager():
+ continue
+
+ try:
++ self._main_thread_exec_task = task
+ self._execute(task)
+ finally:
++ self._main_thread_exec_task = None
+ if task.status is None:
+ # The thread is killed during _execute(). To guarantee
+ # the task been aborted correctly, put it to the queue.
+@@ -348,20 +351,19 @@ class TaskManager():
+ self._thread = None
+
+ def has_pending_task(self):
+- if self._tasks_queue:
+- return True
+-
+- if self._tasks:
++ if self._tasks_queue or self._tasks or self._main_thread_exec_task:
+ return True
+-
+- return False
++ else:
++ return False
+
+ def show_pending_tasks(self):
+ for task in self._tasks_queue:
+- print(str(task))
++ LOG.info(str(task))
+ for resource, tasks in self._tasks.iteritems():
+ for task in tasks:
+- print(str(task))
++ LOG.info(str(task))
++ if self._main_thread_exec_task:
++ LOG.info(str(self._main_thread_exec_task))
+
+ def count(self):
+ count = 0
+
+
+diff --git a/neutron/tests/unit/nicira/test_edge_router.py b/neutron/tests/unit/nicira/test_edge_router.py
+
+index 41efeed..a360b71 100644 (file)
+
+
+--- a/neutron/tests/unit/nicira/test_edge_router.py
++++ b/neutron/tests/unit/nicira/test_edge_router.py
+@@ -135,7 +135,8 @@ class ServiceRouterTest(test_nicira_plugin.NiciraL3NatTest,
+ def tearDown(self):
+ plugin = NeutronManager.get_plugin()
+ manager = plugin.vcns_driver.task_manager
+- for i in range(20):
++ # wait max ~10 seconds for all tasks to be finished
++ for i in range(100):
+ if not manager.has_pending_task():
+ break
+ greenthread.sleep(0.1)
+@@ -183,8 +184,8 @@ class ServiceRouterTestCase(ServiceRouterTest, NvpRouterTestCase):
+ for k, v in expected_value_1:
+ self.assertEqual(router['router'][k], v)
+
+- # wait ~1 seconds for router status update
+- for i in range(2):
++ # wait max ~10 seconds for router status update
++ for i in range(20):
+ greenthread.sleep(0.5)
+ res = self._show('routers', router['router']['id'])
+ if res['router']['status'] == 'ACTIVE':
+
+
+diff --git a/neutron/tests/unit/nicira/test_vcns_driver.py b/neutron/tests/unit/nicira/test_vcns_driver.py
+
+index b0d69a4..ddc0c33 100644 (file)
+
+
+--- a/neutron/tests/unit/nicira/test_vcns_driver.py
++++ b/neutron/tests/unit/nicira/test_vcns_driver.py
+@@ -253,6 +253,31 @@ class VcnsDriverTaskManagerTestCase(base.BaseTestCase):
+ def test_task_manager_stop_4(self):
+ self._test_task_manager_stop(False, False, 1)
+
++ def test_task_pending_task(self):
++ def _exec(task):
++ task.userdata['executing'] = True
++ while not task.userdata['tested']:
++ greenthread.sleep(0)
++ task.userdata['executing'] = False
++ return TaskStatus.COMPLETED
++
++ userdata = {
++ 'executing': False,
++ 'tested': False
++ }
++ manager = ts.TaskManager().start(100)
++ task = ts.Task('name', 'res', _exec, userdata=userdata)
++ manager.add(task)
++
++ while not userdata['executing']:
++ greenthread.sleep(0)
++ self.assertTrue(manager.has_pending_task())
++
++ userdata['tested'] = True
++ while userdata['executing']:
++ greenthread.sleep(0)
++ self.assertFalse(manager.has_pending_task())
++
+
+ class VcnsDriverTestCase(base.BaseTestCase):
+
+@@ -298,6 +323,10 @@ class VcnsDriverTestCase(base.BaseTestCase):
+ self.edge_id = None
+ self.result = None
+
++ def tearDown(self):
++ self.vcns_driver.task_manager.stop()
++ super(VcnsDriverTestCase, self).tearDown()
++
+ def _deploy_edge(self):
+ task = self.vcns_driver.deploy_edge(
+ 'router-id', 'myedge', 'internal-network', {}, wait_for_exec=True)
+@@ -355,12 +384,13 @@ class VcnsDriverTestCase(base.BaseTestCase):
+ self.assertTrue(jobdata.get('edge_deploy_result'))
+
+ def test_deploy_edge_fail(self):
+- self.vcns_driver.deploy_edge(
++ task1 = self.vcns_driver.deploy_edge(
+ 'router-1', 'myedge', 'internal-network', {}, wait_for_exec=True)
+- task = self.vcns_driver.deploy_edge(
++ task2 = self.vcns_driver.deploy_edge(
+ 'router-2', 'myedge', 'internal-network', {}, wait_for_exec=True)
+- task.wait(TaskState.RESULT)
+- self.assertEqual(task.status, TaskStatus.ERROR)
++ task1.wait(TaskState.RESULT)
++ task2.wait(TaskState.RESULT)
++ self.assertEqual(task2.status, TaskStatus.ERROR)
+
+ def test_get_edge_status(self):
+ self._deploy_edge()
diff --git a/sys-cluster/neutron/files/neutron-2013.2-sphinx_mapping.patch b/sys-cluster/neutron/files/neutron-2013.2-sphinx_mapping.patch
new file mode 100644
index 000000000000..d7367d6a6e52
--- /dev/null
+++ b/sys-cluster/neutron/files/neutron-2013.2-sphinx_mapping.patch
@@ -0,0 +1,16 @@
+diff -ur neutron-2013.2.orig/doc/source/conf.py neutron-2013.2/doc/source/conf.py
+--- doc/source/conf.py 2013-10-17 22:01:20.000000000 +0800
++++ doc/source/conf.py 2013-11-15 19:42:42.701213324 +0800
+@@ -238,12 +238,3 @@
+
+ # If false, no module index is generated.
+ #latex_use_modindex = True
+-
+-# Example configuration for intersphinx: refer to the Python standard library.
+-intersphinx_mapping = {'python': ('http://docs.python.org/', None),
+- 'nova': ('http://nova.openstack.org', None),
+- 'swift': ('http://swift.openstack.org', None),
+- 'glance': ('http://glance.openstack.org', None),
+- 'horizon': ('http://horizon.openstack.org', None),
+- 'keystone': ('http://keystone.openstack.org', None),
+- }
diff --git a/sys-cluster/neutron/metadata.xml b/sys-cluster/neutron/metadata.xml
index 0637de22a8f9..cbb14677b53b 100644
--- a/sys-cluster/neutron/metadata.xml
+++ b/sys-cluster/neutron/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
+ <herd>openstack</herd>
<maintainer>
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
diff --git a/sys-cluster/neutron/neutron-2013.2-r1.ebuild b/sys-cluster/neutron/neutron-2013.2-r1.ebuild
new file mode 100644
index 000000000000..9a8e7365ac0d
--- /dev/null
+++ b/sys-cluster/neutron/neutron-2013.2-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.2-r1.ebuild,v 1.1 2013/11/22 04:38:40 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A virtual network service for Openstack."
+HOMEPAGE="https://launchpad.net/neutron"
+SRC_URI="http://launchpad.net/${PN}/havana/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dhcp doc +l3 +metadata +openvswitch +server test sqlite mysql postgres"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+#the cliff dep is as below because it depends on pyparsing, which only has 2.7 OR 3.2, not both
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ app-admin/sudo
+ test? ( >=dev-python/cliff-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ >=dev-python/webtest-2.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ >=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ dev-python/jsonrpclib[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/kombu-2.4.8[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ >=dev-python/python-neutronclient-2.3.0[${PYTHON_USEDEP}]
+ <=dev-python/python-neutronclient-3.0.0[${PYTHON_USEDEP}]
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.99[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.99[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.99[postgres,${PYTHON_USEDEP}] )
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/webob-1.3[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.4.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.10[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-2.15.0[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ net-misc/bridge-utils
+ net-misc/openvswitch
+ dhcp? ( net-dns/dnsmasq[dhcp-tools] )"
+
+PATCHES=( "${FILESDIR}"/${P}-sphinx_mapping.patch \
+ "${FILESDIR}"/${P}-json-tests.patch \
+ "${FILESDIR}"/${P}-nicira.patch )
+
+pkg_setup() {
+ enewgroup neutron
+ enewuser neutron -1 -1 /var/lib/neutron neutron
+}
+
+pkg_config() {
+ fperms 0700 /var/log/neutron
+ fowners neutron:neutron /var/log neutron
+}
+
+src_prepare() {
+ #it's /bin/ip not /sbin/ip
+ sed -i 's/sbin\/ip\,/bin\/ip\,/g' etc/neutron/rootwrap.d/*
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ use doc && make -C doc html
+}
+
+python_test() {
+ # https://bugs.launchpad.net/neutron/+bug/1234857
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ # https://bugs.launchpad.net/neutron/+bug/1251657
+ # turn multiprocessing off, testr will use it --parallel
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ # Move tests out that attempt net connection, have failures
+ mv $(find . -name test_ovs_tunnel.py) . || die
+ sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
+ -e 's:test_start_random_port_with_ipv6:_&:' \
+ -i neutron/tests/unit/test_wsgi.py || die
+ testr init
+ testr run --parallel || die "failed testsuite under python2.7"
+}
+
+python_install() {
+ distutils-r1_python_install
+ newconfd "${FILESDIR}/neutron-confd" "neutron"
+ newinitd "${FILESDIR}/neutron-initd" "neutron"
+
+ use server && dosym /etc/init.d/neutron /etc/init.d/neutron-server
+ use dhcp && dosym /etc/init.d/neutron /etc/init.d/neutron-dhcp-agent
+ use l3 && dosym /etc/init.d/neutron /etc/init.d/neutron-l3-agent
+ use metadata && dosym /etc/init.d/neutron /etc/init.d/neutron-metadata-agent
+ use openvswitch && dosym /etc/init.d/neutron /etc/init.d/neutron-openvswitch-agent
+
+ diropts -m 750
+ dodir /var/log/neutron /var/log/neutron
+ fowners neutron:neutron /var/log/neutron
+ keepdir /etc/neutron
+ insinto /etc/neutron
+
+ doins "etc/api-paste.ini"
+ doins "etc/dhcp_agent.ini"
+ doins "etc/l3_agent.ini"
+ doins "etc/policy.json"
+ doins "etc/neutron.conf"
+ doins "etc/rootwrap.conf"
+ insinto /etc
+ doins -r "etc/neutron/"
+
+ #remove the etc stuff from usr...
+ rm -R "${D}/usr/etc/"
+
+ insinto "/usr/lib64/python2.7/site-packages/neutron/db/migration/alembic_migrations/"
+ doins -r "neutron/db/migration/alembic_migrations/versions"
+
+ #add sudoers definitions for user neutron
+ insinto /etc/sudoers.d/
+ doins "${FILESDIR}/neutron-sudoers"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/sys-cluster/neutron/neutron-2013.2.9999.ebuild b/sys-cluster/neutron/neutron-2013.2.9999.ebuild
index f56544e9244a..a71872895c5c 100644
--- a/sys-cluster/neutron/neutron-2013.2.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2013.2.9999.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.2.9999.ebuild,v 1.4 2013/11/11 03:15:04 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.2.9999.ebuild,v 1.5 2013/11/22 04:38:40 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 git-2
-#restricted due to packages missing and bad depends in the test ==webob-1.0.8
-RESTRICT="test"
-DESCRIPTION="Quantum is a virtual network service for Openstack."
+DESCRIPTION="A virtual network service for Openstack."
HOMEPAGE="https://launchpad.net/neutron"
EGIT_REPO_URI="https://github.com/openstack/neutron.git"
EGIT_BRANCH="stable/havana"
@@ -35,7 +33,11 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
>=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
>=dev-python/webtest-2.0[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}] )"
+ dev-python/configobj[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}] )"
+
RDEPEND="dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
@@ -83,6 +85,21 @@ src_prepare() {
sed -i 's/sbin\/ip\,/bin\/ip\,/g' etc/neutron/rootwrap.d/*
}
+python_test() {
+ # https://bugs.launchpad.net/neutron/+bug/1234857
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ # https://bugs.launchpad.net/neutron/+bug/1251657
+ # turn multiprocessing off, testr will use it --parallel
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ # Move tests out that attempt net connection
+ mv $(find . -name test_ovs_tunnel.py) . || die
+ sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
+ -e 's:test_start_random_port_with_ipv6:_&:' \
+ -i neutron/tests/unit/test_wsgi.py || die
+ testr init
+ testr run --parallel || die "failed testsuite under python2.7"
+}
+
python_install() {
distutils-r1_python_install
newconfd "${FILESDIR}/neutron-confd" "neutron"
diff --git a/sys-cluster/neutron/neutron-2013.2.ebuild b/sys-cluster/neutron/neutron-2013.2.ebuild
index 0aad3604d826..0c9b967ad7b5 100644
--- a/sys-cluster/neutron/neutron-2013.2.ebuild
+++ b/sys-cluster/neutron/neutron-2013.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.2.ebuild,v 1.3 2013/11/11 03:15:04 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.2.ebuild,v 1.4 2013/11/22 04:38:40 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -9,7 +9,7 @@ inherit distutils-r1
#restricted due to packages missing and bad depends in the test ==webob-1.0.8
RESTRICT="test"
-DESCRIPTION="Quantum is a virtual network service for Openstack."
+DESCRIPTION="A virtual network service for Openstack."
HOMEPAGE="https://launchpad.net/neutron"
SRC_URI="http://launchpad.net/${PN}/havana/${PV}/+download/${P}.tar.gz"
diff --git a/sys-cluster/neutron/neutron-9999.ebuild b/sys-cluster/neutron/neutron-9999.ebuild
index ec2e0f0a41f9..b48da9007dde 100644
--- a/sys-cluster/neutron/neutron-9999.ebuild
+++ b/sys-cluster/neutron/neutron-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.7 2013/09/27 00:41:28 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.8 2013/11/22 04:38:39 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -9,7 +9,7 @@ inherit distutils-r1 git-2
#restricted due to packages missing and bad depends in the test ==webob-1.0.8
RESTRICT="test"
-DESCRIPTION="Quantum is a virtual network service for Openstack."
+DESCRIPTION="A virtual network service for Openstack."
HOMEPAGE="https://launchpad.net/neutron"
EGIT_REPO_URI="https://github.com/openstack/neutron.git"