summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-06 18:15:41 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-06 18:15:41 +0000
commitf52cfcfd465e37c8a0a4e719d4df405e4f223e94 (patch)
treec8f26b7fd71418612407923913a5de3ef3951d3a /sys-devel/bin86
parentfix argparse dep (diff)
downloadgentoo-2-f52cfcfd465e37c8a0a4e719d4df405e4f223e94.tar.gz
gentoo-2-f52cfcfd465e37c8a0a4e719d4df405e4f223e94.tar.bz2
gentoo-2-f52cfcfd465e37c8a0a4e719d4df405e4f223e94.zip
Version bump #450572 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel/bin86')
-rw-r--r--sys-devel/bin86/ChangeLog9
-rw-r--r--sys-devel/bin86/bin86-0.16.19.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/sys-devel/bin86/ChangeLog b/sys-devel/bin86/ChangeLog
index b12c9e3fe460..6e715b7e938d 100644
--- a/sys-devel/bin86/ChangeLog
+++ b/sys-devel/bin86/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bin86
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.22 2012/08/01 02:00:35 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.23 2013/01/06 18:15:41 vapier Exp $
+
+*bin86-0.16.19 (06 Jan 2013)
+
+ 06 Jan 2013; Mike Frysinger <vapier@gentoo.org> +bin86-0.16.19.ebuild:
+ Version bump #450572 by Agostino Sarubbo.
01 Aug 2012; Naohiro Aota <naota@gentoo.org> bin86-0.16.18.ebuild:
Add ~x86-fbsd.
diff --git a/sys-devel/bin86/bin86-0.16.19.ebuild b/sys-devel/bin86/bin86-0.16.19.ebuild
new file mode 100644
index 000000000000..ba24845ca20d
--- /dev/null
+++ b/sys-devel/bin86/bin86-0.16.19.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.19.ebuild,v 1.1 2013/01/06 18:15:41 vapier Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Assembler and loader used to create kernel bootsector"
+HOMEPAGE="http://www.debath.co.uk/"
+SRC_URI="http://www.debath.co.uk/dev86/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
+ -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
+ -e '/^INSTALL_OPTS/s:-s::' \
+ -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
+ -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+ Makefile || die
+# epatch "${FILESDIR}"/${PN}-0.16.18-headers.patch #347817
+ epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
+ tc-export CC
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ default
+}