summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-27 08:14:46 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-27 08:14:46 +0000
commit841d56ad935704fabae98508c55c31c74de4ee39 (patch)
treec962145a7602c27f6c905109e8b90052be257bff /sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
parentUse more readable CTARGET setup logic. (diff)
downloadgentoo-2-841d56ad935704fabae98508c55c31c74de4ee39.tar.gz
gentoo-2-841d56ad935704fabae98508c55c31c74de4ee39.tar.bz2
gentoo-2-841d56ad935704fabae98508c55c31c74de4ee39.zip
Use more readable CTARGET setup logic.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild b/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
index 033b7dfb5bc7..db572fdba872 100644
--- a/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild,v 1.4 2015/01/31 02:33:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild,v 1.5 2015/02/27 08:14:46 vapier Exp $
EAPI="3"
@@ -27,8 +27,8 @@ DEPEND="${RDEPEND}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi
is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }