summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-21 19:33:08 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-21 19:33:08 +0000
commitd54752bb5f4cf35b54ea8ed629c52c563e44f273 (patch)
treefa0068e92e7277ca09f0b55a284fa5e5453e4e2a /sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d54752bb5f4cf35b54ea8ed629c52c563e44f273.tar.gz
gentoo-2-d54752bb5f4cf35b54ea8ed629c52c563e44f273.tar.bz2
gentoo-2-d54752bb5f4cf35b54ea8ed629c52c563e44f273.zip
Revision bump for usage of Xcode 3.2's ld64. Use Heiko Przybyl's patches to remove the dependency on Apple's libunwind. Port all ebuilds to EAPI=3
(Portage version: 2.2.00.15838-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild b/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
index 5b61c45951ec..0f43d23180ee 100644
--- a/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild,v 1.2 2010/02/12 10:24:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-3.1.2.ebuild,v 1.3 2010/03/21 19:33:06 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic toolchain-funcs
@@ -48,7 +50,7 @@ fi
S=${WORKDIR}
-unpack_ld64() {
+prepare_ld64() {
cd "${S}"/${LD64}/src
cp "${FILESDIR}"/Makefile .
@@ -86,9 +88,8 @@ unpack_ld64() {
elog "Deleted $c tests that were bound to fail"
}
-src_unpack() {
- unpack ${A}
- unpack_ld64
+src_prepare() {
+ prepare_ld64
cd "${S}"/${CCTOOLS}
epatch "${FILESDIR}"/${PN}-3.1.1-as.patch
@@ -146,8 +147,6 @@ install_ld64() {
}
install_cctools() {
- local ED=${ED-${D}}
-
cd "${S}"/${CCTOOLS}
emake install_all_but_headers \
EFITOOLS= \