summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-08-30 09:41:16 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-08-30 09:41:16 +0000
commitc2095761e41e77a1b417400c6e5e1969994c4002 (patch)
tree393b76032dc5758483775969ced2a8ecc34c9ef3 /sys-devel/clang/clang-3.1-r5.ebuild
parentAdd GeoIPASNum database to SRC_URI as it is updated by geoipupdate.sh and thu... (diff)
downloadgentoo-2-c2095761e41e77a1b417400c6e5e1969994c4002.tar.gz
gentoo-2-c2095761e41e77a1b417400c6e5e1969994c4002.tar.bz2
gentoo-2-c2095761e41e77a1b417400c6e5e1969994c4002.zip
Also apply llvm r600 patches, should fix bug #427206
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/clang/clang-3.1-r5.ebuild')
-rw-r--r--sys-devel/clang/clang-3.1-r5.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-devel/clang/clang-3.1-r5.ebuild b/sys-devel/clang/clang-3.1-r5.ebuild
index e0c2aa61bcbe..15c9734079c0 100644
--- a/sys-devel/clang/clang-3.1-r5.ebuild
+++ b/sys-devel/clang/clang-3.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.1-r5.ebuild,v 1.2 2012/07/27 18:22:45 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.1-r5.ebuild,v 1.3 2012/08/30 09:41:16 voyageur Exp $
EAPI=4
@@ -18,7 +18,7 @@ SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz
LICENSE="UoI-NCSA"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="debug kernel_FreeBSD multitarget +static-analyzer test"
DEPEND="static-analyzer? ( dev-lang/perl )"
@@ -87,8 +87,9 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-increase-parser-recursion-limit.patch
# Apply r600 OpenCL-related patches, bug #425688
+ epatch "${FILESDIR}"/cl-patches/llvm-*.patch
pushd tools/clang &>/dev/null || die
- epatch "${FILESDIR}"/cl-patches/*.patch
+ epatch "${FILESDIR}"/cl-patches/clang-*.patch
popd &>/dev/null || die
# User patches