summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-11 09:00:42 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-11 09:00:42 +0000
commitdafc8b45f2b8416e947f460a2b890b98fa88d303 (patch)
tree8b4ae713c3179e7a002f493c237eab1fe3f8bc31 /sys-devel/crossdev
parentRemoved ket-misc/ksb26 entry since it is no longer in the Tree. (diff)
downloadgentoo-2-dafc8b45f2b8416e947f460a2b890b98fa88d303.tar.gz
gentoo-2-dafc8b45f2b8416e947f460a2b890b98fa88d303.tar.bz2
gentoo-2-dafc8b45f2b8416e947f460a2b890b98fa88d303.zip
Add support for custom env settings, CONFIGROOT, and other stuff.
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog7
-rw-r--r--sys-devel/crossdev/crossdev-20101011.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 6b9ee1dff121..2ae61c05acbf 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.71 2010/10/11 08:57:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.72 2010/10/11 09:00:42 vapier Exp $
+
+*crossdev-20101011 (11 Oct 2010)
+
+ 11 Oct 2010; Mike Frysinger <vapier@gentoo.org> +crossdev-20101011.ebuild:
+ Add support for custom env settings, CONFIGROOT, and other stuff.
11 Oct 2010; Mike Frysinger <vapier@gentoo.org> crossdev-20100814.ebuild:
Stabilize for everyone.
diff --git a/sys-devel/crossdev/crossdev-20101011.ebuild b/sys-devel/crossdev/crossdev-20101011.ebuild
new file mode 100644
index 000000000000..06c4f62424a9
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20101011.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20101011.ebuild,v 1.1 2010/10/11 09:00:42 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}