summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-24 02:03:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-24 02:03:55 +0000
commit53400a4bfc737213f7b19aabea4ca8f3d707cf75 (patch)
treea67655905496d9f97ac28c0e1f289b91e224cc8b /sys-devel/flex
parentFix building with USE=-nls #123826 by Chris Fairles. (diff)
downloadgentoo-2-53400a4bfc737213f7b19aabea4ca8f3d707cf75.tar.gz
gentoo-2-53400a4bfc737213f7b19aabea4ca8f3d707cf75.tar.bz2
gentoo-2-53400a4bfc737213f7b19aabea4ca8f3d707cf75.zip
Version bump #122940.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-devel/flex')
-rw-r--r--sys-devel/flex/ChangeLog8
-rw-r--r--sys-devel/flex/files/digest-flex-2.5.333
-rw-r--r--sys-devel/flex/files/flex-2.5.33-isatty.patch53
-rw-r--r--sys-devel/flex/flex-2.5.33.ebuild39
4 files changed, 102 insertions, 1 deletions
diff --git a/sys-devel/flex/ChangeLog b/sys-devel/flex/ChangeLog
index 3e636bdd931c..c8bb631f1db0 100644
--- a/sys-devel/flex/ChangeLog
+++ b/sys-devel/flex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/flex
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/ChangeLog,v 1.40 2006/02/20 20:07:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/ChangeLog,v 1.41 2006/02/24 02:03:55 vapier Exp $
+
+*flex-2.5.33 (24 Feb 2006)
+
+ 24 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/flex-2.5.33-isatty.patch, +flex-2.5.33.ebuild:
+ Version bump #122940.
20 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+files/flex-2.5.31-gnu-m4.patch, flex-2.5.31-r2.ebuild:
diff --git a/sys-devel/flex/files/digest-flex-2.5.33 b/sys-devel/flex/files/digest-flex-2.5.33
new file mode 100644
index 000000000000..7a65ac6d8d99
--- /dev/null
+++ b/sys-devel/flex/files/digest-flex-2.5.33
@@ -0,0 +1,3 @@
+MD5 343374a00b38d9e39d1158b71af37150 flex-2.5.33.tar.bz2 695464
+RMD160 360e08457d324c5b87c02b0ed61983877c173c98 flex-2.5.33.tar.bz2 695464
+SHA256 53b56a62ea9409b99b7a0ac4a5204fac16ca7eaf39b9374164c346d6badc6914 flex-2.5.33.tar.bz2 695464
diff --git a/sys-devel/flex/files/flex-2.5.33-isatty.patch b/sys-devel/flex/files/flex-2.5.33-isatty.patch
new file mode 100644
index 000000000000..2231531569c7
--- /dev/null
+++ b/sys-devel/flex/files/flex-2.5.33-isatty.patch
@@ -0,0 +1,53 @@
+Declare the isatty prototype all the time ... otherwise packages like
+doxygen and ttmkfdir fail to build.
+
+http://bugs.gentoo.org/119598
+
+--- flex/scan.c
++++ flex/scan.c
+@@ -4179,9 +4179,19 @@
+
+ #ifndef YY_ALWAYS_INTERACTIVE
+ #ifndef YY_NEVER_INTERACTIVE
++#ifndef _UNISTD_H /* assume unistd.h has isatty() for us */
+-#ifndef __cplusplus
++#ifdef __cplusplus
++extern "C" {
++#endif
++#ifdef __THROW /* this is a gnuism */
++extern int isatty YY_PARAMS(( int )) __THROW;
++#else
+ extern int isatty YY_PARAMS(( int ));
++#endif
+-#endif /* __cplusplus */
++#ifdef __cplusplus
++}
++#endif
++#endif
+ #endif /* !YY_NEVER_INTERACTIVE */
+ #endif /* !YY_ALWAYS_INTERACTIVE */
+
+--- flex/skel.c
++++ flex/skel.c
+@@ -2183,9 +2183,19 @@
+ "[[",
+ " m4_ifdef( [[M4_YY_NEVER_INTERACTIVE]],,",
+ " [[",
++ "#ifndef _UNISTD_H /* assume unistd.h has isatty() for us */",
+- "#ifndef __cplusplus",
++ "#ifdef __cplusplus",
++ "extern \"C\" {",
++ "#endif",
++ "#ifdef __THROW /* this is a gnuism */",
++ "extern int isatty M4_YY_PARAMS( int ) __THROW;",
++ "#else",
+ "extern int isatty M4_YY_PARAMS( int );",
++ "#endif",
+- "#endif /* __cplusplus */",
++ "#ifdef __cplusplus",
++ "}",
++ "#endif",
++ "#endif",
+ " ]])",
+ "]])",
+ "%endif",
diff --git a/sys-devel/flex/flex-2.5.33.ebuild b/sys-devel/flex/flex-2.5.33.ebuild
new file mode 100644
index 000000000000..0abf0bcd1855
--- /dev/null
+++ b/sys-devel/flex/flex-2.5.33.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.33.ebuild,v 1.1 2006/02/24 02:03:55 vapier Exp $
+
+inherit eutils flag-o-matic
+
+#DEB_VER=36
+DESCRIPTION="GNU lexical analyser generator"
+HOMEPAGE="http://lex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lex/${P}.tar.bz2"
+# mirror://debian/pool/main/f/flex/${PN}_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="FLEX"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -n ${DEB_VER} ]] && epatch "${WORKDIR}"/${PN}_${PV}-${DEB_VER}.diff
+ epatch "${FILESDIR}"/${PN}-2.5.31-include.patch
+ epatch "${FILESDIR}"/${P}-isatty.patch #119598
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS ONEWS README* RoadMap THANKS TODO
+ dosym flex /usr/bin/lex
+}