summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-10-07 02:01:56 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-10-07 02:01:56 +0000
commit93631bde08f93f606575bd132bcef2422128c7ed (patch)
tree06d5137385f480f413ef2d6c5964fb0e926cf9c3 /sys-devel/gcc/gcc-3.2.3-r4.ebuild
parentRemoving comment about breakage... re-emerging glibc will setup symlinks prop... (diff)
downloadgentoo-2-93631bde08f93f606575bd132bcef2422128c7ed.tar.gz
gentoo-2-93631bde08f93f606575bd132bcef2422128c7ed.tar.bz2
gentoo-2-93631bde08f93f606575bd132bcef2422128c7ed.zip
Let eselect-compiler be an option instead of sys-devel/gcc-config in DEPEND.
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'sys-devel/gcc/gcc-3.2.3-r4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.2.3-r4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-3.2.3-r4.ebuild b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
index e3a31c3a6d31..066257a39330 100644
--- a/sys-devel/gcc/gcc-3.2.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.17 2005/05/24 04:28:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.18 2005/10/07 02:01:56 eradicator Exp $
inherit eutils flag-o-matic libtool versionator
@@ -111,19 +111,19 @@ SLOT="${GCC_BRANCH_VER}"
DEPEND=">=sys-libs/glibc-2.3.2-r3
mips? ( >=sys-devel/binutils-2.13.90.0.16 )
!mips? ( >=sys-devel/binutils-2.13.90.0.18 )
- >=sys-devel/gcc-config-1.3.1
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.1 )
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
# this glibc has the glibc guard symbols which are needed for the propolice functions to get moved to glibc
# out of the libgcc in this gcc release, however, the propolice patch itself is not defused by this removal
RDEPEND=">=sys-libs/glibc-2.3.2-r3
- >=sys-devel/gcc-config-1.3.1
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.1 )
>=sys-libs/zlib-1.1.4
>=sys-apps/texinfo-4.2-r4
!build? ( >=sys-libs/ncurses-5.2-r2 )"
-PDEPEND="sys-devel/gcc-config"
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
# Hack used to patch Makefiles to install into the build dir