summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-04 21:32:45 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-04 21:32:45 +0000
commitb0405da04c37de2c555f7677ef22384c30e4de3a (patch)
tree4248b6764bc1727741dd910e6f0e1fc9faedc53e /sys-devel/gdb-apple/gdb-apple-1346.ebuild
parentMake xorg-server optional on prefix (assume its available on the host, as it ... (diff)
downloadgentoo-2-b0405da04c37de2c555f7677ef22384c30e4de3a.tar.gz
gentoo-2-b0405da04c37de2c555f7677ef22384c30e4de3a.tar.bz2
gentoo-2-b0405da04c37de2c555f7677ef22384c30e4de3a.zip
Bump to version from Developer Tools 3.2.1
(Portage version: 2.2.00.15738-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-1346.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1346.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-1346.ebuild b/sys-devel/gdb-apple/gdb-apple-1346.ebuild
new file mode 100644
index 000000000000..37f5707b64df
--- /dev/null
+++ b/sys-devel/gdb-apple/gdb-apple-1346.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1346.ebuild,v 1.1 2010/03/04 21:32:45 grobian Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Apple branch of the GNU Debugger, Developer Tools 3.2.1"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.tar.gz"
+
+LICENSE="APSL-2 GPL-2"
+SLOT="0"
+
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ =dev-db/sqlite-3*"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/gdb-${PV}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-768-texinfo.patch
+ [[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1344-darwin8.patch
+
+ # for FSF gcc / gcc-apple:42
+ sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
+}
+
+src_compile() {
+ replace-flags -O? -O2
+ econf \
+ --disable-werror \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ local ED=${ED-${D}}
+
+ emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
+ rm -R "${D}"/nukeme || die
+ rm -Rf "${ED}"/usr/${CHOST} || die
+ mv "${ED}"/usr/bin/gdb ${ED}/
+ rm -f "${ED}"/usr/bin/*
+ mv "${ED}"/gdb "${ED}"/usr/bin/
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
+ ewarn "Due to increased security measures in 10.5 and up, gdb is"
+ ewarn "not able to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
+}