summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-19 02:39:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-19 02:39:00 +0000
commit1becd9a336aadae7b7ce0323af9bd64f348cf2a5 (patch)
treee3ca22a5206508b58bf5d5f436480c83da4a54b5 /sys-devel/kgcc64
parentRemove app-pda/syncekonnector from p.mask, removed from tree. bug #180883 (diff)
downloadgentoo-2-1becd9a336aadae7b7ce0323af9bd64f348cf2a5.tar.gz
gentoo-2-1becd9a336aadae7b7ce0323af9bd64f348cf2a5.tar.bz2
gentoo-2-1becd9a336aadae7b7ce0323af9bd64f348cf2a5.zip
Create the files on the fly to avoid file collision #228157 by Robin Johnson.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/ChangeLog8
-rw-r--r--sys-devel/kgcc64/files/wrapper2
-rw-r--r--sys-devel/kgcc64/kgcc64-3.4.6.ebuild16
-rw-r--r--sys-devel/kgcc64/kgcc64-4.1.2.ebuild16
-rw-r--r--sys-devel/kgcc64/kgcc64-4.2.4.ebuild14
-rw-r--r--sys-devel/kgcc64/kgcc64-4.3.1.ebuild14
6 files changed, 41 insertions, 29 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index 4d810412e7e5..4502d9a7b344 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/kgcc64
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.15 2008/06/18 09:58:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.16 2008/06/19 02:38:58 vapier Exp $
+
+ 19 Jun 2008; Mike Frysinger <vapier@gentoo.org> -files/wrapper,
+ kgcc64-3.4.6.ebuild, kgcc64-4.1.2.ebuild, kgcc64-4.2.4.ebuild,
+ kgcc64-4.3.1.ebuild:
+ Create the files on the fly to avoid file collision #228157 by Robin
+ Johnson.
*kgcc64-4.3.1 (18 Jun 2008)
*kgcc64-4.2.4 (18 Jun 2008)
diff --git a/sys-devel/kgcc64/files/wrapper b/sys-devel/kgcc64/files/wrapper
deleted file mode 100644
index 775f64b9d004..000000000000
--- a/sys-devel/kgcc64/files/wrapper
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec TARGET "$@"
diff --git a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
index 8d281dd700bb..a014734a5177 100644
--- a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
+++ b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.7 2007/01/18 12:45:02 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.8 2008/06/19 02:38:58 vapier Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -60,12 +60,14 @@ src_unpack() {
esac
}
-src_install() {
- toolchain_src_install
-
+pkg_postinst() {
+ cd "${ROOT}"/usr/bin
local x
for x in gcc cpp ; do
- newbin "${FILESDIR}"/wrapper ${CTARGET%%-*}-linux-${x}
- dosed "s:TARGET:${CTARGET}-${x}:" /usr/bin/${CTARGET%%-*}-linux-${x}
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
done
}
diff --git a/sys-devel/kgcc64/kgcc64-4.1.2.ebuild b/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
index 811d4d37d974..dd1153264510 100644
--- a/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.1.2.ebuild,v 1.5 2007/11/20 04:06:21 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.1.2.ebuild,v 1.6 2008/06/19 02:38:58 vapier Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -39,12 +39,14 @@ src_unpack() {
epatch "${GCC_FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
}
-src_install() {
- toolchain_src_install
-
+pkg_postinst() {
+ cd "${ROOT}"/usr/bin
local x
for x in gcc cpp ; do
- newbin "${FILESDIR}"/wrapper ${CTARGET%%-*}-linux-${x}
- dosed "s:TARGET:${CTARGET}-${x}:" /usr/bin/${CTARGET%%-*}-linux-${x}
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
done
}
diff --git a/sys-devel/kgcc64/kgcc64-4.2.4.ebuild b/sys-devel/kgcc64/kgcc64-4.2.4.ebuild
index 34fe03db92ef..304b319d3c9e 100644
--- a/sys-devel/kgcc64/kgcc64-4.2.4.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.2.4.ebuild,v 1.1 2008/06/18 09:58:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.2.4.ebuild,v 1.2 2008/06/19 02:38:58 vapier Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -32,12 +32,14 @@ DEPEND="hppa? ( sys-devel/binutils-hppa64 )
!sys-devel/gcc-powerpc64
!sys-devel/gcc-sparc64"
-src_install() {
- toolchain_src_install
-
+pkg_postinst() {
+ cd "${ROOT}"/usr/bin
local x
for x in gcc cpp ; do
- newbin "${FILESDIR}"/wrapper ${CTARGET%%-*}-linux-${x}
- dosed "s:TARGET:${CTARGET}-${x}:" /usr/bin/${CTARGET%%-*}-linux-${x}
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
done
}
diff --git a/sys-devel/kgcc64/kgcc64-4.3.1.ebuild b/sys-devel/kgcc64/kgcc64-4.3.1.ebuild
index 4e70c3d72216..f501ac675f9d 100644
--- a/sys-devel/kgcc64/kgcc64-4.3.1.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.3.1.ebuild,v 1.1 2008/06/18 09:58:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.3.1.ebuild,v 1.2 2008/06/19 02:38:58 vapier Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -32,12 +32,14 @@ DEPEND="hppa? ( sys-devel/binutils-hppa64 )
!sys-devel/gcc-powerpc64
!sys-devel/gcc-sparc64"
-src_install() {
- toolchain_src_install
-
+pkg_postinst() {
+ cd "${ROOT}"/usr/bin
local x
for x in gcc cpp ; do
- newbin "${FILESDIR}"/wrapper ${CTARGET%%-*}-linux-${x}
- dosed "s:TARGET:${CTARGET}-${x}:" /usr/bin/${CTARGET%%-*}-linux-${x}
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
done
}