summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-14 01:56:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-14 01:56:33 +0000
commitf607a9ea99c1da39f9cd501eefa87726f0ae105b (patch)
treeb6877991002863f66ab87c9d545c2813bf2853c7 /sys-devel/libperl/libperl-5.8.5.ebuild
parentbetter cross-compile patch (Manifest recommit) (diff)
downloadgentoo-2-f607a9ea99c1da39f9cd501eefa87726f0ae105b.tar.gz
gentoo-2-f607a9ea99c1da39f9cd501eefa87726f0ae105b.tar.bz2
gentoo-2-f607a9ea99c1da39f9cd501eefa87726f0ae105b.zip
Use toolchain-funcs to get $CC.
Diffstat (limited to 'sys-devel/libperl/libperl-5.8.5.ebuild')
-rw-r--r--sys-devel/libperl/libperl-5.8.5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/libperl/libperl-5.8.5.ebuild b/sys-devel/libperl/libperl-5.8.5.ebuild
index e63f8d127c62..67f39b4deed8 100644
--- a/sys-devel/libperl/libperl-5.8.5.ebuild
+++ b/sys-devel/libperl/libperl-5.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.11 2004/12/07 20:31:35 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.12 2004/12/14 01:56:33 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -54,7 +54,7 @@
IUSE="berkdb debug gdbm ithreads uclibc"
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
# Perl has problems compiling with -Os in your flags
use uclibc || replace-flags "-Os" "-O2"
@@ -197,7 +197,7 @@ src_compile() {
-Darchname="${myarch}" \
-Dcccdlflags='-fPIC' \
-Dccdlflags='-rdynamic' \
- -Dcc="${CC:-gcc}" \
+ -Dcc="$(tc-getCC)" \
-Dprefix='/usr' \
-Dvendorprefix='/usr' \
-Dsiteprefix='/usr' \