summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-04-20 18:08:52 +0000
committerFabian Groffen <grobian@gentoo.org>2011-04-20 18:08:52 +0000
commit1ba0508b516355522fb66cb1dc1fa763d3a59dea (patch)
tree5cee9c12e18cf2e2e1e515a14dd643d47ec2016a /sys-devel/llvm
parentDon't PROVIDE virtual/libc, bug 359001. (diff)
downloadgentoo-2-1ba0508b516355522fb66cb1dc1fa763d3a59dea.tar.gz
gentoo-2-1ba0508b516355522fb66cb1dc1fa763d3a59dea.tar.bz2
gentoo-2-1ba0508b516355522fb66cb1dc1fa763d3a59dea.zip
Fix install_name_tooling
(Portage version: 2.2.01.18252-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-2.9-r1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index b2ffeae494c6..bdd7c781eb70 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.39 2011/04/15 17:28:55 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.40 2011/04/20 18:08:52 grobian Exp $
+
+ 20 Apr 2011; Fabian Groffen <grobian@gentoo.org> llvm-2.9-r1.ebuild,
+ llvm-9999.ebuild:
+ Fix install_name_tooling
*llvm-2.8-r4 (15 Apr 2011)
diff --git a/sys-devel/llvm/llvm-2.9-r1.ebuild b/sys-devel/llvm/llvm-2.9-r1.ebuild
index aee267371c60..233c6f743895 100644
--- a/sys-devel/llvm/llvm-2.9-r1.ebuild
+++ b/sys-devel/llvm/llvm-2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r1.ebuild,v 1.1 2011/04/15 16:02:59 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r1.ebuild,v 1.2 2011/04/20 18:08:52 grobian Exp $
EAPI="3"
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -160,7 +160,7 @@ src_install() {
# Fix install_names on Darwin. The build system is too complicated
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{EnhancedDisassembly,LLVM-${PV},BugpointPasses,LLVMHello,LTO,profile_rt}.dylib ; do
+ for lib in lib{EnhancedDisassembly,LLVM-${PV},LTO}.dylib {BugpointPasses,LLVMHello,profile_rt}.dylib ; do
# libEnhancedDisassembly is Darwin10 only, so non-fatal
[[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
ebegin "fixing install_name of $lib"
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 1645b1759e54..b3235a6f3dad 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.10 2011/02/28 23:05:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.11 2011/04/20 18:08:52 grobian Exp $
EAPI="3"
inherit subversion eutils multilib toolchain-funcs
@@ -157,7 +157,7 @@ src_install() {
# Fix install_names on Darwin. The build system is too complicated
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{EnhancedDisassembly,LLVM-${PV},BugpointPasses,LLVMHello,LTO,profile_rt}.dylib ; do
+ for lib in lib{EnhancedDisassembly,LLVM-${PV},LTO}.dylib {BugpointPasses,LLVMHello,profile_rt}.dylib ; do
# libEnhancedDisassembly is Darwin10 only, so non-fatal
[[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
ebegin "fixing install_name of $lib"