summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-09-29 16:03:23 +0000
committerMichał Górny <mgorny@gentoo.org>2014-09-29 16:03:23 +0000
commit74a6cbbc19fe80b6cdb99cbd11851e94c55375af (patch)
tree6f0aaef88abf66bcf9a6eaff85d638dd94932b58 /sys-devel/llvm
parentDrop USE=g-sorcery mask for app-portage/layman (bug #524040). (diff)
downloadgentoo-2-74a6cbbc19fe80b6cdb99cbd11851e94c55375af.tar.gz
gentoo-2-74a6cbbc19fe80b6cdb99cbd11851e94c55375af.tar.bz2
gentoo-2-74a6cbbc19fe80b6cdb99cbd11851e94c55375af.zip
Block configparser-3.2 since it is known to break the build.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-3.5.0.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
3 files changed, 11 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index b2f38d5bb954..55a005eca118 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.207 2014/09/18 20:06:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.208 2014/09/29 16:03:23 mgorny Exp $
+
+ 29 Sep 2014; Michał Górny <mgorny@gentoo.org> llvm-3.5.0.ebuild,
+ llvm-9999.ebuild:
+ Block configparser-3.2 since it is known to break the build.
18 Sep 2014; Michał Górny <mgorny@gentoo.org>
files/clang-3.5-gentoo-runtime-gcc-detection-v3.patch:
diff --git a/sys-devel/llvm/llvm-3.5.0.ebuild b/sys-devel/llvm/llvm-3.5.0.ebuild
index c78f18926539..128900852630 100644
--- a/sys-devel/llvm/llvm-3.5.0.ebuild
+++ b/sys-devel/llvm/llvm-3.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.0.ebuild,v 1.2 2014/09/16 14:33:37 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.0.ebuild,v 1.3 2014/09/29 16:03:23 mgorny Exp $
EAPI=5
@@ -39,6 +39,7 @@ COMMON_DEPEND="
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
ocaml? ( dev-lang/ocaml:0= )"
+# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${COMMON_DEPEND}
app-arch/xz-utils
dev-lang/perl
@@ -52,6 +53,7 @@ DEPEND="${COMMON_DEPEND}
clang? ( xml? ( virtual/pkgconfig ) )
doc? ( dev-python/sphinx )
libffi? ( virtual/pkgconfig )
+ !<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
clang? ( !<=sys-devel/clang-${PV}-r99
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index b452ff42dc2d..7e79f4b03b2a 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.90 2014/09/07 11:12:00 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.91 2014/09/29 16:03:23 mgorny Exp $
EAPI=5
@@ -37,6 +37,7 @@ COMMON_DEPEND="
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:5=[${MULTILIB_USEDEP}] )
ocaml? ( dev-lang/ocaml:0= )"
+# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${COMMON_DEPEND}
dev-lang/perl
dev-python/sphinx
@@ -49,6 +50,7 @@ DEPEND="${COMMON_DEPEND}
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
clang? ( xml? ( virtual/pkgconfig ) )
libffi? ( virtual/pkgconfig )
+ !<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
clang? ( !<=sys-devel/clang-${PV}-r99 )