summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-10-07 15:16:59 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-10-07 15:16:59 +0000
commit8e999dc845c38a01c95383255f9e56c6c3b5fca3 (patch)
treef37bc7a32e069f4f915cef20ea356eb90c524a9c /sys-devel/llvm
parentRe-Keywording for ppc. (diff)
downloadgentoo-2-8e999dc845c38a01c95383255f9e56c6c3b5fca3.tar.gz
gentoo-2-8e999dc845c38a01c95383255f9e56c6c3b5fca3.tar.bz2
gentoo-2-8e999dc845c38a01c95383255f9e56c6c3b5fca3.zip
Add USE flag for ocaml bindings, complete doc patch to fix ocmal doc failure, see bug #186279
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog9
-rw-r--r--sys-devel/llvm/files/llvm-2.6-nodoctargz.patch45
-rw-r--r--sys-devel/llvm/files/llvm-2.6-nohtmltargz.patch17
-rw-r--r--sys-devel/llvm/llvm-2.6_pre2.ebuild12
4 files changed, 61 insertions, 22 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 2bf1786af2bd..d72298d6d911 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.2 2009/10/07 14:03:08 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.3 2009/10/07 15:16:59 voyageur Exp $
+
+ 07 Oct 2009; Bernard Cafarelli <voyageur@gentoo.org> llvm-2.6_pre2.ebuild,
+ +files/llvm-2.6-nodoctargz.patch, -files/llvm-2.6-nohtmltargz.patch:
+ Add USE flag for ocaml bindings, complete doc patch to fix ocmal doc
+ failure, see bug #186279
07 Oct 2009; Bernard Cafarelli <voyageur@gentoo.org> llvm-2.6_pre2.ebuild:
- Fix llvm-gcc location, work with
+ Fix llvm-gcc location, work with ${ROOT}
*llvm-2.6_pre2 (05 Oct 2009)
diff --git a/sys-devel/llvm/files/llvm-2.6-nodoctargz.patch b/sys-devel/llvm/files/llvm-2.6-nodoctargz.patch
new file mode 100644
index 000000000000..3d775e0bcce8
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-2.6-nodoctargz.patch
@@ -0,0 +1,45 @@
+--- docs/Makefile.orig 2009-10-07 17:08:03.000000000 +0200
++++ docs/Makefile 2009-10-07 17:08:47.000000000 +0200
+@@ -46,13 +46,12 @@
+ # 'make generated BUILD_FOR_WEBSITE=1'
+ generated:: doxygen ocamldoc
+
+-install-html: $(PROJ_OBJ_DIR)/html.tar.gz
++install-html:
+ $(Echo) Installing HTML documentation
+ $(Verb) $(MKDIR) $(PROJ_docsdir)/html
+ $(Verb) $(MKDIR) $(PROJ_docsdir)/html/img
+ $(Verb) $(DataInstall) $(HTML) $(PROJ_docsdir)/html
+ $(Verb) $(DataInstall) $(IMAGES) $(PROJ_docsdir)/html/img
+- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(PROJ_docsdir)
+
+ $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
+ $(Echo) Packaging HTML documentation
+@@ -64,12 +63,11 @@
+ install-doxygen: doxygen
+ $(Echo) Installing doxygen documentation
+ $(Verb) $(MKDIR) $(PROJ_docsdir)/html/doxygen
+- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(PROJ_docsdir)
+ $(Verb) cd $(PROJ_OBJ_DIR)/doxygen && \
+ $(FIND) . -type f -exec \
+ $(DataInstall) {} $(PROJ_docsdir)/html/doxygen \;
+
+-doxygen: regendoc $(PROJ_OBJ_DIR)/doxygen.tar.gz
++doxygen: regendoc
+
+ regendoc:
+ $(Echo) Building doxygen documentation
+@@ -95,12 +93,11 @@
+ install-ocamldoc: ocamldoc
+ $(Echo) Installing ocamldoc documentation
+ $(Verb) $(MKDIR) $(PROJ_docsdir)/ocamldoc/html
+- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/ocamldoc.tar.gz $(PROJ_docsdir)
+ $(Verb) cd $(PROJ_OBJ_DIR)/ocamldoc && \
+ $(FIND) . -type f -exec \
+ $(DataInstall) {} $(PROJ_docsdir)/ocamldoc/html \;
+
+-ocamldoc: regen-ocamldoc $(PROJ_OBJ_DIR)/ocamldoc.tar.gz
++ocamldoc: regen-ocamldoc
+
+ regen-ocamldoc:
+ $(Echo) Building ocamldoc documentation
diff --git a/sys-devel/llvm/files/llvm-2.6-nohtmltargz.patch b/sys-devel/llvm/files/llvm-2.6-nohtmltargz.patch
deleted file mode 100644
index 65209e6d0b95..000000000000
--- a/sys-devel/llvm/files/llvm-2.6-nohtmltargz.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- docs/Makefile.orig 2009-09-25 15:02:13.000000000 +0200
-+++ docs/Makefile 2009-09-25 15:02:47.000000000 +0200
-@@ -46,13 +46,12 @@
- # 'make generated BUILD_FOR_WEBSITE=1'
- generated:: doxygen ocamldoc
-
--install-html: $(PROJ_OBJ_DIR)/html.tar.gz
-+install-html:
- $(Echo) Installing HTML documentation
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html/img
- $(Verb) $(DataInstall) $(HTML) $(PROJ_docsdir)/html
- $(Verb) $(DataInstall) $(IMAGES) $(PROJ_docsdir)/html/img
-- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(PROJ_docsdir)
-
- $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
- $(Echo) Packaging HTML documentation
diff --git a/sys-devel/llvm/llvm-2.6_pre2.ebuild b/sys-devel/llvm/llvm-2.6_pre2.ebuild
index c97c73b6508d..0f1c1c76ad62 100644
--- a/sys-devel/llvm/llvm-2.6_pre2.ebuild
+++ b/sys-devel/llvm/llvm-2.6_pre2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.6_pre2.ebuild,v 1.2 2009/10/07 14:03:08 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.6_pre2.ebuild,v 1.3 2009/10/07 15:16:59 voyageur Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="http://llvm.org/prereleases/${PV/_pre*}/pre-release${PV/*_pre}/${PN}-${
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alltargets debug llvm-gcc test"
+IUSE="alltargets debug llvm-gcc ocaml test"
DEPEND="dev-lang/perl
>=sys-devel/make-3.79
@@ -24,6 +24,7 @@ DEPEND="dev-lang/perl
>=sys-devel/gcc-3.0
>=sys-devel/binutils-2.18
llvm-gcc? ( sys-devel/llvm-gcc )
+ ocaml? ( dev-lang/ocaml )
test? ( dev-util/dejagnu )"
RDEPEND="dev-lang/perl"
@@ -83,7 +84,7 @@ src_prepare() {
# Fix docs installation
sed -e '/^NO_INSTALL_MANS/s/$/$(DST_MAN_DIR)tblgen.1 $(DST_MAN_DIR)llvmgcc.1 $(DST_MAN_DIR)llvmgxx.1/' \
-i docs/CommandGuide/Makefile || die "manpages sed failed"
- epatch "${FILESDIR}"/${PN}-2.6-nohtmltargz.patch
+ epatch "${FILESDIR}"/${PN}-2.6-nodoctargz.patch
# Buggy test, http://llvm.org/bugs/show_bug.cgi?id=5047
rm test/DebugInfo/2009-01-15-dbg_declare.ll
@@ -134,6 +135,11 @@ src_configure() {
--with-llvmgcc=${LLVM_GCC_DRIVER} \
--with-llvmgxx=${LLVM_GPP_DRIVER}"
+ if use ocaml; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-bindings=ocaml"
+ else
+ CONF_FLAGS="${CONF_FLAGS} --enable-bindings=none"
+ fi
econf ${CONF_FLAGS} || die "econf failed"
}