summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2015-01-11 20:05:43 +0000
committerFabian Groffen <grobian@gentoo.org>2015-01-11 20:05:43 +0000
commitaffd5cf6806fd8a248320f418dafdbd4cf095bdb (patch)
tree9a40065f4266dca51e8dc24a20f31b540bb5e855 /sys-devel/llvm
parentStable for amd64 wrt bug #510600 (diff)
downloadgentoo-2-affd5cf6806fd8a248320f418dafdbd4cf095bdb.tar.gz
gentoo-2-affd5cf6806fd8a248320f418dafdbd4cf095bdb.tar.bz2
gentoo-2-affd5cf6806fd8a248320f418dafdbd4cf095bdb.zip
Add workaround for our older (Prefix/Darwin) toolchain
(Portage version: 2.2.14-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/files/clang-3.4-darwin_old_linker.patch15
-rw-r--r--sys-devel/llvm/llvm-3.4.2.ebuild5
3 files changed, 23 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 3d53c7d69e49..90a2cca9c4e2 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.217 2015/01/01 20:53:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.218 2015/01/11 20:05:43 grobian Exp $
+
+ 11 Jan 2015; Fabian Groffen <grobian@gentoo.org>
+ +files/clang-3.4-darwin_old_linker.patch, llvm-3.4.2.ebuild:
+ Add workaround for our older (Prefix/Darwin) toolchain
01 Jan 2015; Markus Meier <maekke@gentoo.org> llvm-3.5.0.ebuild:
arm stable, bug #530882
diff --git a/sys-devel/llvm/files/clang-3.4-darwin_old_linker.patch b/sys-devel/llvm/files/clang-3.4-darwin_old_linker.patch
new file mode 100644
index 000000000000..78a789532223
--- /dev/null
+++ b/sys-devel/llvm/files/clang-3.4-darwin_old_linker.patch
@@ -0,0 +1,15 @@
+The linker shipped with 10.8 knows to use _main as the entry point,
+however, we (Prefix) couldn't keep up with linkers, so we can't assume
+the linker is able to do this.
+
+--- tools/clang/lib/Driver/Tools.cpp
++++ tools/clang/lib/Driver/Tools.cpp
+@@ -5006,7 +5006,7 @@
+ CmdArgs.push_back("-lcrt1.o");
+ else if (getDarwinToolChain().isMacosxVersionLT(10, 6))
+ CmdArgs.push_back("-lcrt1.10.5.o");
+- else if (getDarwinToolChain().isMacosxVersionLT(10, 8))
++ else
+ CmdArgs.push_back("-lcrt1.10.6.o");
+
+ // darwin_crt2 spec is empty.
diff --git a/sys-devel/llvm/llvm-3.4.2.ebuild b/sys-devel/llvm/llvm-3.4.2.ebuild
index 6356305ffd8c..a994c39fa8d9 100644
--- a/sys-devel/llvm/llvm-3.4.2.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.5 2014/11/26 16:13:33 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.6 2015/01/11 20:05:43 grobian Exp $
EAPI=5
@@ -180,6 +180,7 @@ src_prepare() {
epatch "${FILESDIR}"/clang-3.4-gentoo-install.patch
epatch "${FILESDIR}"/clang-3.4-darwin_build_fix.patch
+ epatch "${FILESDIR}"/clang-3.4-darwin_old_linker.patch
epatch "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
fi