summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-23 02:26:21 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-23 02:26:21 +0000
commit912e0ed80b61e4cdeb8f23d9db05057e1c44da25 (patch)
tree56e8aa5c2e1360a43780ed7e1a3ed1b2d9c498a9 /sys-devel/m4
parentRespect $AR and $LD. (diff)
downloadgentoo-2-912e0ed80b61e4cdeb8f23d9db05057e1c44da25.tar.gz
gentoo-2-912e0ed80b61e4cdeb8f23d9db05057e1c44da25.tar.bz2
gentoo-2-912e0ed80b61e4cdeb8f23d9db05057e1c44da25.zip
Version bump.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/ChangeLog7
-rw-r--r--sys-devel/m4/m4-1.4.17.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-devel/m4/ChangeLog b/sys-devel/m4/ChangeLog
index 8f1f76d70a48..a69a244c3396 100644
--- a/sys-devel/m4/ChangeLog
+++ b/sys-devel/m4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/m4
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.163 2013/02/18 01:07:35 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.164 2013/09/23 02:26:21 radhermit Exp $
+
+*m4-1.4.17 (23 Sep 2013)
+
+ 23 Sep 2013; Tim Harder <radhermit@gentoo.org> +m4-1.4.17.ebuild:
+ Version bump.
18 Feb 2013; Zac Medico <zmedico@gentoo.org> m4-1.4.16.ebuild:
Add ~arm-linux keyword.
diff --git a/sys-devel/m4/m4-1.4.17.ebuild b/sys-devel/m4/m4-1.4.17.ebuild
new file mode 100644
index 000000000000..bc38a8ae41a9
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.17.ebuild,v 1.1 2013/09/23 02:26:21 radhermit Exp $
+
+EAPI="4"
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+# remember: cannot dep on autoconf since it needs us
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+src_configure() {
+ # Disable automagic dependency over libsigsegv; see bug #278026
+ export ac_cv_libsigsegv=no
+
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ econf --enable-changeword ${myconf}
+}
+
+src_test() {
+ [[ -d /none ]] && die "m4 tests will fail with /none/" #244396
+ emake check
+}
+
+src_install() {
+ default
+ # autoconf-2.60 for instance, first checks gm4, then m4. If we don't have
+ # gm4, it might find gm4 from outside the prefix on for instance Darwin
+ use prefix && dosym /usr/bin/m4 /usr/bin/gm4
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ rm -f "${ED}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+}