summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-07 09:39:40 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-07 09:39:40 +0000
commit384bb8038cbc489a5762d228632f71ec9326a332 (patch)
treee84cfbbba6a21333b111317e648d8b6d3480af3f /sys-devel/patch/patch-2.5.9-r1.ebuild
parentAdded to ~ppc (diff)
downloadgentoo-2-384bb8038cbc489a5762d228632f71ec9326a332.tar.gz
gentoo-2-384bb8038cbc489a5762d228632f71ec9326a332.tar.bz2
gentoo-2-384bb8038cbc489a5762d228632f71ec9326a332.zip
Install as gpatch on non-GNU systems #91560.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-devel/patch/patch-2.5.9-r1.ebuild')
-rw-r--r--sys-devel/patch/patch-2.5.9-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/patch/patch-2.5.9-r1.ebuild b/sys-devel/patch/patch-2.5.9-r1.ebuild
index e4abf55f99fd..c64a61cb5d0e 100644
--- a/sys-devel/patch/patch-2.5.9-r1.ebuild
+++ b/sys-devel/patch/patch-2.5.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9-r1.ebuild,v 1.6 2005/04/01 17:12:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9-r1.ebuild,v 1.7 2005/05/07 09:39:40 vapier Exp $
inherit flag-o-matic eutils
@@ -19,8 +19,8 @@ DEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-deb-cr.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-deb-cr.patch
}
src_compile() {
@@ -28,7 +28,9 @@ src_compile() {
append-flags -DLINUX -D_XOPEN_SOURCE=500
use static && append-ldflags -static
- ac_cv_sys_long_file_names=yes econf || die
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ ac_cv_sys_long_file_names=yes econf ${myconf} || die
emake || die "emake failed"
}