summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-26 18:29:41 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-26 18:29:41 +0000
commit14865cbbea1ff8d3a79a581ebd051c213624588b (patch)
treef8ff51b1996314f562cb634bd426c8e41e14b53b /sys-devel
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-14865cbbea1ff8d3a79a581ebd051c213624588b.tar.gz
gentoo-2-14865cbbea1ff8d3a79a581ebd051c213624588b.tar.bz2
gentoo-2-14865cbbea1ff8d3a79a581ebd051c213624588b.zip
<geoman-campus> that CFLAG information that was discussed on #gentoo-mips wasn't really correct ;)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-3.4.0.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index f5e82e7f009a..bc2f6076091d 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.216 2004/04/26 17:49:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.217 2004/04/26 18:29:41 lv Exp $
+
+ 26 Apr 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0.ebuild:
+ changed mips default arch settings so that march defaults to r4k and not
+ mips3. also removed default mtune setting. thanks for the heads up geoman
*gcc-3.4.0 (26 Apr 2004)
diff --git a/sys-devel/gcc/gcc-3.4.0.ebuild b/sys-devel/gcc/gcc-3.4.0.ebuild
index 7400924f80e3..bc4a44846cc3 100644
--- a/sys-devel/gcc/gcc-3.4.0.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.1 2004/04/26 17:49:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.2 2004/04/26 18:29:41 lv Exp $
IUSE="static nls bootstrap java build X multilib gcj hardened f77 objc uclibc"
@@ -389,7 +389,7 @@ src_compile() {
use ppc64 && myconf="${myconf} --with-cpu=g5 --with-arch=g5"
use s390 && myconf="${myconf} --with-cpu=z990 --with-arch=g5"
use x86 && myconf="${myconf} --with-cpu=pentium4 --with-arch=i586"
- use mips && myconf="${myconf} --with-cpu=mips4 --with-arch=mips3"
+ use mips && myconf="${myconf} --with-arch=r4k"
use ppc && myconf="${myconf} --with-cpu=g4 --with-arch=g3"
# In general gcc does not like optimization, and add -O2 where